gdk-pixbuf-query-loaders-32bit-2.34.0-16.1.x86_64.rpm


Advertisement

Description

gdk-pixbuf-query-loaders-32bit - An image loading library - Utility to create loaders cache

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name gdk-pixbuf-query-loaders-32bit
Package version 2.34.0
Package release 16.1
Package architecture x86_64
Package type rpm
Installed size 9.58 KB
Download size 26.72 KB
Official Mirror ftp.gwdg.de
gdk-pixbuf is an image loading library that can be extended by loadable
modules for new image formats. It is used by toolkits such as GTK+ or
Clutter.
This package contains the utility to create the cache file needed for
loadable modules.

Alternatives

Package Version Architecture Repository
gdk-pixbuf-query-loaders-32bit-2.34.0-19.1.x86_64.rpm 2.34.0 x86_64 openSUSE Update Oss
gdk-pixbuf-query-loaders-32bit-2.34.0-13.1.x86_64.rpm 2.34.0 x86_64 openSUSE Update Oss
gdk-pixbuf-query-loaders-32bit-2.34.0-10.1.x86_64.rpm 2.34.0 x86_64 openSUSE Update Oss
gdk-pixbuf-query-loaders-32bit-2.34.0-8.4.x86_64.rpm 2.34.0 x86_64 openSUSE Oss
gdk-pixbuf-query-loaders-32bit - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libglib-2.0.so.0 -
libgmodule-2.0.so.0 -
libgobject-2.0.so.0 -
libpthread.so.0 -

Provides

Name Value
gdk-pixbuf-query-loaders-32bit = 2.34.0-16.1
gdk-pixbuf-query-loaders-32bit(x86-32) = 2.34.0-16.1

Download

Type URL
Binary Package gdk-pixbuf-query-loaders-32bit-2.34.0-16.1.x86_64.rpm
Source Package gdk-pixbuf-2.34.0-16.1.src.rpm

Install Howto

Install gdk-pixbuf-query-loaders-32bit rpm package:

# zypper install gdk-pixbuf-query-loaders-32bit

Files

Path
/usr/bin/gdk-pixbuf-query-loaders

Changelog

2018-05-16 - mgorse@suse.com
- Fix the build: revert to original version of
gdk-pixbuf-cve-2017-6312-ico-integer-overflow.patch
2018-01-08 - mgorse@suse.com
- Add gdk-pixbuf-bgo785973-large-gif.patch: fail quickly when image
dimentions are too big (boo#1074462 CVE-2017-1000422).
- Add gdk-pixbuf-gif-negative-array-indexes.patch and
gdk-pixbuf-gif-uninitialized-variable.patch: protect against
access to negative array indexes (BGO#778584).
- Replace gdk-pixbuf-cve-2017-6312-ico-integer-overflow.patch,
gdk-pixbuf-cve-2017-6313-icns-integer-underflow.patch, and
gdk-pixbuf-cve-2017-6314-tiff-infinite-loop.patch with upstream
versions.
2017-11-24 - federico@suse.com
- Added gdk-pixbuf-toplevel-overflow-checks.patch - This adds overflow
checks when creating pixbuf structures in general.
- gdk-pixbuf-bsc1053417-bmp-updates.patch - Fixes bsc#1053417, for
arithmetic overflow in the BMP loader.  Also adds support for BMPv3
with bitmasks.
2017-07-27 - hpj@suse.com
- Update gdk-pixbuf-cve-2017-2862-jpeg-channels.patch to fix
grayscale JPEG breakage (bsc#1049877, bgo#785171).
2017-07-16 - hpj@suse.com
- Add fixes for crashes, taken from upstream git
(CVE-2017-2862 bsc#1048289 bgo#784866,
CVE-2017-2870 bsc#1048544 bgo#780269,
CVE-2017-6312 bsc#1027026 bgo#779012,
CVE-2017-6313 bsc#1027024 bgo#779016,
CVE-2017-6314 bsc#1027025 bgo#779020):
gdk-pixbuf-cve-2017-2862-jpeg-channels.patch,
gdk-pixbuf-cve-2017-2870-tiff-mul-overflow.patch,
gdk-pixbuf-cve-2017-6312-ico-integer-overflow.patch,
gdk-pixbuf-cve-2017-6313-icns-integer-underflow.patch,
gdk-pixbuf-cve-2017-6314-tiff-infinite-loop.patch.
2016-12-12 - mstaudt@suse.com
- u_contrib-gdk-pixbuf-xlib-Fix-rgb888amsb.patch
Fix RGBA conversion for big endian X11 environments.
Fixes (boo#929462), (bsc#1010497)
2016-08-30 - mgorse@suse.com
- Add fixes for some crashes, taken from upstream git (bsc#988745
bsc#991450 CVE-2016-6352):
gdk-pixbuf-bgo768688-bmp-overflow.patch
gdk-pixbuf-bgo768484-ico-set-errors.patch
gdk-pixbuf-bgo769738-bmp-overflow.patch
gdk-pixbuf-bgo769170-ico-headers.patch
2016-04-13 - idonmez@suse.com
- Update to GNOME 3.20  Fate#318572
- Remove upstreamed patches: gdk-pixbuf-bgo758991.patch,
0001-pixops-Don-t-overflow-variables-when-shifting-them.patch,
gdk-pixbuf-bgo747605.patch, gdk-pixbuf-bgo752297.patch,
0001-ico-Protect-against-overflow.patch,
0001-pixops-use-gint64-in-more-places-to-avoid-overflow-w.patch,
gdk-pixbuf-bsc960155-divide-by-zero.patch,
gdk-pixbuf-bsc948790-tga-dos.patch and
gdk-pixbuf-2-32-overflow-fixes.patch.
2016-03-25 - zaitor@opensuse.org
- Update to version 2.34.0:
+ Don't force no static builds on Win32 (bgo#760369).
+ Updated translations.
2016-01-04 - mgorse@suse.com
- Add gdk-pixbuf-bsc960155-divide-by-zero.patch -- fix a possible
divide by zero (bsc#960155).
- Add gdk-pixbuf-2-32-overflow-fixes.patch,
0001-ico-Protect-against-overflow.patch,
gdk-pixbuf-bgo747605.patch, and gdk-pixbuf-bgo758991.patch:
fix various overflows (bsc#958963 CVE-2015-7552).

See Also

Package Description
geoclue2-2.4.3-5.3.1.x86_64.rpm GeoLocation Framework
geoclue2-devel-2.4.3-5.3.1.x86_64.rpm GeoLocation Framework -- Development files
geotiff-1.4.2-6.3.1.x86_64.rpm Library to handle georeferenced TIFF
geotiff-devel-1.4.2-6.3.1.x86_64.rpm GeoTIFF header files
ghostscript-9.15-14.3.1.x86_64.rpm The Ghostscript interpreter for PostScript and PDF
ghostscript-9.15-14.6.1.x86_64.rpm The Ghostscript interpreter for PostScript and PDF
ghostscript-9.25-14.9.1.x86_64.rpm The Ghostscript interpreter for PostScript and PDF
ghostscript-devel-9.15-14.3.1.x86_64.rpm Development files for Ghostscript
ghostscript-devel-9.15-14.6.1.x86_64.rpm Development files for Ghostscript
ghostscript-devel-9.25-14.9.1.x86_64.rpm Development files for Ghostscript
ghostscript-mini-9.15-14.3.1.x86_64.rpm Minimal Ghostscript for minimal build requirements
ghostscript-mini-9.15-14.6.1.x86_64.rpm Minimal Ghostscript for minimal build requirements
ghostscript-mini-9.25-14.9.1.x86_64.rpm Minimal Ghostscript for minimal build requirements
ghostscript-mini-devel-9.15-14.3.1.x86_64.rpm Development files for Minimal Ghostscript
ghostscript-mini-devel-9.15-14.6.1.x86_64.rpm Development files for Minimal Ghostscript
Advertisement
Advertisement