corosync-2.3.6-10.1.x86_64.rpm


Advertisement

Description

corosync - The Corosync Cluster Engine and Application Programming Interfaces

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Update Oss all
Package name corosync
Package version 2.3.6
Package release 10.1
Package architecture x86_64
Package type rpm
Installed size 441.81 KB
Download size 169.89 KB
Official Mirror ftp.gwdg.de
This package contains the Corosync Cluster Engine Executive, several default
APIs and libraries, default configuration files, and an init script.

Alternatives

Package Version Architecture Repository
corosync-2.3.6-7.1.x86_64.rpm 2.3.6 x86_64 openSUSE Update Oss
corosync-2.3.6-5.1.x86_64.rpm 2.3.6 x86_64 openSUSE Oss
corosync - - -

Requires

Name Value
/bin/bash -
/usr/sbin/useradd -
libc.so.6(GLIBC_2.14)(64bit) -
libcfg.so.6()(64bit) -
libcfg.so.6(COROSYNC_CFG_0.82)(64bit) -
libcmap.so.4()(64bit) -
libcmap.so.4(COROSYNC_CMAP_1.0)(64bit) -
libcorosync4 = 2.3.6
libcorosync_common.so.4()(64bit) -
libcpg.so.4()(64bit) -
libcpg.so.4(COROSYNC_CPG_1.0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libqb.so.0()(64bit) -
libquorum.so.5()(64bit) -
libquorum.so.5(COROSYNC_QUORUM_1.0)(64bit) -
libtotem_pg.so.5()(64bit) -
libvotequorum.so.7()(64bit) -
libvotequorum.so.7(COROSYNC_VOTEQUORUM_1.0)(64bit) -
systemd -

Provides

Name Value
config(corosync) = 2.3.6-10.1
corosync = 2.3.6-10.1
corosync(x86-64) = 2.3.6-10.1

Conflicts

Name Value
openais <= 0.89
openais-devel <= 0.89

Download

Type URL
Binary Package corosync-2.3.6-10.1.x86_64.rpm
Source Package corosync-2.3.6-10.1.src.rpm

Install Howto

Install corosync rpm package:

# zypper install corosync

Files

Path
/etc/corosync/
/etc/corosync/uidgid.d/
/usr/bin/corosync-blackbox
/usr/lib/corosync/upgrade.sh
/usr/lib/systemd/system/corosync-notifyd.service
/usr/lib/systemd/system/corosync.service
/usr/lib/tmpfiles.d/corosync-notifyd
/usr/sbin/corosync
/usr/sbin/corosync-cfgtool
/usr/sbin/corosync-cmapctl
/usr/sbin/corosync-cpgtool
/usr/sbin/corosync-keygen
/usr/sbin/corosync-notifyd
/usr/sbin/corosync-quorumtool
/usr/sbin/rccorosync
/usr/share/corosync/corosync
/usr/share/corosync/corosync-notifyd
/usr/share/doc/packages/corosync/LICENSE
/usr/share/doc/packages/corosync/SECURITY
/usr/share/doc/packages/corosync/corosync.conf.example
/usr/share/doc/packages/corosync/corosync.conf.example.udpu
/usr/share/man/man5/corosync.conf.5.gz
/usr/share/man/man5/votequorum.5.gz
/usr/share/man/man8/cmap_keys.8.gz
/usr/share/man/man8/corosync-blackbox.8.gz
/usr/share/man/man8/corosync-cfgtool.8.gz
/usr/share/man/man8/corosync-cmapctl.8.gz
/usr/share/man/man8/corosync-cpgtool.8.gz
/usr/share/man/man8/corosync-keygen.8.gz
/usr/share/man/man8/corosync-notifyd.8.gz
/usr/share/man/man8/corosync-quorumtool.8.gz
/usr/share/man/man8/corosync.8.gz
/usr/share/man/man8/corosync_overview.8.gz
/var/lib/corosync/
/var/log/cluster/

Changelog

2018-04-16 - bliu@suse.com
- VUL-0: CVE-2018-1084: corosync: Integer overflow in totemcrypto:authenticate_nss_2_3() (bsc#1089346)
Added: 0010-bsc#1089346-corosync-Integer-overflow-in-totemcrypto.patch
2018-03-08 - bliu@suse.com
- [Build 489.1] Corosync is not working after upgrade from sle11sp4-ha to sle12/sle15(bsc#1083561)
The configuration files are different from SLE11 and SLE12/SLE15, this patch will
remove uncompitable contents.
Added: 0009-bsc#1083561-upgrade-from-1-x-y.patch
2017-11-06 - bliu@suse.com
- coroparse: uidgid with empty uid or gid results into add uid 0(bsc#1066585)
Added: 0008-do-not-convert-empty-uid-gid-to-0.patch
2017-09-28 - bliu@suse.com
- wrong "service_del_postun corosync.service"(bsc#1060767)
Modified: corosync.spec, remove service_del_postun in postun of corosync
2017-08-01 - bliu@suse.com
- L3: corosync: assert(sender_node != NULL) fails after tearing down a network interface(bsc#1032634)
Added: 0007-fix-ifdown-udp.patch
2017-07-10 - bliu@suse.com
- some errors in spec file(bsc#1047862)
Modified:corosync.spec
1) as in SP3 GA, there are both %bcond_ and %define, to make it uniform, change %define to %bcond_without
2) change service_del_postun to service_del_preun, since service_del_postun is not a right macro
2017-06-07 - bliu@suse.com
-  some Fixes from upstream(bsc#1043045)
Added: 0004-main-Display-reason-why-cluster-cannot-be-formed.patch
0005-votequorum-Report-errors-from-votequorum_exec_send_r.patch
0006-coroapi-Use-size_t-for-private_data_size.patch
2017-05-16 - bliu@suse.com
- totemrrp: Fix situation when all rings are faulty(bsc#1039215)
Added: 0003-totemrrp-Fix-situation-when-all-rings-are-faulty.patch
2017-05-09 - bliu@suse.com
- calling mlockall before corosync_tty_detach is noop when corosync is executed as a daemon(bsc#1038147)
Added: 0002-Main-call-mlock-after-fork.patch
2017-04-10 - bliu@suse.com
- [upgrade] Changing the pre-upgrade role for node failed(bsc#1030437)
Added: 0001-totemconfig.c-Fixed-Evicted-from-CPG-membership.patch
removed: 0001-totemip.c-Fixed-Evicted-from-CPG-membership.patch

See Also

Package Description
corosync-testagents-2.3.6-10.1.x86_64.rpm The Corosync Cluster Engine Test Agents
corosync-testagents-2.3.6-7.1.x86_64.rpm The Corosync Cluster Engine Test Agents
cpp48-4.8.5-26.2.x86_64.rpm The GCC Preprocessor
cpp48-4.8.5-29.1.x86_64.rpm The GCC Preprocessor
cpp48-4.8.5-32.1.x86_64.rpm The GCC Preprocessor
cpp48-4.8.5-35.1.x86_64.rpm The GCC Preprocessor
cpp7-7.2.1+r253435-3.2.x86_64.rpm The GCC Preprocessor
cpp7-7.3.1+r258313-6.1.x86_64.rpm The GCC Preprocessor
cpp7-7.3.1+r258812-10.1.x86_64.rpm The GCC Preprocessor
cppunit-devel-1.14.0-8.3.x86_64.rpm Include Files and Libraries mandatory for Development
cppunit-devel-32bit-1.14.0-8.3.x86_64.rpm Include Files and Libraries mandatory for Development
cppunit-devel-doc-1.14.0-8.3.noarch.rpm Documentation for the cppunit API
cpupower-4.10-4.1.x86_64.rpm Tools to determine and set CPU Power related Settings
cpupower-bench-4.10-4.1.x86_64.rpm CPU frequency micro benchmark
cpupower-devel-4.10-4.1.x86_64.rpm Include files and C-libraries
Advertisement
Advertisement