rtmidi-devel-3.0.0-3.1.x86_64.rpm


Advertisement

Description

rtmidi-devel - Development files for rtmidi

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Multimedia Libs all
Package name rtmidi-devel
Package version 3.0.0
Package release 3.1
Package architecture x86_64
Package type rpm
Installed size 40.13 KB
Download size 13.05 KB
Official Mirror ftp.gwdg.de
C++ library for realtime MIDI input/ouput.
This package contains header files and libraries needed to develop
application that use rtmidi.

Alternatives

Package Version Architecture Repository
rtmidi-devel-3.0.0-4.1.x86_64.rpm 3.0.0 x86_64 Packman
rtmidi-devel-3.0.0-4.1.armv7hl.rpm 3.0.0 armv7hl Packman
rtmidi-devel-3.0.0-4.1.aarch64.rpm 3.0.0 aarch64 Packman
rtmidi-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
librtmidi4 = 3.0.0
pkgconfig(alsa) -
pkgconfig(jack) -

Provides

Name Value
pkgconfig(rtmidi) = 3.0.0
rtmidi-devel = 3.0.0-3.1
rtmidi-devel(x86-64) = 3.0.0-3.1

Download

Type URL
Binary Package rtmidi-devel-3.0.0-3.1.x86_64.rpm
Source Package rtmidi-3.0.0-3.1.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Leap_42.3/ opensuse-multimedia-libs
  2. Install rtmidi-devel rpm package:
    # zypper install rtmidi-devel

Files

Path
/usr/bin/rtmidi-config
/usr/include/rtmidi/RtMidi.h
/usr/include/rtmidi/rtmidi_c.h
/usr/lib64/librtmidi.so
/usr/lib64/pkgconfig/rtmidi.pc
/usr/share/licenses/rtmidi-devel/README.md

Changelog

2018-04-19 - aloisio@gmx.com
- Update to version 3.0.0
* The version number has been bumped to 3.0.0 because of the
past API change concerning the renaming of the RtError class
to RtMidiError. Changes in this release include:
+ see git history for complete list of changes
+ new sendMessage() function that does not use std::vector
+ various std::string updates, including use of UTF8 for port
names
+ fixes for the MIDI queue
+ various build system updates and code efficiencies
- Spec cleanup
2017-05-25 - avvissu@yandex.by
- Change path to headers
- Drop _service file
2017-01-30 - edogawa@aon.at
- Update to version 2.1.1
* update pkgconfig.patch
2015-06-24 - avvissu@yandex.ru
- Initial release

See Also

Package Description
rubberband-cli-1.8.1-25.16.x86_64.rpm Command line interface for librubberband
rubberband-ladspa-1.8.1-25.16.x86_64.rpm LADSPA plugin for librubberband
rubberband-ladspa-32bit-1.8.1-25.16.x86_64.rpm LADSPA plugin for librubberband
rubberband-vamp-1.8.1-25.16.x86_64.rpm Vamp plugins for librubberband
rubberband-vamp-32bit-1.8.1-25.16.x86_64.rpm Vamp plugins for librubberband
sapplay-1.51.1-660.9.x86_64.rpm Plays Atari XL/XE tune files (files with .sap extension)
sbiload-0.4.0-109.2.x86_64.rpm OPL2/3 FM instrument loader
schroedinger-devel-1.0.11-27.11.x86_64.rpm Library for decoding and encoding video in the Dirac format
schroedinger-doc-1.0.11-27.11.x86_64.rpm Library for decoding and encoding video in the Dirac format
serd-devel-0.28.0-17.2.x86_64.rpm Development files for libserd
serdi-0.28.0-17.2.x86_64.rpm Read and write RDF syntax
shairplay-20160101-1.5.x86_64.rpm Apple airplay and raop protocol server
shairplay-devel-20160101-1.5.x86_64.rpm Development files for shairplay
sndio-1.0.1-10.11.x86_64.rpm Small audio and MIDI framework
sndio-devel-1.0.1-10.11.x86_64.rpm Library Developer Files for sndio
Advertisement
Advertisement