libopus-devel-1.2.1-40.6.x86_64.rpm


Advertisement

Description

libopus-devel - Opus Audio Codec Library Development Environment

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Multimedia Libs all
Package name libopus-devel
Package version 1.2.1
Package release 40.6
Package architecture x86_64
Package type rpm
Installed size 137.12 KB
Download size 31.34 KB
Official Mirror ftp.gwdg.de
The Opus codec is designed for interactive speech and audio transmission over
the Internet. It is designed by the IETF Codec Working Group and incorporates
technology from Skype's SILK codec and Xiph.Org's CELT codec.

Alternatives

Package Version Architecture Repository
libopus-devel-1.1-9.3.x86_64.rpm 1.1 x86_64 openSUSE Oss
libopus-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libopus0 = 1.2.1

Provides

Name Value
libopus-devel = 1.2.1-40.6
libopus-devel(x86-64) = 1.2.1-40.6
pkgconfig(opus) = 1.2.1

Download

Type URL
Binary Package libopus-devel-1.2.1-40.6.x86_64.rpm
Source Package opus-1.2.1-40.6.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Leap_42.3/ opensuse-multimedia-libs
  2. Install libopus-devel rpm package:
    # zypper install libopus-devel

Files

Path
/usr/include/opus/opus.h
/usr/include/opus/opus_custom.h
/usr/include/opus/opus_defines.h
/usr/include/opus/opus_multistream.h
/usr/include/opus/opus_types.h
/usr/lib64/libopus.so
/usr/lib64/pkgconfig/opus.pc
/usr/share/aclocal/opus.m4

Changelog

2017-06-26 - zaitor@opensuse.org
- Update to version 1.2.1:
+ This fixes an issue where the encoder can misdetect that the
signal is SWB instead of FB, lowpassing the signal. This patch
makes the encoder much more careful about doing that.
2017-06-21 - mpluskal@suse.com
- Cleanup with spec-cleaner
2017-06-20 - aloisio@gmx.com
- Update to version 1.2
+ Speech quality improvements especially in the 12-20 kbit/s
range
+ Improved VBR encoding for hybrid mode
+ More aggressive use of wider speech bandwidth, including
fullband speech starting at 14 kbit/s
+ Music quality improvements in the 32-48 kb/s range
+ Generic and SSE CELT optimizations
+ Support for directly encoding packets up to 120 ms
+ DTX support for CELT mode
+ SILK CBR improvements
+ Support for all of the fixes in
draft-ietf-codec-opus-update-06 (the mono downmix and the
folding fixes need --enable-update-draft)
+ Many bug fixes, including integer wrap-arounds discovered
through fuzzing (no security implications)
- Removed static package
2017-05-28 - idonmez@suse.com
- Update to version 1.1.5
+ This release backports the surround encoder bug fix from
1.2-beta branch
2017-03-11 - jengelh@inai.de
- Rename %soname to %sover to better reflect its use.
RPM group fix.
2017-02-26 - zaitor@opensuse.org
- Update to version 1.1.4 (CVE-2017-0381):
+ A specially-crafted Opus packet could cause an integer
wrap-around in the SILK LSF stabilization code. This would
cause an out-of-bounds read 256 bytes before a constant table.
- Drop opus-NLSF-not-negative.patch: Fixed upstream.
2017-01-16 - zaitor@opensuse.org
- Fix CVE-2017-0381 (boo#1020102), opus: remote code execution
vulnerability in silk/NLSF_stabilize.c.
- Add opus-NLSF-not-negative.patch: Ensure that NLSF cannot be
negative when computing a min distance between them.
2016-08-13 - zaitor@opensuse.org
- Update to version 1.1.3:
+ Neon optimizations improving performance on ARMv7 and ARMv8 by
up to 15%.
+ Fixes some issues with 16-bit platforms (e.g. TI C55x).
+ Fixes to comfort noise generation (CNG).
+ Documenting that PLC packets can also be 2 bytes.
+ Includes experimental ambisonics work (--enable-ambisonics).
- Stop passing conditional --enable/disable-intrinsics, it's
enabled by default now.
- Not adding the new --enable-ambisonics to configure, it's still
experimental.
2016-01-27 - olaf@aepfle.de
- Disable SSE2 in SLE_11 due to code or compiler bugs.
2016-01-26 - mpluskal@suse.com
- Enable tests during package build
- Cleanup spec file with spec-cleaner
- Drop not needed libtool dependency for build

See Also

Package Description
libopus0-1.2.1-40.6.x86_64.rpm Opus Audio Codec Library
libopus0-32bit-1.2.1-40.6.x86_64.rpm Opus Audio Codec Library
libopusenc-devel-0.1.1-1.5.x86_64.rpm Development package for libopusenc
libopusenc0-0.1.1-1.5.x86_64.rpm Library package for libopusenc
libopusfile0-0.10-14.2.x86_64.rpm A high-level API for decoding and seeking within .opus files
liborc-0_4-0-0.4.28-78.4.x86_64.rpm The Oil Runtime Compiler Library
libout123-0-1.25.10-31.1.x86_64.rpm MPEG audio decoder library
libout123-0-32bit-1.25.10-31.1.x86_64.rpm MPEG audio decoder library
libpcaudio0-1.0-6.2.x86_64.rpm Cross platform audio library
libportaudio2-190600_20161030-299.1.x86_64.rpm Portable Real-Time Audio Library
libportaudio2-32bit-190600_20161030-299.1.x86_64.rpm Portable Real-Time Audio Library
libportaudiocpp0-190600_20161030-299.1.x86_64.rpm Portable Real-Time Audio Library
libportmidi0-217-12.16.x86_64.rpm Real-time MIDI input/output audio library
libpostproc-devel-4.0.1-211.1.x86_64.rpm Development files for the FFmpeg post-processing library
libpostproc53-2.8.14-5.1.x86_64.rpm FFmpeg post-processing library
Advertisement
Advertisement