libchromaprint-devel-1.4.3-41.8.x86_64.rpm


Advertisement

Description

libchromaprint-devel - Audio Fingerprinting Library

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE Multimedia Libs all
Package name libchromaprint-devel
Package version 1.4.3
Package release 41.8
Package architecture x86_64
Package type rpm
Installed size 13.06 KB
Download size 11.05 KB
Official Mirror ftp.gwdg.de
Chromaprint is the core component of the Acoustid project. It's a client-side
library that implements a custom algorithm for extracting fingerprints from any
audio source.

Alternatives

Package Version Architecture Repository
libchromaprint-devel-1.3.1-3.5.x86_64.rpm 1.3.1 x86_64 openSUSE Oss
libchromaprint-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
fftw3-devel -
libchromaprint1 = 1.4.3
libtag-devel -

Provides

Name Value
libchromaprint-devel = 1.4.3-41.8
libchromaprint-devel(x86-64) = 1.4.3-41.8
pkgconfig(libchromaprint) = 1.4.3

Download

Type URL
Binary Package libchromaprint-devel-1.4.3-41.8.x86_64.rpm
Source Package chromaprint-1.4.3-41.8.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Leap_42.3/ opensuse-multimedia-libs
  2. Install libchromaprint-devel rpm package:
    # zypper install libchromaprint-devel

Files

Path
/usr/include/chromaprint.h
/usr/lib64/libchromaprint.so
/usr/lib64/pkgconfig/libchromaprint.pc

Changelog

2018-01-24 - avindra@opensuse.org
- Update to 1.4.3:
* Allow one packet to have decoding error
* Print output even if there is a decoding error, exit with error
code 3 instead of 2 in such case
* Add new option -ignore-errors to change the error code 3 to 0
* Add new option -algorithm NUM
* Periodically flush output when working on a stream
- drop chromaprint-ffmpeg-pkgconfig.patch
* fixed upstream
- Switch to https for URL
- Source moved to github
- cleanup with spec-cleaner
2017-07-25 - jengelh@inai.de
- Fix RPM groups.
2017-07-17 - alarrosa@suse.com
- Update to 1.4.2:
* Fixed invalid memory access when decoding base64-encoded fingerprints.
* Removed unnecessary library dependencies libchromaprint to avoid
circular dependency problems with FFmpeg.
- Rebase chromaprint-ffmpeg-pkgconfig.patch
- Drop chromaprint-ffmpeg-API.patch which isn't needed anymore.
- Update to 1.4.1:
* Restored the -v/-version parameter for fpcalc that got accidentally
removed in 1.4.
* Fixed processing of some short audio files. They were ignored in 1.4.
* The DURATION field in the default output of fpcalc is now printed as an
integer again.
* Added missing version number to libchromaprint.pc.
* Linux fpcalc builds are now fully static.
- Update to 1.4.0:
* Fully streaming audio processing without any post-processing step
for the fingerprint generation.
* Many performance optimizations. Especially when processing long streams,
operations should be faster and use less memory.
* C++11 compiler is now required for building the library.
* The public C API now uses standard fixed-size int types from stdint.h
(breaks backwards compatibility).
* All code written for the library is now distributed under the MIT license.
* Kiss FFT is now included with the library and automatically used if
no other FFT library is found.
* Added support for using the FFTW3F version of FFTW3.
* Boost is no longer used.
- Update to 1.3.2:
* Fixed crash on an invalid audio file that FFmpeg could not decode.
2017-02-01 - adam.majer@suse.de
- use individual libboost-*-devel packages instead of boost-devel
2016-07-28 - olaf@aepfle.de
- Remove unused Provides libchromaprint-with-ffmpeg
2016-04-01 - olaf@aepfle.de
- Restore support for libswresample/libavresample (bsc#973555)
- Remove usage of deprecated API
chromaprint-ffmpeg-API.patch
2016-02-15 - jengelh@inai.de
- Update to new upstream release 1.3.1
* Support for ffmpeg 3.x
* You can use use "-length 0" in fpcalc to get the full fingerprint
* New function chromaprint_get_fingerprint_hash for calculating
SimHash from the fingerprint data
2015-12-18 - tchvatal@suse.com
- Remove needless conditional for the libdir which is in the macro
2015-12-09 - olaf@aepfle.de
- Use pkg-config to detect ffmpeg in cmake
chromaprint-ffmpeg-pkgconfig.patch
- Add bcond_without to use ffmpeg unconditional
2015-12-08 - olaf@aepfle.de
- Remove broken libffmpeg requires in devel pkg

See Also

Package Description
libchromaprint1-1.4.3-41.8.x86_64.rpm Audio Fingerprinting Library
libchromaprint1-32bit-1.4.3-41.8.x86_64.rpm Audio Fingerprinting Library
libclastfm-devel-0.5-13.9.x86_64.rpm Unofficial C-API for the Last.fm Web Service
libclastfm0-0.5-13.9.x86_64.rpm Unofficial C-API for the Last.fm Web Service
libconfig++-devel-1.7-35.1.x86_64.rpm C++ bindings development files for libconfig
libconfig++11-1.7-35.1.x86_64.rpm C++ API of libconfig
libconfig-devel-1.7-35.1.x86_64.rpm C bindings development files for libconfig
libconfig11-1.7-35.1.x86_64.rpm C API of libconfig
libcue-devel-2.2.0-22.2.x86_64.rpm Development files for libcue, a CUE sheet parsing library
libcue2-2.2.0-22.2.x86_64.rpm CUE sheet parsing library
libdbus-c++-1-1-0.9.1+git20170322-42.14.x86_64.rpm C++ Interface for D-Bus
libdbus-c++-1-1-32bit-0.9.1+git20170322-42.14.x86_64.rpm C++ Interface for D-Bus
libdbus-c++-devel-0.9.1+git20170322-42.14.x86_64.rpm Development files for libdbus-c++
libdbus-c++-glib-1-1-0.9.1+git20170322-42.14.x86_64.rpm Glib integration for libdbus-c++
libdbus-c++-glib-1-1-32bit-0.9.1+git20170322-42.14.x86_64.rpm Glib integration for libdbus-c++
Advertisement
Advertisement