servletapi5-5.0.18-557.1.noarch.rpm


Advertisement

Description

servletapi5 - Java servlet and JSP implementation classes

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE JAVA all
Package name servletapi5
Package version 5.0.18
Package release 557.1
Package architecture noarch
Package type rpm
Installed size 139.96 KB
Download size 123.51 KB
Official Mirror ftp.gwdg.de
This subproject contains the source code for the implementation classes
of the Java Servlet and JSP APIs (packages javax.servlet).

Alternatives

Package Version Architecture Repository
servletapi5-5.0.18-288.4.noarch.rpm 5.0.18 noarch openSUSE Oss
servletapi5 - - -

Requires

Name Value
update-alternatives -

Provides

Name Value
servlet = 5.0.18
servlet24 = 5.0.18
servlet5 = 5.0.18
servletapi5 = 5.0.18-557.1

Download

Type URL
Binary Package servletapi5-5.0.18-557.1.noarch.rpm
Source Package servletapi5-5.0.18-557.1.src.rpm

Install Howto

  1. Add the openSUSE JAVA repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Java:/packages/openSUSE_Leap_42.3/ opensuse-java
  2. Install servletapi5 rpm package:
    # zypper install servletapi5

Files

Path
/etc/alternatives/servlet.jar
/usr/share/doc/packages/servletapi5/LICENSE
/usr/share/java/jspapi-5.0.18.jar
/usr/share/java/jspapi.jar
/usr/share/java/servlet.jar
/usr/share/java/servletapi5-5.0.18.jar
/usr/share/java/servletapi5.jar

Changelog

2017-10-03 - fstrba@suse.com
- Removed patch:
* java150_build.patch
- Don't hardcode the source and target levels, specify them on
command line instead
- Don't build with java-1_5_0-gcj-compat, since it is bound to go
- Specify source and target level 1.6 in order to allow building
with jdk9
2014-07-21 - tchvatal@suse.com
- Cleanup with spec-cleaner.
- Fix update-alternatives code
2013-08-23 - mvyskocil@suse.com
- drop javadoc package
2010-11-08 - mvyskocil@suse.cz
- Build ignore xml-commons-1.3-jaxp-apis
2008-07-28 - coolo@suse.de
- yet another package to ignore
2008-07-28 - coolo@suse.de
- build without openjdk to avoid cycle
2006-09-25 - dbornkessel@suse.de
- java150 fixes: added target="1.4" and source="1.4"
2006-01-25 - mls@suse.de
- converted neededforbuild to BuildRequires
2005-09-28 - dmueller@suse.de
- add norootforbuild
2004-09-16 - skh@suse.de
- Fix prerequires of javadoc subpackage

See Also

Package Description
skinlf-6.7-16.4.noarch.rpm Allows developers to write skinnable application using the Swing toolkit
skinlf-demo-6.7-16.4.noarch.rpm Examples for skinlf
skinlf-javadoc-6.7-16.4.noarch.rpm Javadoc for skinlf
slf4j-1.7.12-48.1.noarch.rpm Simple Logging Facade for Java
slf4j-javadoc-1.7.12-48.1.noarch.rpm Javadoc for slf4j
slf4j-manual-1.7.12-48.1.noarch.rpm Documents for slf4j
stringtemplate-3.2.1-2.27.noarch.rpm A Java template engine
stringtemplate-javadoc-3.2.1-2.27.noarch.rpm API documentation for stringtemplate
swing-layout-1.0.3-58.5.noarch.rpm Natural layout for Swing panels
swing-layout-javadoc-1.0.3-58.5.noarch.rpm Natural layout for Swing panels
swing-worker-1.2-35.5.noarch.rpm UI updates support for long running tasks
swing-worker-demo-1.2-35.5.noarch.rpm UI updates support for long running tasks
swing-worker-javadoc-1.2-35.5.noarch.rpm UI updates support for long running tasks
swingx-0.9.4-42.5.noarch.rpm A collection of Swing components
swingx-javadoc-0.9.4-42.5.noarch.rpm Javadoc for swingx
Advertisement
Advertisement