apache-portlet-1_0-api-1.0-215.1.noarch.rpm


Advertisement

Description

apache-portlet-1_0-api - Portlet API 1.0 from Jetspeed2

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE JAVA all
Package name apache-portlet-1_0-api
Package version 1.0
Package release 215.1
Package architecture noarch
Package type rpm
Installed size 30.43 KB
Download size 22.37 KB
Official Mirror ftp.gwdg.de
Java Standard Portlet API accoring to JSR-168, from Jetspeed-2 .

Alternatives

Package Version Architecture Repository
apache-portlet-1_0-api-1.0-112.25.noarch.rpm 1.0 noarch openSUSE Oss
apache-portlet-1_0-api - - -

Requires

Name Value
java-headless -
javapackages-tools -

Provides

Name Value
apache-portlet-1_0-api = 1.0-215.1
mvn(javax.portlet:portlet-api) = 1.0
mvn(javax.portlet:portlet-api:pom:) = 1.0
portlet = 1.0
portlet-1.0-api = 1.0

Download

Type URL
Binary Package apache-portlet-1_0-api-1.0-215.1.noarch.rpm
Source Package apache-portlet-1_0-api-1.0-215.1.src.rpm

Install Howto

  1. Add the openSUSE JAVA repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Java:/packages/openSUSE_Leap_42.3/ opensuse-java
  2. Install apache-portlet-1_0-api rpm package:
    # zypper install apache-portlet-1_0-api

Files

Path
/usr/share/doc/packages/apache-portlet-1_0-api-1.0/LICENSE.TXT
/usr/share/java/apache-portlet-1_0-api-1.0.jar
/usr/share/java/apache-portlet-1_0-api.jar
/usr/share/java/portlet-1.0-api-1.0.jar
/usr/share/java/portlet-1.0-api.jar
/usr/share/java/portlet-api-1.0.jar
/usr/share/java/portlet-api.jar
/usr/share/maven-metadata/apache-portlet-1_0-api.xml
/usr/share/maven-poms/JPP-portlet-api.pom

Changelog

2018-05-15 - fstrba@suse.com
- Build with source and target 8 to prepare for a possible removal
of 1.6 compatibility
- Run fdupes on documentation
2017-09-15 - fstrba@suse.com
- Fix build with jdk9: specify java source and target level 1.6
2017-05-19 - pcervinka@suse.com
- New build dependency: javapackages-local
- Removed maven conditions
- Spec file cleaned
- Fixed javadoc Requires
2015-03-18 - tchvatal@suse.com
- Fix build with new javapackages-tools
2014-07-08 - tchvatal@suse.com
- Do not depend on ant-nodeps.
2013-09-09 - tchvatal@suse.com
- Move from jpackage-utils to javapackage-tools
2013-08-27 - mvyskocil@suse.com
- use new add_maven_depmap
2011-09-17 - jengelh@medozas.de
- Remove redundant tags/sections from specfile
2008-08-25 - mvyskocil@suse.cz
- target=1.5 source=1.5
- remove a gcj build support
- fixed some rpmlint warnings
2008-03-13 - mvyskocil@suse.cz
- Initial package build of version 1.0 (jpackage 1.7)

See Also

Package Description
apache-portlet-1_0-api-javadoc-1.0-215.1.noarch.rpm Portlet API 1.0 from Jetspeed2
appframework-1.03-45.17.noarch.rpm Swing Application Framework
appframework-1.03-49.1.noarch.rpm Swing Application Framework
appframework-javadoc-1.03-45.17.noarch.rpm Swing Application Framework
appframework-javadoc-1.03-49.1.noarch.rpm Swing Application Framework
args4j-2.0.9-16.3.noarch.rpm Java commandline parser
args4j-javadoc-2.0.9-16.3.noarch.rpm Javadoc for Java commandline parser
asm-1.5.3-568.18.noarch.rpm Java bytecode manipulation framework
asm-1.5.3-578.1.noarch.rpm Java bytecode manipulation framework
asm-javadoc-1.5.3-568.18.noarch.rpm Java bytecode manipulation framework (documentation)
asm-javadoc-1.5.3-578.1.noarch.rpm Java bytecode manipulation framework (documentation)
asm2-2.2.3-31.1.noarch.rpm Java bytecode manipulation framework
asm2-2.2.3-34.1.noarch.rpm Java bytecode manipulation framework
asm2-examples-2.2.3-31.1.noarch.rpm Java bytecode manipulation framework
asm2-examples-2.2.3-34.1.noarch.rpm Java bytecode manipulation framework
Advertisement
Advertisement