ant-junit-1.9.10-141.1.noarch.rpm


Advertisement

Description

ant-junit - Optional junit tasks for ant

Property Value
Distribution openSUSE Leap 42.3
Repository openSUSE JAVA all
Package name ant-junit
Package version 1.9.10
Package release 141.1
Package architecture noarch
Package type rpm
Installed size 202.80 KB
Download size 143.91 KB
Official Mirror ftp.gwdg.de
Apache Ant is a Java-based build tool.
This package contains optional JUnit tasks for Apache Ant.

Alternatives

Package Version Architecture Repository
ant-junit-1.9.4-11.3.noarch.rpm 1.9.4 noarch openSUSE Oss
ant-junit - - -

Requires

Name Value
ant = 1.9.10
java-headless -
javapackages-tools -
junit4 -

Provides

Name Value
ant-junit = 1.9.10-141.1
config(ant-junit) = 1.9.10-141.1
mvn(org.apache.ant:ant-junit) = 1.9.10
mvn(org.apache.ant:ant-junit4) = 1.9.10
mvn(org.apache.ant:ant-junit4:pom:) = 1.9.10
mvn(org.apache.ant:ant-junit:pom:) = 1.9.10

Download

Type URL
Binary Package ant-junit-1.9.10-141.1.noarch.rpm
Source Package ant-junit-1.9.10-141.1.src.rpm

Install Howto

  1. Add the openSUSE JAVA repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Java:/packages/openSUSE_Leap_42.3/ opensuse-java
  2. Install ant-junit rpm package:
    # zypper install ant-junit

Files

Path
/etc/ant.d/junit
/etc/ant.d/junit4
/usr/share/ant/etc/junit-frames.xsl
/usr/share/ant/etc/junit-noframes.xsl
/usr/share/ant/lib/ant-junit.jar
/usr/share/ant/lib/ant-junit4.jar
/usr/share/java/ant/ant-junit.jar
/usr/share/java/ant/ant-junit4.jar
/usr/share/maven-metadata/ant-junit.xml
/usr/share/maven-poms/JPP.ant-ant-junit.pom
/usr/share/maven-poms/JPP.ant-ant-junit4.pom

Changelog

2018-05-15 - fstrba@suse.com
- Build with source and target 8 to prepare for a possible removal
of 1.6 compatibility
- Modified patch:
* apache-ant-1.9.9-sourcetarget.patch
- Build with source/target 8
2018-02-23 - ecsos@opensuse.org
- fix build error for Leap 42.3
2018-02-22 - tchvatal@suse.com
- Add patch to run scripts with python3 if applicable bsc#1082202:
* ant-python3.patch
2018-02-22 - tchvatal@suse.com
- Update to 1.9.10:
* Various fixes for java10
* Small fixes all around
- Remove merged patch reproducible.patch
2017-10-28 - jengelh@inai.de
- Simply use find -delete over xargs.
- Make description neutral.
2017-10-24 - bwiedemann@suse.com
- Add reproducible-build-date.patch to allow to have fixed build dates
to make other packages build more reproducibly
2017-10-04 - fstrba@suse.com
- Remove dependency on java-1_5_0-gcj-compat-devel and build even
the bootstrap package with java source and target 1.6
2017-09-29 - fstrba@suse.com
- Don't condition the maven defines on release version, but on
_maven_repository being defined
2017-09-14 - fstrba@suse.com
- Allow bootstrapping with something else then
java-1_5_0-gcj-compat, but still require
java-1_5_0-gcj-compat-devel
- Added patch:
* apache-ant-bootstrap.patch
- Add -sourcepath option to fix build breakages with Eclipse
Compiler for Java(tm)
2017-09-06 - fstrba@suse.com
- Added patch:
* apache-ant-1.9.9-sourcetarget.patch
+ Change java source and target versions to 1.6 to allow build
with jdk9
- For non-boostrap builds require java-devel >= 1.6

See Also

Package Description
ant-manual-1.9.10-141.1.noarch.rpm Manual for ant
ant-scripts-1.9.10-137.1.noarch.rpm Additional scripts for ant
ant-scripts-1.9.10-141.1.noarch.rpm Additional scripts for ant
ant-swing-1.9.10-137.1.noarch.rpm Optional swing tasks for ant
ant-swing-1.9.10-141.1.noarch.rpm Optional swing tasks for ant
ant-testutil-1.9.10-141.1.noarch.rpm Test utility classes for ant
antlr-2.7.7-164.1.i586.rpm Another Tool for Language Recognition
antlr-2.7.7-170.1.x86_64.rpm Another Tool for Language Recognition
antlr-bootstrap-2.7.7-164.1.noarch.rpm Antlr for bootstrapping purposes
antlr-bootstrap-2.7.7-170.1.noarch.rpm Antlr for bootstrapping purposes
antlr-devel-2.7.7-164.1.i586.rpm ANother Tool for Language Recognition (c++ runtime)
antlr-devel-2.7.7-170.1.x86_64.rpm ANother Tool for Language Recognition (c++ runtime)
antlr-java-2.7.7-164.1.noarch.rpm ANother Tool for Language Recognition (Manual)
antlr-java-2.7.7-170.1.noarch.rpm ANother Tool for Language Recognition (Manual)
antlr-manual-2.7.7-164.1.noarch.rpm ANother Tool for Language Recognition (Manual)
Advertisement
Advertisement