nvidia-computeG02-304.137-13.1.x86_64.rpm


Advertisement

Description

nvidia-computeG02 - NVIDIA driver for computing with GPGPU

Property Value
Distribution openSUSE Leap 42.3
Repository nVidia drivers all
Package name nvidia-computeG02
Package version 304.137
Package release 13.1
Package architecture x86_64
Package type rpm
Installed size 36.63 MB
Download size 11.88 MB
Official Mirror http.download.nvidia.com
NVIDIA driver for computing with GPGPUs using CUDA or OpenCL.

Alternatives

Package Version Architecture Repository
nvidia-computeG02 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.2.5)(64bit) -
libdl.so.2 -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6 -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0 -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.2.5)(64bit) -
libz.so.1 -
libz.so.1()(64bit) -
nvidia-gfxG02-kmp = 304.137

Provides

Name Value
config(nvidia-computeG02) = 304.137-13.1
libOpenCL.so.1 -
libOpenCL.so.1()(64bit) -
libcuda.so.1 -
libcuda.so.1()(64bit) -
libnvidia-ml.so.1 -
libnvidia-ml.so.1()(64bit) -
libnvidia-opencl.so.1 -
libnvidia-opencl.so.1()(64bit) -
nvidia-computeG02 = 304.137-13.1
nvidia-computeG02(x86-64) = 304.137-13.1
x11-video-nvidiaG02:/usr/lib/libcuda.so -

Conflicts

Name Value
libOpenCL1 -

Download

Type URL
Binary Package nvidia-computeG02-304.137-13.1.x86_64.rpm
Source Package x11-video-nvidiaG02-304.137-13.1.nosrc.rpm

Install Howto

  1. Add the nVidia drivers repository:
    # zypper addrepo http://http.download.nvidia.com/opensuse/leap/42.3/ nvidia
  2. Install nvidia-computeG02 rpm package:
    # zypper install nvidia-computeG02

Files

Path
/etc/OpenCL/
/etc/OpenCL/vendors/nvidia.icd
/usr/bin/nvidia-smi
/usr/lib/libOpenCL.so
/usr/lib/libOpenCL.so.1
/usr/lib/libOpenCL.so.1.0.0
/usr/lib/libcuda.so
/usr/lib/libcuda.so.1
/usr/lib/libcuda.so.304.137
/usr/lib/libnvidia-ml.so.1
/usr/lib/libnvidia-ml.so.304.137
/usr/lib/libnvidia-opencl.so.1
/usr/lib/libnvidia-opencl.so.304.137
/usr/lib64/libOpenCL.so
/usr/lib64/libOpenCL.so.1
/usr/lib64/libOpenCL.so.1.0.0
/usr/lib64/libcuda.so
/usr/lib64/libcuda.so.1
/usr/lib64/libcuda.so.304.137
/usr/lib64/libnvidia-ml.so
/usr/lib64/libnvidia-ml.so.1
/usr/lib64/libnvidia-ml.so.304.137
/usr/lib64/libnvidia-opencl.so.1
/usr/lib64/libnvidia-opencl.so.304.137

Changelog

2018-05-17 - sndirsch@suse.com
- workaround build failure of kernelrelease target on sle12-sp4
(boo#1093333)
2017-09-30 - sndirsch@suse.com
- update to driver release 304.137
* Improved compatibility with recent Linux kernels.
* Updated nvidia-installer to label kernel modules with SELinux
file type 'modules_object_t'. Some system SELinux policies only
permit loading of kernel modules with this SELinux file type.
* Removed support for checking for and downloading updated driver
packages and precompiled kernel interfaces from nvidia-installer.
This functionality was limited to unencrypted ftp and http, and
was implemented using code that is no longer actively maintained.
- adjusted NVIDIA_kernel-define_linux/NVIDIA_kernel-define_linux-x86.diff
- obsoletes u_gcc4.8.5.patch, nvidia-304-4.10.patch
- fixed %kver macro
- some more specfile cleanup
2017-08-18 - sndirsch@suse.com
- kmp-post.sh/kmp-post-old.sh
* make sure kernel module gets generated into initrd during
kmp installation
- x11-video-nvidiaG04.spec
* %post: only recreate initrd if needed (possibly on sle11)
- nvidia-gfxG04.spec
* use trigger scripts for Leap 42.3/sle12-sp3; trigger
in addition to %post on uninstall of drm-kmp (boo#1053934)
- preamble
* readded provides to drm-kmp on Leap 42.3/sle12-sp3, since
otherwise NVIDIA KMP isn't autoselected :-(
2017-06-19 - sndirsch@suse.com
- computeG02: added conflicts to libOpenCL1 (boo#1044948)
2017-05-25 - sndirsch@suse.com
- removed/disabled Xwrapper for TW/sle15, since you can't rely any
longer on a displaymanager running as root (bsc#1040699)
2017-05-19 - sndirsch@suse.com
- fixed dependancies so nvidia-computeG02 can now be installed
without x11-video-nvidiaG02 package
* moved 32bit libnvidia-ml.so.* and libnvidia-opencl.so* from
x11-video-nvidiaG02 to nvidia-computeG02 package
2017-04-24 - toddrme2178@gmail.com
- Various spec file and rpmlint cleanups:
* Improve descriptions
* Add URL
* Remove spurious obsoletes (higher versions don't necessarily
replace lower ones due to dropped graphics card support).
* Add %config tags
* Update year
* Use versioning provides to avoid self-obsoletes.
2017-02-16 - sndirsch@suse.com
- update to driver release 304.135
* Added support for X.Org xserver ABI 23 (xorg-server 1.19)
* Fixed a bug that allowed nvidia-installer to attempt loading
kernel modules that were built against non-running kernels.
2016-12-13 - sndirsch@suse.com
- update to driver release 304.134
* Added support for X.Org xserver ABI 23 (xorg-server 1.19)
* Fixed a bug that allowed nvidia-installer to attempt loading kernel
modules that were built against non-running kernels.
2016-09-26 - sndirsch@suse.com
- update to driver release 304.132
* Added /var/log/dmesg to the list of paths which are searched by
nvidia-bug-report.sh for kernel messages.
* Fixed a bug that caused kernel panics when using the NVIDIA driver
on v4.5 and newer Linux kernels built with CONFIG_DEBUG_VM_PGFLAGS.
* Updated nvidia-installer to support ncurses version 6.x.

See Also

Package Description
nvidia-computeG03-340.107-9.1.x86_64.rpm NVIDIA driver for computing with GPGPU
nvidia-computeG04-390.87-10.1.x86_64.rpm NVIDIA driver for computing with GPGPU
nvidia-gfxG02-kmp-default-304.137_k4.4.76_1-13.1.x86_64.rpm NVIDIA graphics driver kernel module for GeForce 6xxx and newer GPUs
nvidia-gfxG03-kmp-default-340.107_k4.4.76_1-9.1.x86_64.rpm NVIDIA graphics driver kernel module for GeForce 8xxx and newer GPUs
nvidia-gfxG04-kmp-default-390.87_k4.4.76_1-10.1.x86_64.rpm NVIDIA graphics driver kernel module for GeForce 400 series and newer
nvidia-glG03-340.107-9.1.x86_64.rpm NVIDIA GL libraries for OpenGL acceleration
nvidia-glG04-390.87-10.1.x86_64.rpm NVIDIA OpenGL libraries for OpenGL acceleration
nvidia-uvm-gfxG03-kmp-default-340.107_k4.4.76_1-9.1.x86_64.rpm NVIDIA Unified Memory kernel module
x11-video-nvidiaG02-304.137-13.1.x86_64.rpm NVIDIA graphics driver for GeForce 6xxx and newer GPUs
x11-video-nvidiaG03-340.107-9.1.x86_64.rpm NVIDIA graphics driver for GeForce 8xxx and newer GPUs
x11-video-nvidiaG04-390.87-10.1.x86_64.rpm NVIDIA graphics driver for GeForce 400 series and newer
Advertisement
Advertisement