concurrent-1.3.4-572.1.noarch.rpm


Advertisement

Description

concurrent - Utility Classes for Concurrent Java Programming

Property Value
Distribution openSUSE Leap 42.3
Repository JAVA all
Package name concurrent
Package version 1.3.4
Package release 572.1
Package architecture noarch
Package type rpm
Installed size 318.04 KB
Download size 283.60 KB
Official Mirror widehat.opensuse.org
This package provides standardized, efficient versions of utility
classes commonly encountered in concurrent Java programming. This code
consists of implementations of ideas that have been around for ages and
is merely intended to save you the trouble of coding them. Discussions
of the rationale and application of several of these classes can be
found in the second edition of Concurrent Programming in Java.

Alternatives

Package Version Architecture Repository
concurrent-1.3.4-296.25.noarch.rpm 1.3.4 noarch openSUSE Oss
concurrent - - -

Provides

Name Value
concurrent = 1.3.4-572.1

Obsoletes

Name Value
concurrent-javadoc -

Download

Type URL
Binary Package concurrent-1.3.4-572.1.noarch.rpm
Source Package concurrent-1.3.4-572.1.src.rpm

Install Howto

  1. Add the JAVA repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/Java:/packages/openSUSE_Leap_42.3/ java
  2. Install concurrent rpm package:
    # zypper install concurrent

Files

Path
/usr/share/java/concurrent-1.3.4.jar
/usr/share/java/concurrent.jar

Changelog

2018-05-16 - fstrba@suse.com
- Build with source and target 8 to prepare for a possible removal
of 1.6 compatibility
2017-09-14 - fstrba@suse.com
- Allow building with other JDK then gcj
- Build with java source and target level 1.6 in order to allow
building with jdk9
- Added patch:
* concurrent-jdk8.patch
+ Fix a name clash that exist from jdk8
2017-05-20 - tchvatal@suse.com
- Fix building with java properly, use gcj as anything newer fails
to compile this
2006-09-25 - skh@suse.de
- don't use icecream
- use source="1.4" and target="1.4" for build with java 1.5
2006-01-25 - mls@suse.de
- converted neededforbuild to BuildRequires
2005-07-27 - jsmeix@suse.de
- Adjustments in the spec file.
2005-07-19 - jsmeix@suse.de
- Current version 1.3.4 from JPackage.org
2005-02-18 - skh@suse.de
- update to version 1.3.4
- don't use icecream
2004-09-16 - skh@suse.de
- Fix prerequires of javadoc subpackage
2004-09-06 - skh@suse.de
- Initial package created with version 1.3.2 (JPackage 1.5)

See Also

Package Description
cpptasks-1.0b5-16.27.noarch.rpm Compile and link task
cpptasks-javadoc-1.0b5-16.27.noarch.rpm Javadoc for cpptasks
cunit-devel-2.1.3-15.1.x86_64.rpm CUnit development files
cunit-doc-2.1.3-15.1.x86_64.rpm CUnit documentation
derby-10.13.1.1-4.5.noarch.rpm Embeddable Database Engine Written in Java
derby-javadoc-10.13.1.1-4.5.noarch.rpm Embeddable Database Engine Written in Java
dom2-core-tests-0.0.1-50.1.noarch.rpm DOM Conformance Test Suite
dom4j-1.6.1-57.44.noarch.rpm JarJar of dom4j for JBoss
dom4j-demo-1.6.1-57.44.noarch.rpm XML, XPath and XSLT library for Java
dom4j-javadoc-1.6.1-57.44.noarch.rpm XML, XPath and XSLT library for Java
dom4j-manual-1.6.1-57.44.noarch.rpm JarJar of dom4j for JBoss
dtdinst-20151127-17.6.noarch.rpm XML DTD to XML instance format converter
ecj-4.4.0-301.6.noarch.rpm Eclipse Compiler for Java
eclipse-swt-4.333-34.1.x86_64.rpm SWT Library for GTK2
fastjar-0.98-37.1.x86_64.rpm Java package archiver
Advertisement
Advertisement