thedarkmod-2.06-2.2.x86_64.rpm


Advertisement

Description

thedarkmod - Steampunk Stealth Game

Property Value
Distribution openSUSE Leap 42.3
Repository Games all
Package name thedarkmod
Package version 2.06
Package release 2.2
Package architecture x86_64
Package type rpm
Installed size 10.56 MB
Download size 3.51 MB
Official Mirror widehat.opensuse.org
A first-person stealth game. In it you play a hooded figure
slinking through the shadows of a gothic steampunk city,
hunting priceless valuables while avoiding the swords and
arrows of those hired to stop you.

Alternatives

Package Version Architecture Repository
thedarkmod - - -

Requires

Name Value
libIL.so.1()(64bit) -
libX11.so.6()(64bit) -
libXext.so.6()(64bit) -
libXxf86vm.so.1()(64bit) -
libavcodec.so.57()(64bit) -
libavcodec.so.57(LIBAVCODEC_57)(64bit) -
libavformat.so.57()(64bit) -
libavformat.so.57(LIBAVFORMAT_57)(64bit) -
libavutil.so.55()(64bit) -
libavutil.so.55(LIBAVUTIL_55)(64bit) -
libboost_filesystem.so.1.61.0()(64bit) -
libboost_program_options.so.1.61.0()(64bit) -
libboost_system.so.1.61.0()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libcurl.so.4()(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libjpeg.so.8()(64bit) -
libjpeg.so.8(LIBJPEG_8.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.15)(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libopenal.so.1()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.1)(64bit) -
libstdc++.so.6(CXXABI_1.3.5)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.17)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.19)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.22)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libswresample.so.2()(64bit) -
libswresample.so.2(LIBSWRESAMPLE_2)(64bit) -
libswscale.so.4()(64bit) -
libswscale.so.4(LIBSWSCALE_4)(64bit) -
libz.so.1()(64bit) -
libz.so.1(ZLIB_1.2.0)(64bit) -
xdg-utils -

Provides

Name Value
application() -
application(thedarkmod.desktop) -
thedarkmod = 2.06-2.2
thedarkmod(x86-64) = 2.06-2.2

Download

Type URL
Binary Package thedarkmod-2.06-2.2.x86_64.rpm
Source Package thedarkmod-2.06-2.2.src.rpm

Install Howto

  1. Add the Games repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/games/openSUSE_Leap_42.3/ games
  2. Install thedarkmod rpm package:
    # zypper install thedarkmod

Files

Path
/usr/bin/thedarkmod
/usr/lib/thedarkmod/tdm_update.linux
/usr/lib/thedarkmod/thedarkmod.bin
/usr/share/applications/thedarkmod.desktop
/usr/share/doc/packages/thedarkmod/README.txt
/usr/share/icons/hicolor/64x64/apps/thedarkmod.png
/usr/share/licenses/thedarkmod/COPYING.txt
/usr/share/licenses/thedarkmod/LICENSE.txt

Changelog

2018-06-30 - stefan.bruens@rwth-aachen.de
- Fix build error, avoid code triggering undefined behaviour:
0001-Use-offsetof-instead-of-homegrown-macro-triggering-u.patch
- Use gcc-7 instead of gcc-5 on Leap 42.x
2018-06-29 - stefan.bruens@rwth-aachen.de
- BuildRequire p7zip-full instead of p7zip on TW, 7za was moved
from p7zip to the new package, breaking backwards compatibility.
2018-06-02 - stefan.bruens@rwth-aachen.de
- Drop Requires: opengl-games-utils, a defunct wrapper from the past
- Use arch agnostic name (thedarkmod.bin) for the binary, to use
a common name in the wrapper script
- Disallow the updater to replace itself
- Fix wrapper script
2018-05-29 - stefan.bruens@rwth-aachen.de
- update to version 2.06
* Native 64-bit support
* Better Visuals: e.g. Soft Shadows option
* Better Sound: EFX audio allows to enable EAX effects with openal-soft
* Better Menus
* New Assets: e.g. new architectural modules
* Better Mission Intros: Video codec support using FFMPEG
* Better Gameplay: Food will always restore some health when eaten.
Guards can now sleep and wake up while seated.
* Better Performance: Experimental multi-core support. Uncapped FPS option.
- For details, see:
http://wiki.thedarkmod.com/index.php?title=What%27s_new_in_TDM_2.06
- Build fixes:
0001-SConstruct-Use-print-as-a-function-for-python3-compa.patch
0002-SConstruct-Replace-deprecated-syntax-modules-with-fo.patch
0003-Use-DBL_MAX-for-HUGE.patch
0004-Use-system-libraries-for-curl-and-libav-format-utils.patch
0005-Build-64bit-tdm_update-on-x86_64.patch
0006-Use-system-DevIL-libpng-libjpeg.patch
- Add BuildRequires: m4
- Add BuildRequires: libav{codec,format,util}, libsw{resample,scale}
- Add BuildRequires: libboost_{filesystem,program_options,thread}-devel
- Use GCC 5 for Leap 42.3, required for std::filesystem
2015-12-26 - mailaender@opensuse.org
- update to version 2.03
2014-06-07 - mailaender@opensuse.org
- initial packaging

See Also

Package Description
tint-0.04-4.1.x86_64.rpm A Clone of the Original Tetris Game
tinygettext-devel-0.1.1469459657.bf66a57-3.30.x86_64.rpm Development files for tinygettext
tomatoes-1.55-9.2.x86_64.rpm How many tomatoes can you smash in ten short minutes?
tome4-1.4.6-1.63.x86_64.rpm Roguelike turn-based RPG
tong-1.3-2.6.x86_64.rpm Tetris and Pong in the same place at the same time
torcs-1.3.7-4.1.x86_64.rpm The Open Racing Car Simulator
torcs-car-setup-editor-0.11-5.6.x86_64.rpm Torcs Car Setup Editor
torcs-data-1.3.7-4.1.noarch.rpm Data files for TORCS
toycars-0.3.10-5.4.x86_64.rpm Toy Cars is a physics based 2-D racer
trackballs-1.3.1-12.1.x86_64.rpm A Marble Madness-like Game
trader-7.12-31.1.x86_64.rpm Star Traders, a simple game of interstellar trading
trader-lang-7.12-31.1.noarch.rpm Languages for package trader
traingame-0.3-7.1.x86_64.rpm Game about Trains
tremulous-1.1.0-13.42.x86_64.rpm First Person Shooter game based on the Quake 3 engine
tremulous-data-1.1.0-6.3.noarch.rpm Data files for tremulous the FPS game
Advertisement
Advertisement