yast2-ruby-bindings-3.1.51.2-3.1.x86_64.rpm


Advertisement

Description

yast2-ruby-bindings - Ruby bindings for the YaST platform

Property Value
Distribution openSUSE Leap 42.2
Repository openSUSE Update Oss all
Package name yast2-ruby-bindings
Package version 3.1.51.2
Package release 3.1
Package architecture x86_64
Package type rpm
Installed size 423.63 KB
Download size 123.50 KB
Official Mirror ftp.gwdg.de
The bindings allow YaST modules to be written using the Ruby language
and also Ruby scripts can use YaST agents, APIs and modules.

Alternatives

Package Version Architecture Repository
yast2-ruby-bindings-3.1.51-1.2.x86_64.rpm 3.1.51 x86_64 openSUSE Oss
yast2-ruby-bindings - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
libcrypt.so.1()(64bit) -
libcrypt.so.1(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6()(64bit) -
libowcrypt.so.1()(64bit) -
libowcrypt.so.1(OW_CRYPT_1.0)(64bit) -
libpy2UI.so.2()(64bit) -
libpy2scr.so.2()(64bit) -
libpy2wfm.so.2()(64bit) -
libruby2.1.so.2.1()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
liby2.so.4()(64bit) -
libycp.so.5()(64bit) -
ruby -
rubygem(ruby:2.1.0:fast_gettext) -
yast2-core >= 2.24.0
yast2-ycp-ui-bindings >= 2.21.9

Provides

Name Value
builtinx.so()(64bit) -
libpy2lang_ruby.so()(64bit) -
yast2-ruby-bindings = 3.1.51.2-3.1
yast2-ruby-bindings(x86-64) = 3.1.51.2-3.1
yastx.so()(64bit) -

Download

Type URL
Binary Package yast2-ruby-bindings-3.1.51.2-3.1.x86_64.rpm
Source Package yast2-ruby-bindings-3.1.51.2-3.1.src.rpm

Install Howto

Install yast2-ruby-bindings rpm package:

# zypper install yast2-ruby-bindings

Files

Path
/usr/lib64/YaST2/plugin/libpy2lang_ruby.so
/usr/lib64/ruby/vendor_ruby/2.1.0/yast.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/x86_64-linux-gnu/yastx.so
/usr/lib64/ruby/vendor_ruby/2.1.0/x86_64-linux-gnu/yast/builtinx.so
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/arg_ref.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/break.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/builtins.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/client.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/convert.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/core_ext.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/debugger.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/exportable.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/external.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/fun_ref.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/i18n.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/logger.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/module.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/ops.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/path.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/profiler.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/rspec.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/scr.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/term.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/ui.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/ui_shortcuts.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/wfm.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/y2logger.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/yast.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/core_ext/ansi_string.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/rspec/matchers.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/rspec/scr.rb
/usr/lib64/ruby/vendor_ruby/2.1.0/yast/rspec/shortcuts.rb

Changelog

2016-12-15 - igonzalezsosa@suse.com
- Do not crash when FastGettext is unable to find the empty.mo
file (bsc#1014458)
- 3.1.51.2
2016-11-15 - lslezak@suse.cz
- Improved debugger support: catch the magic debugging key
combination (Shift+Ctrl+Alt+D in Qt) returned by UI calls and
start the Ruby debugger when received (FATE#318421)
- 3.1.51.1
2016-09-16 - mvidner@suse.com
- Rescue "invalid byte sequence in UTF-8", with a custom message
(bsc#992821).
- 3.1.51
2016-06-30 - jreidinger@suse.com
- Fix segfault when running rspec tests caused by added ruby
profiler (bnc#986649 comment2)
- 3.1.50
2016-06-28 - jreidinger@suse.com
- Added support for running the Ruby profiler
- Improve performance of code by specialized `caller` call
(bnc#986649)
- 3.1.49
2016-05-30 - lslezak@suse.cz
- Improve the debugger support - use the same code also at run
time, allow using `Y2DEBUGGER` also in installed system
(FATE#318421)
- 3.1.48
2016-05-23 - lslezak@suse.cz
- Added support for running the Ruby debugger (FATE#318421)
- Allow running the Ruby debugger from the generic crash handler
if the debugger is installed
- 3.1.47
2016-03-07 - jreidinger@suse.com
- update code according to updated yast ruby style guide
2016-01-13 - jreidinger@suse.com
- Move transdb initialization to C part to keep it together with
index initialization (bsc#932014)
- 3.1.46
2016-01-13 - jreidinger@suse.com
- fixed early return from logging method causing failure of old
testsuite (bsc#932014)
- 3.1.45

See Also

Package Description
yast2-services-manager-3.1.43-18.1.noarch.rpm YaST2 - Services Manager
yast2-services-manager-3.1.44-20.3.1.noarch.rpm YaST2 - Services Manager
yast2-storage-3.1.106-3.1.x86_64.rpm YaST2 - Storage Configuration
yast2-storage-devel-3.1.106-3.1.x86_64.rpm YaST2 - Storage Library Headers and Documentation
yast2-support-3.1.7-5.3.1.noarch.rpm YaST2 - Support Inquiries
yast2-update-3.1.44-3.1.x86_64.rpm YaST2 - Update
yast2-update-FACTORY-3.1.44-3.1.x86_64.rpm YaST2 - Update
yast2-xml-3.1.2-5.3.1.x86_64.rpm YaST2 - XML Agent
yodl-3.05.01-3.3.1.x86_64.rpm Yet One-other Document Language
ypserv-4.0-3.1.x86_64.rpm YP - (NIS)-Server
yum-3.4.3-18.1.x86_64.rpm RPM installer/updater
yum-lang-3.4.3-18.1.noarch.rpm Languages for package yum
yum-updatesd-3.4.3-18.1.x86_64.rpm YUM update notification daemon
zip-3.0-19.3.1.x86_64.rpm File compression program
zlib-devel-1.2.8-10.1.x86_64.rpm Development files for zlib, a data compression library
Advertisement
Advertisement