libseccomp-tools-2.3.1-3.1.x86_64.rpm


Advertisement

Description

libseccomp-tools - Utilities for the seccomp API

Property Value
Distribution openSUSE Leap 42.2
Repository openSUSE Update Oss all
Package name libseccomp-tools
Package version 2.3.1
Package release 3.1
Package architecture x86_64
Package type rpm
Installed size 11.16 KB
Download size 9.99 KB
Official Mirror ftp.gwdg.de
The libseccomp library provides and easy to use, platform
independent, interface to the Linux Kernel's syscall filtering
mechanism: seccomp.
This subpackage contains debug utilities for the seccomp interface.

Alternatives

Package Version Architecture Repository
libseccomp-tools-2.3.3-62.1.x86_64.rpm 2.3.3 x86_64 openSUSE Security
libseccomp-tools-2.3.0-1.4.x86_64.rpm 2.3.0 x86_64 openSUSE Oss
libseccomp-tools - - -

Requires

Name Value
libc.so.6(GLIBC_2.3)(64bit) -
libseccomp.so.2()(64bit) -

Provides

Name Value
libseccomp-tools = 2.3.1-3.1
libseccomp-tools(x86-64) = 2.3.1-3.1

Download

Type URL
Binary Package libseccomp-tools-2.3.1-3.1.x86_64.rpm
Source Package libseccomp-2.3.1-3.1.src.rpm

Install Howto

Install libseccomp-tools rpm package:

# zypper install libseccomp-tools

Files

Path
/usr/bin/scmp_sys_resolver
/usr/share/man/man1/scmp_sys_resolver.1.gz

Changelog

2017-01-13 - meissner@suse.com
- updated to 2.3.1 release. (FATE#321647 bsc#1019900)
- Fixed a problem with 32-bit x86 socket syscalls on some systems
- Fixed problems with ipc syscalls on 32-bit x86
- Fixed problems with socket and ipc syscalls on s390 and s390x
2016-03-23 - meissner@suse.com
- updated to final 2.3.0 release. (FATE#318471)
- 0001-build-use-autotools-as-build-system.patch
libseccomp-s390x-support.patch:
dropped, upstream
- builderror-k316.diff: fixed upstream
- no-static.diff: do not build static libraries
2016-02-24 - jengelh@inai.de
- Update to git snapshot 2.3.0~g96
* have libseccomp build with newer linux-glibc-devel;
"multiplexed and direct socket syscalls"
- Drop libseccomp-s390x-support.patch, libseccomp-ppc64le.patch
(no longer apply - merged upstream)
- Add builderror-k316.diff
2015-09-25 - dimstar@opensuse.org
- Add baselibs.conf: systemd-32bit-224+ links against
libseccomp.so.2.
2015-08-31 - jengelh@inai.de
- Update to new upstream release 2.2.3
* Fix a problem with the masked equality operator
* Fix a problem on x86_64/x32 involving invalid architectures
* Fix a problem with the ARM specific syscalls
2015-06-18 - meissner@suse.com
- 0001-build-use-autotools-as-build-system.patch: adjust the pkgconfig reported
version from 2.1.0 to the correct 2.1.1 (bsc#932372)
2015-05-30 - jengelh@inai.de
- Update to new upstream release 2.2.1
* Fix a problem with syscall argument filtering on 64-bit systems
* Fix some problems with the 32-bit ARM syscall table
- Drop 0001-tools-add-the-missing-elf.h-header-file.patch,
libseccomp-arm-syscall-fixes.patch
(applied upstream)
2015-04-13 - dvaleev@suse.com
- Fix ppc64le build: libseccomp-ppc64le.patch
2014-03-05 - meissner@suse.com
- libseccomp-s390x-support.patch:
support s390,s390x,ppc,ppc64,ppc64le too. bnc#866526 (arm64 not yet done)
- disabled testsuite on the new platforms, as there
are still some failures.
s390:     passed: 2492 / failed: 915 / errored: 25
s390x:    passed: 2492 / failed: 915 / errored: 25
ppc64le:  passed: 4032 / failed:   0 / errored: 0
2013-06-18 - jengelh@inai.de
- Update to new upstream release 2.1.0
* Add support for the x32 and ARM architectures
* More verbose PFC output, including translation of syscall
numbers to names
* Several assorted bugfixes affecting the seccomp BPF generation
* The syscall number/name resolver tool is now installed
* Fixes for the x86 multiplexed syscalls
* Additions to the API to better support non-native architecures
* Additions to the API to support multiple architecures in one filter
* Additions to the API to resolve syscall name/number mappings
- Remove 0001-build-use-ac-variables-in-pkgconfig-file.patch
(merged into 0001-build-use-autotools-as-build-system.patch)

See Also

Package Description
libseccomp2-2.3.1-3.1.x86_64.rpm An enhanced Seccomp (mode 2) helper library
libseccomp2-32bit-2.3.1-3.1.x86_64.rpm An enhanced Seccomp (mode 2) helper library
libsecret-1-0-0.18.5-3.3.1.x86_64.rpm Library for accessing the Secret Service API
libsecret-1-0-32bit-0.18.5-3.3.1.x86_64.rpm Library for accessing the Secret Service API
libsecret-devel-0.18.5-3.3.1.x86_64.rpm Library for accessing the Secret Service API -- Development Files
libsecret-lang-0.18.5-3.3.1.noarch.rpm Languages for package libsecret
libsecret-tools-0.18.5-3.3.1.x86_64.rpm Library for accessing the Secret Service API -- Tools
libsemanage-devel-2.5-2.3.1.x86_64.rpm Header files and libraries used to build policy manipulation tools
libsemanage-devel-2.5-2.6.1.x86_64.rpm Header files and libraries used to build policy manipulation tools
libsemanage-devel-static-2.5-2.3.1.x86_64.rpm SELinux binary policy manipulation library
libsemanage-devel-static-2.5-2.6.1.x86_64.rpm SELinux binary policy manipulation library
libsemanage1-2.5-2.3.1.x86_64.rpm SELinux binary policy manipulation library
libsemanage1-2.5-2.6.1.x86_64.rpm SELinux binary policy manipulation library
libsemanage1-32bit-2.5-2.3.1.x86_64.rpm SELinux binary policy manipulation library
libsemanage1-32bit-2.5-2.6.1.x86_64.rpm SELinux binary policy manipulation library
Advertisement
Advertisement