libpurple-plugin-sipe-1.22.0-3.1.x86_64.rpm


Advertisement

Description

libpurple-plugin-sipe - Libpurple third-party plugin for MS Skype for Business

Property Value
Distribution openSUSE Leap 42.2
Repository openSUSE Update Oss all
Package name libpurple-plugin-sipe
Package version 1.22.0
Package release 3.1
Package architecture x86_64
Package type rpm
Installed size 560.09 KB
Download size 218.98 KB
Official Mirror ftp.gwdg.de
A third-party plugin for the libpurple multi-protocol instant
messaging library. It implements the extended version of SIP/SIMPLE
used by various products:
* Skype for Business.
* Microsoft Office 365.
* Microsoft Business Productivity Online Suite (BPOS).
* Microsoft Lync Server.
* Microsoft Office Communications Server (OCS 2007/2007 R2).
* Microsoft Live Communications Server (LCS 2003/2005).
* Reuters Messaging.

Alternatives

Package Version Architecture Repository
libpurple-plugin-sipe-1.21.1-1.1.x86_64.rpm 1.21.1 x86_64 openSUSE Oss
libpurple-plugin-sipe - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libfarstream-0.2.so.5()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgmime-2.6.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgssapi_krb5.so.2()(64bit) -
libgssapi_krb5.so.2(gssapi_krb5_2_MIT)(64bit) -
libgstreamer-1.0.so.0()(64bit) -
libgstrtp-1.0.so.0()(64bit) -
libnspr4.so()(64bit) -
libnss3.so()(64bit) -
libnss3.so(NSS_3.10)(64bit) -
libnss3.so(NSS_3.2)(64bit) -
libnss3.so(NSS_3.3)(64bit) -
libnss3.so(NSS_3.4)(64bit) -
libnss3.so(NSS_3.5)(64bit) -
libnss3.so(NSS_3.6)(64bit) -
libnss3.so(NSS_3.9.2)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpurple.so.0()(64bit) -
libsmime3.so()(64bit) -
libsmime3.so(NSS_3.4)(64bit) -
libxml2.so.2()(64bit) -
libxml2.so.2(LIBXML2_2.4.30)(64bit) -
libxml2.so.2(LIBXML2_2.6.0)(64bit) -

Provides

Name Value
libpurple-plugin-sipe = 1.22.0-3.1
libpurple-plugin-sipe(x86-64) = 1.22.0-3.1
libsipe.so()(64bit) -

Download

Type URL
Binary Package libpurple-plugin-sipe-1.22.0-3.1.x86_64.rpm
Source Package pidgin-sipe-1.22.0-3.1.src.rpm

Install Howto

Install libpurple-plugin-sipe rpm package:

# zypper install libpurple-plugin-sipe

Files

Path
/usr/lib64/purple-2/libsipe.so

Changelog

2017-02-15 - mrueckert@suse.de
- update to 1.22.0
- Feature #93: Support for Lync Autodiscover (Stefan Becker)
- Feature #6: Application Sharing Viewer (Jakub Adam)
* requires libpurple >= 2.12.0
* needs an external RDP client - remmina and xfreerdp are supported
- Fixed #315: Crash when contact list is empty (Stefan Becker)
- Fixed #314: sipe login problems with long pw (Stefan Becker)
- separate logging and debugging output (Stefan Becker)
* logging is always shown, e.g. in the Pidgin debug window
* full message debugging now requires PURPLE_UNSAFE_DEBUG=1
- new translations: Greek (el), Lithuanian (lt)
- drop pidgin-sipe-gstreamer-1.0.patch: no longer needed
- add recommends for remmina and freerdp so the desktop sharing
stuff would work out of the box
- add BR for gstreamer-rtp-1.0 and farstream-0.2 to keep the
video/audio feature working
2016-12-16 - sor.alexei@meowr.ru
- Rename the pidgin-sipe package to pidgin-plugin-sipe.
- Rename the telepathy-plugin-sipe package to telepathy-sipe.
- Require Pidgin of the exact or greater version.
- Make pidgin-plugin-sipe noarch.
- Separate locales to libpurple-plugin-sipe-lang.
- Update description.
2016-07-08 - tchvatal@suse.com
- Version update to 1.21.1:
* various bug fixes in media support
* configure no longer ignores CFLAGS/LDFLAGS/LIBS
- Drop telepathy conditionals as we don't build on sle11 anyway
- Move the docs from library to main package to allow multiple versions
at once as SLP wants
2016-02-12 - dimstar@opensuse.org
- Pass --disable-quality-check to configure: the 'quality' checks
are a bunch of compiler flags like Werror and more warning. This
is more important for development versions than for released
ones.
2016-01-13 - dimstar@opensuse.org
- Update to version 1.20.1:
+ Add support for another type of ADFS response.
+ Improve configure check for back-ported features.
+ Updated translations.
- Changes from version 1.20.0:
+ Parse HTML from Lync conference URL (Stefan Becker)
+ SRTP Support.
+ Office365 rejects RC4 in TLS-DSK: added support for
AES-128/256-CBC.
- Drop patch: 0001-Fix-285-backport-for-1.18.x-1.19.x.patch
Fixed upstream (bnc#965323).
2015-06-30 - dimstar@opensuse.org
- Port to GStreamer 1.0 (follow pidin's port):
+ Add pidgin-sipe-gstreamer-1.0.patch
+ Replace pkgconfig(gstreamer-0.10) BuildRequires with
pkgconfig(gstreamer-1.0).
+ Add autoreconf call, as the patch touches the buildsystem.
+ Pass --with-vv to configure, to ensure we do not lose Voice &
Video support.
2015-04-08 - tyang@suse.com
- Add patch: 0001-Fix-285-backport-for-1.18.x-1.19.x.patch
Fixed both upstream and sled:
sf#285: Office365 rejects RC4 in TLS-DSK.
bnc#965323:Pidgin-sipe no longer works with Office 365 of
skype for Business.
2015-04-07 - dimstar@opensuse.org
- Update to version 1.19.1:
+ Fixed sf#278: 488 error after libnice upgrade.
+ Fix SIP re-authentication timeout to be max. 8 hours.
2015-02-13 - zaitor@opensuse.org
- Update to version 1.19.0:
+ Move parsing of login name.
+ Support for Adium group chat bookmarks.
+ Support searching for SIP ID.
+ ADFS can't always be used for accounts that have Multi-Factor
Authentication (MFA) enabled.
+ Support buddy photos from contactCard.
+ Fall back from Kerberos to NTLM.
+ Raised contact names.
+ Corrupted HTTP response crashes SIPE.
+ Fix calendar state machine when EWS URL is set.
+ Fall back to [MS-DLX] BasicSearch to improve search experience.
+ Implement search functionality for UCS.
+ adium:
- Add chat room list UI.
- Fix duplicate debug log messages.
+ Support for libnice TCP mode.
+ Refactor CCCP request code.
2014-12-31 - jozef.koval03@gmail.com
- Update to version 1.18.5:
+ Redundant "const" breaks build with clang.
+ Purple idle-away converted to Away.
+ Svc: use authuser for RealmInfo request.
+ Adium: add release checking script.
+ Mingw: update fetch script to Pidgin 2.10.11.
+ Bugs fixed: sf#269, sf#276.
+ Updated translations.

See Also

Package Description
libpurple-plugin-sipe-lang-1.22.0-3.1.noarch.rpm Languages for package pidgin-sipe
libpurple-tcl-2.10.11-8.3.1.x86_64.rpm TCL Plugin Support for Pidgin
libpurple-tcl-2.12.0-8.6.1.x86_64.rpm TCL Plugin Support for Pidgin
libpython2_7-1_0-2.7.13-25.3.1.x86_64.rpm Python Interpreter shared library
libpython2_7-1_0-32bit-2.7.13-25.3.1.x86_64.rpm Python Interpreter shared library
libpython3_4m1_0-3.4.6-10.3.1.x86_64.rpm Python Interpreter shared library
libpython3_4m1_0-32bit-3.4.6-10.3.1.x86_64.rpm Python Interpreter shared library
libqt5-qtbase-common-devel-5.6.1-3.3.1.x86_64.rpm Qt 5 Core Development Binaries
libqt5-qtbase-devel-5.6.1-3.3.1.x86_64.rpm Qt Development Kit
libqt5-qtbase-examples-32bit-5.6.1-3.3.1.x86_64.rpm Qt5 base examples
libqt5-qtbase-examples-5.6.1-3.3.1.x86_64.rpm Qt5 base examples
libqt5-qtbase-private-headers-devel-5.6.1-3.3.1.noarch.rpm Non-ABI stable experimental API
libqt5-qtdeclarative-devel-32bit-5.6.1-5.1.x86_64.rpm Qt Development Kit
libqt5-qtdeclarative-devel-32bit-5.6.1-7.3.1.x86_64.rpm Qt Development Kit
libqt5-qtdeclarative-devel-5.6.1-5.1.x86_64.rpm Qt Development Kit
Advertisement
Advertisement