libopus-devel-1.1-6.1.x86_64.rpm


Advertisement

Description

libopus-devel - Opus Audio Codec Library Development Environment

Distribution: openSUSE 42.2
Repository: openSUSE Update Oss all
Package name: libopus-devel
Package version: 1.1
Package release: 6.1
Package architecture: x86_64
Package type: rpm
Installed size: 134.10 KB
Download size: 27.70 KB
Official Mirror: ftp.gwdg.de
The Opus codec is designed for interactive speech and audio transmission over the Internet. It is designed by the IETF Codec Working Group and incorporates technology from Skype's SILK codec and Xiph.Org's CELT codec.

Alternatives

Requires

Provides

  • libopus-devel = 1.1-6.1
  • libopus-devel(x86-64) = 1.1-6.1
  • pkgconfig(opus) = 1.1

    Download

    Source package: opus-1.1-6.1.src.rpm

    Install Howto

    Install libopus-devel rpm package:

    # zypper install libopus-devel

    Files

    • /usr/include/opus/opus.h
    • /usr/include/opus/opus_custom.h
    • /usr/include/opus/opus_defines.h
    • /usr/include/opus/opus_multistream.h
    • /usr/include/opus/opus_types.h
    • /usr/lib64/libopus.so
    • /usr/lib64/pkgconfig/opus.pc
    • /usr/share/aclocal/opus.m4

    Changelog

    2017-02-01 - idonmez@suse.com - Add CVE-2017-0381.patch to fix a remote code execution vulnerability in silk/NLSF_stabilize.c CVE-2017-0381 bsc#1020102

    2013-12-08 - zaitor@opensuse.org - Update to version 1.1: + New analysis code and tuning that significantly improves encoding quality, especially for variable-bitrate (VBR). + Automatic detection of speech or music to decide which encoding mode to use. + Surround with good quality at 128 kbps for 5.1 and usable down to 48 kbps. + Speed improvements on all architectures, especially ARM, where decoding uses around 40% less CPU and encoding uses around 30% less CPU.

    2013-08-01 - zaitor@opensuse.org - Update to version 1.0.3: + Backport of the new 1.1 surround API. + Fixes for a few minor glitches during mode switching. + Some minor fixed-point fixes. + Fix a regression in the FEC code introduced in 1.0.2.

    2013-02-02 - zaitor@opensuse.org - Update to version 1.0.2: + Fix an out-of-bounds read security issue. + Fixes and improvements to the PLC and hybrid mode quality. - Drop opus-fix-out-of-bounds-read-issue-with-the-padding-handling.patch Fixed upstream.

    2013-01-13 - zaitor@opensuse.org - Add opus-fix-out-of-bounds-read-issue-with-the-padding-handling.patch Fixes an out-of-bounds read that could be triggered by a malicious Opus packet causing an integer wrap-around in the padding code.

    2012-09-19 - zaitor@opensuse.org - Update to version 1.0.1: + First bugfix release of stable version. + Changes are mostly buildfixes. + Fully compliant with the Opus specification. - Remove unneeded autoconf, automake, gcc glibc-devel and make. - Remove manual deletion of docs, instead pass --disable-doc to configure. - Minor spec cleanup.

    2012-05-31 - pascal.bleser@opensuse.org - initial version (0.9.14)

    Advertisement
    Advertisement