kiconthemes-devel-5.26.0-3.1.x86_64.rpm


Advertisement

Description

kiconthemes-devel - Icon GUI utilities: Build Environment

Distribution: openSUSE 42.2
Repository: openSUSE Update Oss all
Package name: kiconthemes-devel
Package version: 5.26.0
Package release: 3.1
Package architecture: x86_64
Package type: rpm
Installed size: 70.85 KB
Download size: 30.69 KB
Official Mirror: ftp.gwdg.de
This library contains classes to improve the handling of icons in applications using the KDE Frameworks. Development files.

Alternatives

Provides

  • cmake(KF5IconThemes) = 5.26.0
  • kiconthemes-devel = 5.26.0-3.1
  • kiconthemes-devel(x86-64) = 5.26.0-3.1

    Install Howto

    Install kiconthemes-devel rpm package:

    # zypper install kiconthemes-devel

    Files

    • /usr/bin/kiconfinder5
    • /usr/include/KF5/kiconthemes_version.h
    • /usr/include/KF5/KIconThemes/KIconButton
    • /usr/include/KF5/KIconThemes/KIconDialog
    • /usr/include/KF5/KIconThemes/KIconEffect
    • /usr/include/KF5/KIconThemes/KIconEngine
    • /usr/include/KF5/KIconThemes/KIconLoader
    • /usr/include/KF5/KIconThemes/KIconTheme
    • /usr/include/KF5/KIconThemes/kiconbutton.h
    • /usr/include/KF5/KIconThemes/kicondialog.h
    • /usr/include/KF5/KIconThemes/kiconeffect.h
    • /usr/include/KF5/KIconThemes/kiconengine.h
    • /usr/include/KF5/KIconThemes/kiconloader.h
    • /usr/include/KF5/KIconThemes/kicontheme.h
    • /usr/include/KF5/KIconThemes/kiconthemes_export.h
    • /usr/lib64/libKF5IconThemes.so
    • /usr/lib64/cmake/KF5IconThemes/KF5IconThemesConfig.cmake
    • /usr/lib64/cmake/KF5IconThemes/KF5IconThemesConfigVersion.cmake
    • /usr/lib64/cmake/KF5IconThemes/KF5IconThemesTargets-none.cmake
    • /usr/lib64/cmake/KF5IconThemes/KF5IconThemesTargets.cmake
    • /usr/lib64/qt5/mkspecs/modules/qt_KIconThemes.pri

    Changelog

    2017-01-20 - wbauer@tmo.at - Add Support-non-integer-scale-factors-in-kiconengine.patch to make icons sharper (not blurry) with non-integer scale factors (boo#1006651, kde#366451)

    2017-01-19 - wbauer@tmo.at - Add fix-changing-icon-theme.patch to make running applications detect changing the configured icon theme and as a result not adding wrong icons to the cache (boo#1000519, kde#365363)

    2016-09-06 - hrvoje.senjan@gmail.com - Update to 5.26.0 * For more details please see: https://www.kde.org/announcements/kde-frameworks-5.26.0.php

    2016-08-07 - hrvoje.senjan@gmail.com - Update to 5.25.0 * Qt >= 5.5 is now required * Greatly improve the performance of makeCacheKey, as it is a critical code path in icon lookup * KIconLoader: reduce number of lookups when doing fallbacks * KIconLoader: massive speed improvement for loading unavailable icons * Do not clear search line when switching category * KIconEngine: Fix QIcon::hasThemeIcon always returning true (kde#365130) * For more details please see: https://www.kde.org/announcements/kde-frameworks-5.25.0.php - Drop upstreamed 0001-KIconEngine-Fix-QIcon-hasThemeIcon-always-returning-.patch

    2016-07-15 - hrvoje.senjan@gmail.com - Added 0001-KIconEngine-Fix-QIcon-hasThemeIcon-always-returning-.patch from upstream

    2016-07-06 - hrvoje.senjan@gmail.com - Update to 5.24.0 * Add support for loading and using an icontheme in a RCC file automatically * Document icon theme deployment on MacOS and Windows, see https://api.kde.org/frameworks/kiconthemes/html/index.html * For more details please see: https://www.kde.org/announcements/kde-frameworks-5.24.0.php

    2016-06-06 - hrvoje.senjan@gmail.com - Update to 5.23.0 * Don't make KIconThemes depend on Oxygen (kde#360664) * Selected state concept for icons * Use system colors for monochrome icons * For more details please see: https://www.kde.org/announcements/kde-frameworks-5.23.0.php

    2016-05-07 - hrvoje.senjan@gmail.com - Update to 5.22.0 (boo#980066) * Use appropriate container for internal pointer array * Add opportunity to reduce unneeded disk accesses, introduces KDE-Extensions * Save some disk accesses * For more details please see: https://www.kde.org/announcements/kde-frameworks-5.22.0.php

    2016-04-04 - hrvoje.senjan@gmail.com - Update to 5.21.0 (boo#974793) * Upgrade Qt version requirement to 5.4.0 * For more details please see: https://www.kde.org/announcements/kde-frameworks-5.21.0.php

    2016-03-18 - wbauer@tmo.at - Drop breeze.diff: it caused an incorrect fallback to breeze instead of hicolor when a different icon theme is configured, and has been reverted (and even rejected in a second try) upstream (kde#356064, kde#360664)

    Advertisement
    Advertisement