containerd-0.2.5+gitr569_2a5e70c-8.1.x86_64.rpm


Advertisement

Description

containerd - Standalone OCI Container Daemon

Property Value
Distribution openSUSE Leap 42.2
Repository openSUSE Update Oss all
Package name containerd
Package version 0.2.5+gitr569_2a5e70c
Package release 8.1
Package architecture x86_64
Package type rpm
Installed size 11.31 MB
Download size 2.33 MB
Official Mirror ftp.gwdg.de
Containerd is a daemon with an API and a command line client, to manage
containers on one machine. It uses runC to run containers according to the OCI
specification. Containerd has advanced features such as seccomp and user
namespace support as well as checkpoint and restore for cloning and live
migration of containers.

Alternatives

Package Version Architecture Repository
containerd-0.2.5+gitr639_422e31c-10.3.1.x86_64.rpm 0.2.5+gitr639_422e31c x86_64 openSUSE Update Oss
containerd-0.2.4+gitr565_0366d7e-5.1.x86_64.rpm 0.2.4+gitr565_0366d7e x86_64 openSUSE Update Oss
containerd-0.2.3-3.1.x86_64.rpm 0.2.3 x86_64 openSUSE Oss
containerd - - -

Requires

Name Value
coreutils -
diffutils -
fillup -
grep -
libc.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
runc = 0.1.1+gitr2819_50a19c6

Provides

Name Value
containerd = 0.2.5+gitr569_2a5e70c-8.1
containerd(x86-64) = 0.2.5+gitr569_2a5e70c-8.1

Download

Type URL
Binary Package containerd-0.2.5+gitr569_2a5e70c-8.1.x86_64.rpm
Source Package containerd-0.2.5+gitr569_2a5e70c-8.1.src.rpm

Install Howto

Install containerd rpm package:

# zypper install containerd

Files

Path
/usr/lib/systemd/system/containerd.service
/usr/lib/systemd/system/containerd.socket
/usr/sbin/containerd
/usr/sbin/containerd-shim
/usr/sbin/rccontainerd
/usr/share/doc/packages/containerd/LICENSE.code
/usr/share/doc/packages/containerd/LICENSE.docs
/usr/share/doc/packages/containerd/README.md
/var/adm/fillup-templates/sysconfig.containerd

Changelog

2017-01-14 - asarai@suse.com
- Update docker to the version used in Docker 1.12.6. This is necessary to fix
CVE-2016-9962 (bsc#1012568).
2016-12-19 - jmassaguerpla@suse.com
- update containerd to the version used in docker 1.12.5 (bsc#1016307).
This fixes bsc#1015661
2016-11-24 - jmassaguerpla@suse.com
- fix runc version
fix bsc#1009961
2016-11-24 - jmassaguerpla@suse.com
- fix version so that it contains a sequence number and zypper does
not think is a downgrade
2016-10-25 - jmassaguerpla@suse.com
- fix bsc#1006368: docker/containerd is broken when installed by
SuSE Studio in an appliance: We were missing the
Requires(post): %fillup_prereq
2016-10-25 - jmassaguerpla@suse.com
- update runc requirement to 02f8fa7863dd3f82909a73e2061897828460d52f
(see RUNC_COMMIT in Dockerfile)
2016-10-13 - jmassaguerpla@suse.com
- update to commit 0366d7e which is the one required for docker-1.12.2
(bsc#1004490)
2016-09-19 - jmassaguerpla@suse.com
- fix go_arches definition: use global instead of define, otherwise
it fails to build
2016-08-25 - jmassaguerpla@suse.com
- Remove GOPATH at the end of the GOPATH assignment
cause GOPATH is empty and if we do that, we get the path ""
appended, which causes gcc6-go to complain
2016-08-24 - jmassaguerpla@suse.com
- add go_arches in project configuration: this way, we can use the
same spec file but decide in the project configuration if to
use gc-go or gcc-go for some archs.

See Also

Package Description
containerd-ctr-0.2.4+gitr565_0366d7e-5.1.x86_64.rpm Client for containerd
containerd-ctr-0.2.5+gitr569_2a5e70c-8.1.x86_64.rpm Client for containerd
containerd-ctr-0.2.5+gitr639_422e31c-10.3.1.x86_64.rpm Client for containerd
containerd-test-0.2.4+gitr565_0366d7e-5.1.noarch.rpm Test package for containerd
containerd-test-0.2.5+gitr569_2a5e70c-8.1.noarch.rpm Test package for containerd
containerd-test-0.2.5+gitr639_422e31c-10.3.1.noarch.rpm Test package for containerd
coolkey-1.1.0-153.3.1.x86_64.rpm CoolKey and CAC PKCS #11 PKI Module for Smart Cards
coolkey-32bit-1.1.0-153.3.1.x86_64.rpm CoolKey and CAC PKCS #11 PKI Module for Smart Cards
coolkey-devel-1.1.0-153.3.1.x86_64.rpm CoolKey and CAC PKCS #11 PKI Module for Smart Cards
coreutils-8.25-2.3.1.x86_64.rpm GNU Core Utilities
coreutils-lang-8.25-2.3.1.noarch.rpm Languages for package coreutils
coreutils-testsuite-8.25-2.3.1.x86_64.rpm GNU Core Utilities
corosync-2.3.5-8.3.1.x86_64.rpm The Corosync Cluster Engine and Application Programming Interfaces
corosync-testagents-2.3.5-8.3.1.x86_64.rpm The Corosync Cluster Engine Test Agents
cpio-2.11-33.1.x86_64.rpm A Backup and Archiving Utility
Advertisement
Advertisement