nitrokey-app-0.6.3-2.1.x86_64.rpm


Advertisement

Description

nitrokey-app - Nitrokey's Application

Property Value
Distribution openSUSE Leap 42.2
Repository openSUSE Security all
Package name nitrokey-app
Package version 0.6.3
Package release 2.1
Package architecture x86_64
Package type rpm
Installed size 843.06 KB
Download size 326.67 KB
Official Mirror ftp.gwdg.de
The implementation is compatible to the Google Authenticator application which
can be used for testing purposes. See google-authenticator
Using the application under Linux also requires root privileges, or
configuration of device privileges in udev (due to USB communication).

Alternatives

Package Version Architecture Repository
nitrokey-app - - -

Requires

Name Value
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.6)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.17)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libpthread.so.0(GLIBC_2.3.3)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libusb-1.0.so.0()(64bit) -

Provides

Name Value
application() -
application(nitrokey-app.desktop) -
config(nitrokey-app) = 0.6.3-2.1
nitrokey-app = 0.6.3-2.1
nitrokey-app(x86-64) = 0.6.3-2.1

Download

Type URL
Binary Package nitrokey-app-0.6.3-2.1.x86_64.rpm
Source Package nitrokey-app-0.6.3-2.1.src.rpm

Install Howto

  1. Add the openSUSE Security repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/security/openSUSE_Leap_42.2/ opensuse-security
  2. Install nitrokey-app rpm package:
    # zypper install nitrokey-app

Files

Path
/etc/bash_completion.d/nitrokey-app
/usr/bin/nitrokey-app
/usr/lib/udev/rules.d/40-nitrokey.rules
/usr/share/applications/nitrokey-app.desktop
/usr/share/doc/packages/nitrokey-app/OTP_full_specification.txt
/usr/share/doc/packages/nitrokey-app/README.md
/usr/share/icons/hicolor/128x128/apps/nitrokey-app.png
/usr/share/icons/hicolor/16x16/apps/nitrokey-app.png
/usr/share/icons/hicolor/22x22/apps/nitrokey-app.png
/usr/share/icons/hicolor/24x24/apps/nitrokey-app.png
/usr/share/icons/hicolor/32x32/apps/nitrokey-app.png
/usr/share/icons/hicolor/48x48/apps/nitrokey-app.png
/usr/share/icons/hicolor/scalable/apps/nitrokey-app.svg
/usr/share/icons/ubuntu-mono-dark/
/usr/share/icons/ubuntu-mono-dark/apps/
/usr/share/icons/ubuntu-mono-dark/apps/16/nitrokey-app.svg
/usr/share/icons/ubuntu-mono-dark/apps/22/nitrokey-app.svg
/usr/share/icons/ubuntu-mono-dark/apps/24/nitrokey-app.svg
/usr/share/icons/ubuntu-mono-dark/apps/48/nitrokey-app.svg
/usr/share/icons/ubuntu-mono-light/
/usr/share/icons/ubuntu-mono-light/apps/
/usr/share/icons/ubuntu-mono-light/apps/16/nitrokey-app.svg
/usr/share/icons/ubuntu-mono-light/apps/22/nitrokey-app.svg
/usr/share/icons/ubuntu-mono-light/apps/24/nitrokey-app.svg
/usr/share/icons/ubuntu-mono-light/apps/48/nitrokey-app.svg
/usr/share/locale/de_DE/LC_MESSAGES/nitrokey-app.mo
/usr/share/nitrokey/info.png
/usr/share/nitrokey/quit.png
/usr/share/nitrokey/safe_zahlenkreis.png
/usr/share/nitrokey/settings.png
/usr/share/pixmaps/nitrokey-app.png

Changelog

2017-02-28 - mrueckert@suse.de
- bump cmake to 3.1.0 to match what thd cmake file says
- drop nitrokey-app-0.5.1_cmakepolicy.patch
2017-02-28 - mrueckert@suse.de
- update to v0.6.3
- Do not enable new HID protocol for Storage yet
[#218](https://github.com/Nitrokey/nitrokey-app/issues/218)
- nitrokey-app keeps asking for admin PIN when trying to
configure TOTP or HOTP slot
[#211](https://github.com/Nitrokey/nitrokey-app/issues/211)
- Disable support of new HID protocol for Storage
[#219](https://github.com/Nitrokey/nitrokey-app/pull/219)
([szszszsz](https://github.com/szszszsz))
- Debian packaging rules changes
[#217](https://github.com/Nitrokey/nitrokey-app/pull/217)
([szszszsz](https://github.com/szszszsz))
- changes from v0.6.2
- OTP not working on Windows
[#214](https://github.com/Nitrokey/nitrokey-app/issues/214)
- Bump version to 0.6.2
[#216](https://github.com/Nitrokey/nitrokey-app/pull/216)
([szszszsz](https://github.com/szszszsz))
- Pack union for writing OTP slot data
[#215](https://github.com/Nitrokey/nitrokey-app/pull/215)
([szszszsz](https://github.com/szszszsz))
- Do not block on waiting for symlink to storage being available
[#213](https://github.com/Nitrokey/nitrokey-app/pull/213)
([szszszsz](https://github.com/szszszsz))
- Break asking PIN loop when user cancels it
[#212](https://github.com/Nitrokey/nitrokey-app/pull/212)
([szszszsz](https://github.com/szszszsz))
- Fix compilation warnings
[#208](https://github.com/Nitrokey/nitrokey-app/pull/208)
([szszszsz](https://github.com/szszszsz))
- refresh nitrokey-app-0.5.1_cmakepolicy.patch
2016-12-12 - mrueckert@suse.de
- Update to v0.6.1
Use native settings handler #206 (szszszsz)
Add Arabic translation to resource file #204 (szszszsz)
- changes from v0.6.0
- Implemented enhancements:
- Support for Pro stick version 0.8 #190
- Closed issues:
- Add command line parameter to force language #199
- OTP secret field's max length changes only with text inside
[#195]
- Fedora 23 RPM has conflicts #193
- RPM package installs in wrong directory #178
- Invisible tray icon on openSUSE Tumbleweed unless run as root
[#176]
- Mac OS X version and missing QT libraries #163
- Merged pull requests:
- Update README.md #202 (szszszsz)
- Add language CLI param #200 (szszszsz)
- Bump version to 0.6 #198 (szszszsz)
- Support for Nitrokey Pro 0.8 #196 (szszszsz)
- Resolve conflict with udev rules (for Fedora 23) #194
(vladimir-lu)
- build: set CMAKE_BUILD_TYPE only if not set #188
(ignatenkobrain)
- Translations: initial support for Arabic (ar) language #183
(szszszsz)
- Change RPM package installation dir #180 (szszszsz)
- Update README.md #179 (szszszsz)
- Update changelog #174 (szszszsz)
- drop nitrokey-app-0.5.1_installdir_strip_prefix.patch: included
upstream
2016-10-19 - heiko.jansen.de@gmail.com
- Update to v0.5.1
- Removed obsolete patches
- Apply two patches for compilation and package building only
- Does not use libappindicator anymore
2015-10-12 - mrueckert@suse.de
- fix buildrequires to make it work on more distros
2015-10-12 - mrueckert@suse.de
- initial package of version 0.2
- first set of patches:
- nitrokey-app-0.2_drop_url_from_desktop_file.patch
rpmlint complains about URL in desktop file with type
application. URL should only be used for Type=Link.
- nitrokey-app-0.2_udev_path.patch
use system udev path instead of the user path

See Also

Package Description
nkmkpasswd-0.0.2-2.1.noarch.rpm Create Passwords with various Levels of Strength
nwipe-0.22-1.1.x86_64.rpm Standalone secure disk eraser
oath-toolkit-2.6.2-16.1.x86_64.rpm Toolkit for one-time password authentication systems
oath-toolkit-xml-2.6.2-16.1.noarch.rpm XML data files needed by liboath
openCryptoki-3.8.2-125.1.x86_64.rpm An Implementation of PKCS#11 (Cryptoki) v2.11 for IBM Cryptographic Hardware
openCryptoki-64bit-3.8.2-125.1.x86_64.rpm An Implementation of PKCS#11 (Cryptoki) v2.11 for IBM Cryptographic Hardware
openCryptoki-devel-3.8.2-125.1.x86_64.rpm An Implementation of PKCS#11 (Cryptoki) v2.01 for IBM Cryptographic Hardware
openscap-1.2.17-210.1.x86_64.rpm A Set of Libraries for Integration with SCAP
openscap-content-1.2.17-210.1.x86_64.rpm SCAP content
openscap-devel-1.2.17-210.1.x86_64.rpm Development Files for OpenSCAP
openscap-docker-1.2.17-210.1.x86_64.rpm Docker plugin for OpenSCAP
openscap-engine-sce-1.2.17-210.1.x86_64.rpm Script Checking Engine for OpenSCAP
openscap-extra-probes-1.2.17-210.1.x86_64.rpm SCAP probes
openscap-utils-1.2.17-210.1.x86_64.rpm Openscap utilities
openssl-engine-af_alg-0.0_git201202292316-7.2.x86_64.rpm AF_ALG engine for OpenSSL
Advertisement
Advertisement