nunit-2.6.4-4.29.noarch.rpm


Advertisement

Description

nunit - Unit-testing framework for all .NET languages

Property Value
Distribution openSUSE Leap 42.2
Repository openSUSE Oss all
Package name nunit
Package version 2.6.4
Package release 4.29
Package architecture noarch
Package type rpm
Installed size 7.77 MB
Download size 2.52 MB
Official Mirror ftp.gwdg.de
NUnit is a unit testing framework for all .NET languages. It serves the
same purpose as JUnit does in the Java world. It supports test
categories, testing for exceptions and writing test results in plain
text or XML.

Alternatives

Package Version Architecture Repository
nunit - - -

Requires

Name Value
mono(NSubstitute) = 1.4.3.0
mono(System) >= 1.0.3300.0
mono(System) = 2.0.0.0
mono(System.Configuration) = 2.0.0.0
mono(System.Core) = 3.5.0.0
mono(System.Core) = 4.0.0.0
mono(System.Data) >= 1.0.3300.0
mono(System.Data) = 2.0.0.0
mono(System.Drawing) = 2.0.0.0
mono(System.Runtime.Remoting) = 2.0.0.0
mono(System.ServiceModel) = 3.0.0.0
mono(System.Web) >= 1.0.3300.0
mono(System.Windows.Forms) = 2.0.0.0
mono(System.Xml) >= 1.0.3300.0
mono(System.Xml) = 2.0.0.0
mono(log4net) = 1.2.10.0
mono(mock-assembly) = 2.6.4.0
mono(mscorlib) >= 1.0.3300.0
mono(mscorlib) = 4.0.0.0
mono(mscorlib) = 2.0.0.0
mono(nonamespace-assembly) = 2.6.4.0
mono(nunit-console-runner) = 2.6.4.0
mono(nunit-editor) = 0.9.0.0
mono(nunit-gui-runner) = 2.6.4.0
mono(nunit.core) = 2.6.4.0
mono(nunit.core.interfaces) = 2.6.4.0
mono(nunit.core.tests) = 2.6.4.0
mono(nunit.framework) = 2.6.4.0
mono(nunit.mocks) = 2.6.4.0
mono(nunit.uiexception) = 2.6.4.0
mono(nunit.uikit) = 2.6.4.0
mono(nunit.util) = 2.6.4.0
mono(pnunit.framework) = 1.0.6136.11834
mono(test-assembly) = 2.6.4.0
mono(test-assembly-net45) = 2.6.4.0
mono(test-utilities) = 2.6.4.0
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsLzma) <= 4.4.6-1

Provides

Name Value
mono(NSubstitute) = 1.4.3.0
mono(log4net) = 1.2.10.0
mono(mock-assembly) = 2.6.4.0
mono(nonamespace-assembly) = 2.6.4.0
mono(nunit) = 2.6.4.0
mono(nunit-agent) = 2.6.4.0
mono(nunit-console) = 2.6.4.0
mono(nunit-console-runner) = 2.6.4.0
mono(nunit-console.tests) = 2.6.4.0
mono(nunit-editor) = 0.9.0.0
mono(nunit-editor.tests) = 1.0.0.0
mono(nunit-gui-runner) = 2.6.4.0
mono(nunit-gui.tests) = 2.6.4.0
mono(nunit.core) = 2.6.4.0
mono(nunit.core.interfaces) = 2.6.4.0
mono(nunit.core.tests) = 2.6.4.0
mono(nunit.core.tests.45) = 2.6.4.0
mono(nunit.framework) = 2.6.4.0
mono(nunit.framework.tests) = 2.6.4.0
mono(nunit.framework.tests.net45) = 2.6.4.0
mono(nunit.mocks) = 2.6.4.0
mono(nunit.mocks.tests) = 2.6.4.0
mono(nunit.uiexception) = 2.6.4.0
mono(nunit.uiexception.tests) = 2.6.4.0
mono(nunit.uikit) = 2.6.4.0
mono(nunit.uikit.tests) = 2.6.4.0
mono(nunit.util) = 2.6.4.0
mono(nunit.util.tests) = 2.6.4.0
mono(pnunit-agent) = 1.0.6136.11838
mono(pnunit-launcher) = 1.0.6136.11838
mono(pnunit.framework) = 1.0.6136.11834
mono(pnunit.tests) = 1.0.6136.11835
mono(test-assembly) = 2.6.4.0
mono(test-assembly-net45) = 2.6.4.0
mono(test-utilities) = 2.6.4.0
nunit = 2.6.4-4.29

Download

Type URL
Binary Package nunit-2.6.4-4.29.noarch.rpm
Source Package nunit-2.6.4-4.29.src.rpm

Install Howto

Install nunit rpm package:

# zypper install nunit

Files

Path
/usr/bin/nunit

See Also

Package Description
nunit-devel-2.6.4-4.29.noarch.rpm Development files for NUnit
nuosu-fonts-2.1.1-6.1.noarch.rpm SIL Yi Font
nuoveXT2-icon-theme-0.5.1-4.1.noarch.rpm This package provides the default LXDE icon theme
nut-2.7.1-2.41.x86_64.rpm Network UPS Tools Core (Unbreakable Power Supply Monitoring)
nut-cgi-2.7.1-2.41.x86_64.rpm Network UPS Tools Web Server Support (UPS Status Pages)
nut-devel-2.7.1-2.41.x86_64.rpm Network UPS Tools (Unbreakable Power Supply Monitoring)
nut-drivers-net-2.7.1-2.41.x86_64.rpm Network UPS Tools - Extra Networking Drivers (for Network Monitoring)
nvdock-1.02-16.3.x86_64.rpm Tray icon for launching NVIDIA Settings
nvidia-texture-tools-2.0.8-4.17.x86_64.rpm NVIDIA Texture Tools
nvme-cli-0.7-1.1.x86_64.rpm Core nvme tools
nvml-0.2-3.3.x86_64.rpm Non-Volatile Memory Library
nvml-tools-0.2-3.3.x86_64.rpm Utilities for Persistent Memory
nxtvepg-2.8.1-25.25.x86_64.rpm Nextview EPG Decoder and Browser
obby-0.4.8-11.3.x86_64.rpm Synced document buffers
obby-devel-0.4.8-11.3.x86_64.rpm Synced document buffers
Advertisement
Advertisement