qnapi-0.2.0-7.4.x86_64.rpm


Advertisement

Description

qnapi - A NapiProjekt client

Property Value
Distribution openSUSE Leap 42.2
Repository openSUSE KDE Extra all
Package name qnapi
Package version 0.2.0
Package release 7.4
Package architecture x86_64
Package type rpm
Installed size 974.85 KB
Download size 348.39 KB
Official Mirror ftp.gwdg.de
QNapi is unofficial clone of NapiProjekt program (http://napiprojekt.pl)
written using Qt5. It's focused to be functional on GNU/Linux and other
Unix-like systems, for which NapiProjekt is not available.

Alternatives

Package Version Architecture Repository
qnapi-0.2.0-1.1.x86_64.rpm 0.2.0 x86_64 openSUSE Oss
qnapi - - -

Requires

Name Value
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.6)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Network.so.5()(64bit) -
libQt5Network.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libQt5Xml.so.5()(64bit) -
libQt5Xml.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
p7zip -

Provides

Name Value
application() -
application(qnapi.desktop) -
qnapi = 0.2.0-7.4
qnapi(x86-64) = 0.2.0-7.4

Download

Type URL
Binary Package qnapi-0.2.0-7.4.x86_64.rpm
Source Package qnapi-0.2.0-7.4.src.rpm

Install Howto

  1. Add the openSUSE KDE Extra repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/KDE:/Extra/openSUSE_Leap_42.2/ opensuse-kde-extra
  2. Install qnapi rpm package:
    # zypper install qnapi

Files

Path
/usr/bin/qnapi
/usr/share/applications/qnapi.desktop
/usr/share/doc/packages/qnapi/COPYRIGHT
/usr/share/doc/packages/qnapi/ChangeLog
/usr/share/doc/packages/qnapi/LICENSE
/usr/share/doc/packages/qnapi/LICENSE-pl
/usr/share/doc/packages/qnapi/qnapi-download.desktop
/usr/share/doc/packages/qnapi/qnapi-download.schemas
/usr/share/doc/packages/qnapi/qnapi-scan.desktop
/usr/share/doc/packages/qnapi/qnapi-scan.schemas
/usr/share/icons/hicolor/
/usr/share/icons/hicolor/128x128/
/usr/share/icons/hicolor/128x128/apps/qnapi.png
/usr/share/icons/hicolor/16x16/
/usr/share/icons/hicolor/16x16/apps/qnapi.png
/usr/share/icons/hicolor/32x32/
/usr/share/icons/hicolor/32x32/apps/qnapi.png
/usr/share/icons/hicolor/48x48/
/usr/share/icons/hicolor/48x48/apps/qnapi.png
/usr/share/icons/hicolor/512x512/
/usr/share/icons/hicolor/512x512/apps/qnapi.png
/usr/share/kde4/
/usr/share/kde4/services/
/usr/share/kde4/services/ServiceMenus/qnapi-download.desktop
/usr/share/kde4/services/ServiceMenus/qnapi-scan.desktop
/usr/share/kservices5/
/usr/share/kservices5/ServiceMenus/qnapi-download.desktop
/usr/share/kservices5/ServiceMenus/qnapi-scan.desktop
/usr/share/man/man1/qnapi.1.gz

Changelog

2015-12-19 - fisiu@opensuse.org
- Update to 0.2.0:
* bugfix in napisy24 engine
* icons placed at directories according to their sizes
* bugfixes in file encoding detection
* preserving original file encoding during subtitle format conversion
* bugfixed backup language support
- Drop 0001-fix-license-headers-in-source-files.patch: fixed upstream
- Drop fix-icons-paths.patch: fixed upstream
- Drop qnapi-napisy24.pl-skip-.url.patch: fixed upstream
2015-10-31 - fisiu@opensuse.org
- Add qnapi-napisy24.pl-skip-.url.patch: fix napisy24.pl plugin.
2015-09-05 - fisiu@opensuse.org
- Update to 1.9.0:
* conversion between subtitle formas: SRT, mDVD, TMP, MPL2 (requires ffprobe)
* select target extension of subtitles
* directory scanning now can see other subtitle extensions than .txt (also .srt and .sub)
* respect INSTALL_PREFIX on icons and desktop files installation
- Add 0001-fix-license-headers-in-source-files.patch: fix license headers.
- Add fix-icons-paths.patch: fix icons directories.
2015-08-14 - fisiu@opensuse.org
- Update to 1.8.0:
* support for backup language for subtitle download
* fixed issue with window placing in multi-screen environment
- Update to 1.7.0:
* new subtitle engine for Napisy24 (by fenuks)
* migration to Qt5
* diacritic characters replacement with ASCII counterparts
in subtitle post-processing
* GUI/CLI interface improvements
* lot of minor bugfixes
2013-12-29 - fisiu@opensuse.org
- Spec cleanup. It seems qnapi is not maintained anymore,
but it still works fine.
2009-03-04 - fisiu82@gmail.com
- upstream version
2008-12-27 - fisiu82@gmail.com
- added service menus for KDE4
2008-04-07 - obi.gts@gmail.com
- 0.1.4
2008-03-01 - obi.gts@gmail.com
- 0.1.3
2008-02-20 - obi.gts@gmail.com
- 0.1.2

See Also

Package Description
qpass-1.3.2-1.17.x86_64.rpm Password Manager
qremotecontrol-2.4.0-2.52.x86_64.rpm Remote Control Application
qtcurve-gtk2-1.9.0-3.2.x86_64.rpm QtCurve style for GTK+ 2
qtcurve-gtk2-1.9.0-32.1.x86_64.rpm QtCurve style for GTK+ 2
qtcurve-kde4-1.9.0-3.2.x86_64.rpm QtCurve style for KDE 4
qtcurve-kde4-1.9.0-32.1.x86_64.rpm QtCurve style for KDE 4
qtcurve-qt5-1.9.0-3.2.x86_64.rpm QtCurve style for Qt 5
qtcurve-qt5-1.9.0-32.1.x86_64.rpm QtCurve style for Qt 5
qtkeychain-devel-0.7.0-7.5.x86_64.rpm Platform-independent Qt API for storing passwords securely
qtkeychain-lang-0.7.0-7.5.x86_64.rpm Platform-independent Qt API for storing passwords securely
quassel-base-0.12.4-61.3.x86_64.rpm Modern, cross-platform, distributed IRC client
quassel-client-0.12.4-61.3.x86_64.rpm Modern, cross-platform, distributed IRC client
quassel-client-qt5-0.12.4-61.3.x86_64.rpm Modern, cross-platform, distributed IRC client
quassel-core-0.12.4-61.3.x86_64.rpm Modern, cross-platform, distributed IRC client
quassel-mono-0.12.4-61.3.x86_64.rpm Modern, cross-platform, distributed IRC client
Advertisement
Advertisement