python-jedi-0.9.0-10.3.noarch.rpm


Advertisement

Description

python-jedi - An autocompletion tool for Python

Property Value
Distribution openSUSE Leap 42.2
Repository openSUSE KDE Extra all
Package name python-jedi
Package version 0.9.0
Package release 10.3
Package architecture noarch
Package type rpm
Installed size 931.44 KB
Download size 221.41 KB
Official Mirror ftp.gwdg.de
Jedi is an autocompletion tool for Python. It works. With and without syntax
errors. Sometimes it sucks, but that's normal in dynamic languages. But it
sucks less than other tools. It understands almost all of the basic Python
syntax elements including many builtins.
Jedi suports two different goto functions and has support for renaming.
Probably it will also have some support for refactoring in the future.
Jedi uses a very simple interface to connect with IDE's. As an reference, there
is a VIM implementation, which uses Jedi's autocompletion. However, I encourage
you to use Jedi in your IDEs. Start writing plugins! If there are problems with
licensing, just contact me.

Alternatives

Package Version Architecture Repository
python-jedi-0.9.0-4.1.noarch.rpm 0.9.0 noarch openSUSE Oss
python-jedi - - -

Requires

Name Value
python(abi) = 2.7
python-docopt -

Provides

Name Value
python-jedi = 0.9.0-10.3

Download

Type URL
Binary Package python-jedi-0.9.0-10.3.noarch.rpm
Source Package python-jedi-0.9.0-10.3.src.rpm

Install Howto

  1. Add the openSUSE KDE Extra repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/KDE:/Extra/openSUSE_Leap_42.2/ opensuse-kde-extra
  2. Install python-jedi rpm package:
    # zypper install python-jedi

Files

Path
/usr/lib/python2.7/site-packages/jedi/__init__.py
/usr/lib/python2.7/site-packages/jedi/__init__.pyc
/usr/lib/python2.7/site-packages/jedi/__main__.py
/usr/lib/python2.7/site-packages/jedi/__main__.pyc
/usr/lib/python2.7/site-packages/jedi/_compatibility.py
/usr/lib/python2.7/site-packages/jedi/_compatibility.pyc
/usr/lib/python2.7/site-packages/jedi/cache.py
/usr/lib/python2.7/site-packages/jedi/cache.pyc
/usr/lib/python2.7/site-packages/jedi/common.py
/usr/lib/python2.7/site-packages/jedi/common.pyc
/usr/lib/python2.7/site-packages/jedi/debug.py
/usr/lib/python2.7/site-packages/jedi/debug.pyc
/usr/lib/python2.7/site-packages/jedi/refactoring.py
/usr/lib/python2.7/site-packages/jedi/refactoring.pyc
/usr/lib/python2.7/site-packages/jedi/settings.py
/usr/lib/python2.7/site-packages/jedi/settings.pyc
/usr/lib/python2.7/site-packages/jedi/utils.py
/usr/lib/python2.7/site-packages/jedi/utils.pyc
/usr/lib/python2.7/site-packages/jedi-0.9.0-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/jedi-0.9.0-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/jedi-0.9.0-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/jedi-0.9.0-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/jedi/api/__init__.py
/usr/lib/python2.7/site-packages/jedi/api/__init__.pyc
/usr/lib/python2.7/site-packages/jedi/api/classes.py
/usr/lib/python2.7/site-packages/jedi/api/classes.pyc
/usr/lib/python2.7/site-packages/jedi/api/helpers.py
/usr/lib/python2.7/site-packages/jedi/api/helpers.pyc
/usr/lib/python2.7/site-packages/jedi/api/interpreter.py
/usr/lib/python2.7/site-packages/jedi/api/interpreter.pyc
/usr/lib/python2.7/site-packages/jedi/api/keywords.py
/usr/lib/python2.7/site-packages/jedi/api/keywords.pyc
/usr/lib/python2.7/site-packages/jedi/api/replstartup.py
/usr/lib/python2.7/site-packages/jedi/api/replstartup.pyc
/usr/lib/python2.7/site-packages/jedi/api/usages.py
/usr/lib/python2.7/site-packages/jedi/api/usages.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/__init__.py
/usr/lib/python2.7/site-packages/jedi/evaluate/__init__.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/analysis.py
/usr/lib/python2.7/site-packages/jedi/evaluate/analysis.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/cache.py
/usr/lib/python2.7/site-packages/jedi/evaluate/cache.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/docstrings.py
/usr/lib/python2.7/site-packages/jedi/evaluate/docstrings.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/dynamic.py
/usr/lib/python2.7/site-packages/jedi/evaluate/dynamic.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/finder.py
/usr/lib/python2.7/site-packages/jedi/evaluate/finder.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/flow_analysis.py
/usr/lib/python2.7/site-packages/jedi/evaluate/flow_analysis.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/helpers.py
/usr/lib/python2.7/site-packages/jedi/evaluate/helpers.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/imports.py
/usr/lib/python2.7/site-packages/jedi/evaluate/imports.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/iterable.py
/usr/lib/python2.7/site-packages/jedi/evaluate/iterable.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/param.py
/usr/lib/python2.7/site-packages/jedi/evaluate/param.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/precedence.py
/usr/lib/python2.7/site-packages/jedi/evaluate/precedence.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/recursion.py
/usr/lib/python2.7/site-packages/jedi/evaluate/recursion.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/representation.py
/usr/lib/python2.7/site-packages/jedi/evaluate/representation.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/stdlib.py
/usr/lib/python2.7/site-packages/jedi/evaluate/stdlib.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/sys_path.py
/usr/lib/python2.7/site-packages/jedi/evaluate/sys_path.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/__init__.py
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/__init__.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/fake.py
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/fake.pyc
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/fake/_functools.pym
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/fake/_sqlite3.pym
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/fake/_sre.pym
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/fake/_weakref.pym
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/fake/builtins.pym
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/fake/datetime.pym
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/fake/io.pym
/usr/lib/python2.7/site-packages/jedi/evaluate/compiled/fake/posix.pym
/usr/lib/python2.7/site-packages/jedi/parser/__init__.py
/usr/lib/python2.7/site-packages/jedi/parser/__init__.pyc
/usr/lib/python2.7/site-packages/jedi/parser/fast.py
/usr/lib/python2.7/site-packages/jedi/parser/fast.pyc
/usr/lib/python2.7/site-packages/jedi/parser/grammar2.7.txt
/usr/lib/python2.7/site-packages/jedi/parser/grammar3.4.txt
/usr/lib/python2.7/site-packages/jedi/parser/token.py
/usr/lib/python2.7/site-packages/jedi/parser/token.pyc
/usr/lib/python2.7/site-packages/jedi/parser/tokenize.py
/usr/lib/python2.7/site-packages/jedi/parser/tokenize.pyc
/usr/lib/python2.7/site-packages/jedi/parser/tree.py
/usr/lib/python2.7/site-packages/jedi/parser/tree.pyc
/usr/lib/python2.7/site-packages/jedi/parser/user_context.py
/usr/lib/python2.7/site-packages/jedi/parser/user_context.pyc
/usr/lib/python2.7/site-packages/jedi/parser/pgen2/__init__.py
/usr/lib/python2.7/site-packages/jedi/parser/pgen2/__init__.pyc
/usr/lib/python2.7/site-packages/jedi/parser/pgen2/grammar.py
/usr/lib/python2.7/site-packages/jedi/parser/pgen2/grammar.pyc
/usr/lib/python2.7/site-packages/jedi/parser/pgen2/parse.py
/usr/lib/python2.7/site-packages/jedi/parser/pgen2/parse.pyc
/usr/lib/python2.7/site-packages/jedi/parser/pgen2/pgen.py
/usr/lib/python2.7/site-packages/jedi/parser/pgen2/pgen.pyc
/usr/share/doc/packages/python-jedi/AUTHORS.txt
/usr/share/doc/packages/python-jedi/CHANGELOG.rst
/usr/share/doc/packages/python-jedi/LICENSE.txt
/usr/share/doc/packages/python-jedi/README.rst

Changelog

2015-11-05 - toddrme2178@gmail.com
- Fix tests
2015-05-06 - benoit.monin@gmx.fr
- update to version 0.9.0:
* The import logic has been rewritten to look more like Python's.
There is now an Evaluator.modules import cache, which resembles
sys.modules.
* Integrated the parser of 2to3. This will make refactoring
possible. It will also be possible to check for error messages
(like compiling an AST would give) in the future.
* With the new parser, the evaluation also completely changed.
It's now simpler and more readable.
* Completely rewritten REPL completion.
* Added jedi.names, a command to do static analysis. Thanks to
that sourcegraph guys for sponsoring this!
* Alpha version of the linter.
- remove "-final0" appended to source version
- add python-unittest2 as a test dependency for SLE11
- skip failing tests in test_integration_import.py
2014-08-13 - toddrme2178@gmail.com
- Update to version 0.8.1
* Bugfix release, the last release forgot to include files that
improve autocompletion for builtin libraries. Fixed.
- Update to version 0.8.0
* Memory Consumption for compiled modules (e.g. builtins, sys)
has been reduced drastically. Loading times are down as well
(it takes basically as long as an import).
* REPL completion is starting to become usable.
* Various small API changes. Generally this released focuses on
stability and refactoring of internal APIs.
* Introducing operator precedence, which makes calculating
correct Array indices and __getattr__ strings possible.
2013-12-08 - p.drouand@gmail.com
- Update to version 0.7.0
* switched from LGPL to MIT license
* added an Interpreter class to the API to make autocompletion
in REPL possible.
* added autocompletion support for namespace packages
* add sith.py, a new random testing method
- Change License to MIT
- Drop old python3 stuff
2013-10-24 - speilicke@suse.com
- Require python-setuptools instead of distribute (upstreams merged)
2013-08-15 - mvyskocil@suse.com
- update to 0.6.0
* Created find_module helper to handle compatibility with python 3.3
* Fixed caching issues
* More robust source encoding detection
* Improved documentantion
* and lot of bugfixes
- drop pre-checkin.sh
- drop a dependency on rpmbuild > 4.10, we don't need no ~ in version
2013-05-09 - mvyskocil@suse.com
- package python3 variant via pre_checkin.sh
2013-05-02 - mvyskocil@suse.com
- first packaging of jedi 0.5b5 for SUSE

See Also

Package Description
python-numpy-1.14.0-6.1.x86_64.rpm NumPy array processing for numbers, strings, records and objects
python-numpy-devel-1.14.0-6.1.x86_64.rpm Development files for numpy applications
python-pep8-1.7.0-74.1.noarch.rpm Python style guide checker
python-pivy-0.5.0hg.609-1.8.x86_64.rpm Coin Binding for Python
python-py-1.5.2-60.1.noarch.rpm Library with cross-python path, ini-parsing, io, code, log facilities
python-pychm-0.8.4.1-5.1.x86_64.rpm Python package to handle CHM files
python-pyjslint-0.3.4-2.3.noarch.rpm JSLint wrapper
python-pyplete-0.0.5-7.3.noarch.rpm An interface to autocomplete in python
python-pysmell-0.7.3-8.3.noarch.rpm Autocompletion library for Python
python-pytest-3.4.1-90.1.noarch.rpm Python testing tool with autodiscovery and detailed asserts
python-rarfile-3.0-8.16.noarch.rpm RAR Archive Reader for Python
python-rarfile-doc-3.0-8.16.noarch.rpm RAR Archive Reader for Python (Documentation)
python-setuptools-28.3.0-87.1.noarch.rpm Easily download, build, install, upgrade, and uninstall Python packages
python2-opencv-3.3.1-112.10.x86_64.rpm Python 2 bindings for apps which use OpenCV
python2-pocketsphinx-0.8-1.46.x86_64.rpm Python bindings for pocketsphinx
Advertisement
Advertisement