imlib-1.9.14-411.3.x86_64.rpm


Advertisement

Description

imlib - A Shared Library for Loading and Rendering 3D Images

Distribution: openSUSE 42.2
Repository: openSUSE Games all
Package name: imlib
Package version: 1.9.14
Package release: 411.3
Package architecture: x86_64
Package type: rpm
Installed size: 485.26 KB
Download size: 130.37 KB
Official Mirror: ftp.gwdg.de
This is a general, all-purpose image loading and rendering (image data to screen data) library. Imlib is currently capable of loading 25 different image formats. See the file /usr/include/X11/imlib.h or directory /usr/share/doc/packages/imlib for more details. This shared library is needed for the Enlightenment window manager and for GNOME.

Alternatives

Provides

  • config(imlib) = 1.9.14-411.3
  • imlib = 1.9.14-411.3
  • imlib(x86-64) = 1.9.14-411.3
  • libImlib.so.1()(64bit)
  • libgdk_imlib.so.1()(64bit)
  • libimlib-bmp.so()(64bit)
  • libimlib-gif.so()(64bit)
  • libimlib-jpeg.so()(64bit)
  • libimlib-png.so()(64bit)
  • libimlib-ppm.so()(64bit)
  • libimlib-ps.so()(64bit)
  • libimlib-tiff.so()(64bit)
  • libimlib-xpm.so()(64bit)

    Download

    Install Howto

    1. Add the openSUSE Games repository:
      # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/games/openSUSE_Leap_42.2/ opensuse-games
    2. Install imlib rpm package:
      # zypper install imlib

    Files

    • /etc/im_palette-small.pal
    • /etc/im_palette-tiny.pal
    • /etc/im_palette.pal
    • /etc/imrc
    • /usr/lib64/libImlib.so.1
    • /usr/lib64/libImlib.so.1.9.14
    • /usr/lib64/libgdk_imlib.so.1
    • /usr/lib64/libgdk_imlib.so.1.9.14
    • /usr/lib64/libimlib-bmp.so
    • /usr/lib64/libimlib-gif.so
    • /usr/lib64/libimlib-jpeg.so
    • /usr/lib64/libimlib-png.so
    • /usr/lib64/libimlib-ppm.so
    • /usr/lib64/libimlib-ps.so
    • /usr/lib64/libimlib-tiff.so
    • /usr/lib64/libimlib-xpm.so
    • /usr/share/doc/packages/imlib/AUTHORS
    • /usr/share/doc/packages/imlib/NEWS
    • /usr/share/doc/packages/imlib/README

    Changelog

    2016-01-18 - dimstar@opensuse.org - Fixup imlib-1.9.14-gif.patch to actually work.

    2013-04-23 - joop.boonen@opensuse.org - Add imlib-1.9.14-gif.patch: Fix build with giflib 5

    2013-01-19 - joop.boonen@opensuse.org - Add imlib-1.9.14-libpng15.diff: Fix build with libpng > 1.4. - Cleaned the spec file up.

    2012-07-18 - sbrabec@suse.cz - Update BuildRequires.

    2010-02-13 - coolo@novell.com - do not require libjpeg

    2010-01-31 - jengelh@medozas.de - package baselibs.conf

    2009-01-13 - crrodriguez@suse.de - remove static libraries and "la" files - fix broken -devel package dependencies

    2008-12-10 - olh@suse.de - use Obsoletes: -XXbit only for ppc64 to help solver during distupgrade (bnc#437293)

    2008-12-04 - olh@suse.de - obsolete old -XXbit packages (bnc#437293)

    2008-05-06 - schwab@suse.de - Don't use libtool before it is created.

    Advertisement
    Advertisement