glib-1.2.10-745.2.x86_64.rpm


Advertisement

Description

glib - The Utility Functions for Gtk

Distribution: openSUSE 42.2
Repository: openSUSE Games all
Package name: glib
Package version: 1.2.10
Package release: 745.2
Package architecture: x86_64
Package type: rpm
Installed size: 411.39 KB
Download size: 128.61 KB
Official Mirror: ftp.gwdg.de
A library of utility functions for Gtk.

Alternatives

  • glib All Repositories

Provides

  • glib = 1.2.10-745.2
  • glib(x86-64) = 1.2.10-745.2
  • libglib-1.2.so.0()(64bit)
  • libgmodule-1.2.so.0()(64bit)
  • libgthread-1.2.so.0()(64bit)

    Download

    Install Howto

    1. Add the openSUSE Games repository:
      # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/games/openSUSE_Leap_42.2/ opensuse-games
    2. Install glib rpm package:
      # zypper install glib

    Files

    • /usr/lib64/libglib-1.2.so.0
    • /usr/lib64/libglib-1.2.so.0.0.10
    • /usr/lib64/libgmodule-1.2.so.0
    • /usr/lib64/libgmodule-1.2.so.0.0.10
    • /usr/lib64/libgthread-1.2.so.0
    • /usr/lib64/libgthread-1.2.so.0.0.10
    • /usr/share/doc/packages/glib/AUTHORS
    • /usr/share/doc/packages/glib/COPYING
    • /usr/share/doc/packages/glib/ChangeLog
    • /usr/share/doc/packages/glib/NEWS
    • /usr/share/doc/packages/glib/README

    Changelog

    2015-12-07 - rpm@fthiessen.de - Added glib-1.2.10-gcc5.patch from Fedora to workaround for different inline semantics between GNU89 and C99, needed for openSUSE > 1320.

    2013-01-19 - joop.boonen@opensuse.org - Cleaned the spec file up

    2012-07-18 - sbrabec@suse.cz - Fix for new autotools. - Update BuildRequires.

    2010-10-27 - sbrabec@suse.cz - Added pkg-config to BuildRequires to provide pkgconfig(glib).

    2009-12-17 - jengelh@medozas.de - Add baselibs.conf as a source

    2009-04-22 - vuntz@novell.com - Keep .la files for openSUSE <= 11.1.

    2009-04-17 - crrodriguez@suse.de - remove static libraries and "la" files

    2008-12-10 - olh@suse.de - use Obsoletes: -XXbit only for ppc64 to help solver during distupgrade (bnc#437293)

    2008-11-24 - olh@suse.de - obsolete old -XXbit packages (bnc#437293)

    2008-04-10 - ro@suse.de - added baselibs.conf file to build xxbit packages for multilib support

    Advertisement
    Advertisement