allegro44-4.4.2-1.1.x86_64.rpm


Advertisement

Description

allegro44 - Cross-platform library for games and multimedia programming

Distribution: openSUSE 42.2
Repository: openSUSE Games all
Package name: allegro44
Package version: 4.4.2
Package release: 1.1
Package architecture: x86_64
Package type: rpm
Installed size: 43.60 KB
Download size: 13.73 KB
Official Mirror: ftp.gwdg.de
Allegro is a cross-platform library intended for use in computer games and other types of multimedia programming. A wide range of extension packages and add-on modules are also available, which can be found in the "Library Extensions" section of the Allegro website.

Alternatives

Provides

  • alleg-alsadigi.so()(64bit)
  • alleg-alsamidi.so()(64bit)
  • allegro44 = 4.4.2-1.1
  • allegro44(x86-64) = 4.4.2-1.1

    Download

    Install Howto

    1. Add the openSUSE Games repository:
      # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/games/openSUSE_Leap_42.2/ opensuse-games
    2. Install allegro44 rpm package:
      # zypper install allegro44

    Files

    • /usr/lib64/allegro/
    • /usr/lib64/allegro/4.4.2/alleg-alsadigi.so
    • /usr/lib64/allegro/4.4.2/alleg-alsamidi.so
    • /usr/lib64/allegro/4.4.2/modules.lst

    Changelog

    2017-09-21 - rpm@fthiessen.de - Renamed to allegro44

    2015-05-17 - meissner@suse.com - info deinstall needs to be in preun section

    2014-12-22 - nemysis@gmx.ch - Use for patch(es) %{name}-version instead of %{name}-%{version}

    2014-12-19 - nemysis@gmx.ch - Use SED-FIX-OPENSUSE for sed

    2014-12-18 - nemysis@gmx.ch - Rename allegro4 to allegro - Change Summary - Change URL for The giftware licence - Use for patches %{name}-%{version} instead of liballeg4_4 or allegro-4.4.2 and add descriptions for patches - Add patch allegro4-4.4.2-src_x_xkeyboard.c.patch - Use check for openSUSE %if 0%{?suse_version} - Change Description - Add sed, fix include xf86dga.h

    2014-12-07 - mailaender@opensuse.org - fixed rpmlint warnings

    2014-05-02 - bwiedemann@suse.com - Add 32bit modules.lst via baselibs.conf

    2012-09-22 - reddwarf@opensuse.org - Add texinfo BuildRequires

    2012-04-19 - reddwarf@opensuse.org - Update to 4.4.2

    2011-05-15 - reddwarf@opensuse.org - Fix main pkg-config, requiring X11 related packages. Through RPM magic automatically fixes the package dependencies.

    Advertisement
    Advertisement