libgtkglext-x11-1_0-0-1.2.0-13.4.x86_64.rpm


Advertisement

Description

libgtkglext-x11-1_0-0 - OpenGL Extension to GTK

Property Value
Distribution openSUSE Leap 42.2
Repository openSUSE Education all
Package name libgtkglext-x11-1_0-0
Package version 1.2.0
Package release 13.4
Package architecture x86_64
Package type rpm
Installed size 629.81 KB
Download size 119.23 KB
Official Mirror ftp.gwdg.de
GtkGLExt is an OpenGL extension to GTK. It provides the GDK objects
that support OpenGL rendering in GTK and GtkWidget API add-ons, to make
GTK+ widgets OpenGL-capable.

Alternatives

Package Version Architecture Repository
libgtkglext-x11-1_0-0-1.2.0git20110529-6.4.x86_64.rpm 1.2.0git20110529 x86_64 openSUSE Oss
libgtkglext-x11-1_0-0 - - -

Requires

Name Value
/sbin/ldconfig -
libGL.so.1()(64bit) -
libGLU.so.1()(64bit) -
libX11.so.6()(64bit) -
libXmu.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libgdk-x11-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgmodule-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-x11-2.0.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpango-1.0.so.0()(64bit) -
libpangox-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -

Provides

Name Value
gtkglext = 1.2.0
libgdkglext-x11-1.0.so.0()(64bit) -
libgtkglext-x11-1.0.so.0()(64bit) -
libgtkglext-x11-1_0-0 = 1.2.0-13.4
libgtkglext-x11-1_0-0(x86-64) = 1.2.0-13.4

Obsoletes

Name Value
gtkglext <= 1.2.0

Download

Type URL
Binary Package libgtkglext-x11-1_0-0-1.2.0-13.4.x86_64.rpm
Source Package gtkglext-1.2.0-13.4.src.rpm

Install Howto

  1. Add the openSUSE Education repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Education/openSUSE_Leap_42.2/ opensuse-education
  2. Install libgtkglext-x11-1_0-0 rpm package:
    # zypper install libgtkglext-x11-1_0-0

Files

Path
/usr/lib64/libgdkglext-x11-1.0.so.0
/usr/lib64/libgdkglext-x11-1.0.so.0.0.0
/usr/lib64/libgtkglext-x11-1.0.so.0
/usr/lib64/libgtkglext-x11-1.0.so.0.0.0
/usr/share/doc/packages/libgtkglext-x11-1_0-0/AUTHORS
/usr/share/doc/packages/libgtkglext-x11-1_0-0/COPYING
/usr/share/doc/packages/libgtkglext-x11-1_0-0/COPYING.LIB
/usr/share/doc/packages/libgtkglext-x11-1_0-0/ChangeLog
/usr/share/doc/packages/libgtkglext-x11-1_0-0/README
/usr/share/doc/packages/libgtkglext-x11-1_0-0/TODO

Changelog

2014-03-21 - avvissu@yandex.ru
- Fix for SLE_11: The build can not begin, because required
packages are missing...:
* add RPM conditional tests for %suse_version
2014-03-20 - badshah400@gmail.com
- Use full URL for source
- Do not package INSTALL file (fixes rpmlint install-file-in-docs
warning)
- Use https://projects.gnome.org/gtkglext/ for the Url (the
previous one was simply a redirector to this).
2014-03-20 - avvissu@yandex.ru
- Downgrade gtlglext for all packages with support pango
2013-11-19 - stecue@gmail.com
- Downgrade gtlglext to 1.2.0 for gabedit.
- Note pangox-compat is needed for this version.
2013-01-09 - dmitry_r@opensuse.org
- -Reintroduce gtkglext and Update to git-20110529 (bnc#799544):
* no longer depends on pangox
- NOTE: gtkglext is unmaintained and provided as-is for 3rd party
packages only. Nothing inside openSUSE is supposed to use it.
2012-02-19 - coolo@suse.com
- Add more explicit requires of devel package: the pkgconfig
file references some libraries in Libs (and not Requires), so we
need to depend on them.
2011-12-22 - vuntz@opensuse.org
- Explicitly list files we package.
2010-10-11 - vuntz@opensuse.org
- Update packaging to use the shared library packaging policy:
+ Create libgtkglext-x11-1_0-0 subpackage.
+ Add Provides/Obsoletes for gtkglext to libgtkglext-x11-1_0-0.
+ Update baselibs.conf accordingly.
2010-07-05 - vuntz@opensuse.org
- Add gtkglext-no-deprecated-flags.patch to not build gtkglext with
the *_DISABLE_DEPRECATED flags. This makes the build more robust
when some API is marked as deprecated. Unfortunately, without
this, the gtkglext library is looking for unknown symbols that
should actually be macros at build time. Fix bnc#617677.
- Drop gtkglext-gtk_widget_toplevel.patch: this is not needed
anymore thanks to gtkglext-no-deprecated-flags.patch.
2010-03-04 - dimstar@opensuse.org
- Add gtkglext-gtk_widget_toplevel.patch to drop deprecated usage
of GTK_WIDGET_TOPLEVEL, bnc#585137, bgo#611803, reported and
patched by Guillermo Ballester Valor.
- Clean spec file.

See Also

Package Description
libgtkglextmm-x11-1_2-0-1.2.0-128.10.x86_64.rpm C++ wrapper for GtkGLExt
libhydrogen-core-devel-0.9.7-5.1.x86_64.rpm Development files and headers for libhydrogen-core
libhydrogen-core0-0.9.7-5.1.x86_64.rpm Library essential for the hydrogen drum machine software
libinchi0-2.4.1-18.1.x86_64.rpm Component library of Open Babel, a chemistry toolbox
libiniparser-devel-4.1-1.1.x86_64.rpm Libraries and Header Files to Develop Programs with libiniparser Support
libiniparser1-4.1-1.1.x86_64.rpm Library to parse ini files
libinotifytools-devel-3.14-4.2.x86_64.rpm Development files for inotify
libinotifytools0-3.14-4.2.x86_64.rpm Library for inotify
libjlibnxt-0.9-0.9.1beta-3.15.x86_64.rpm Lejos nxj native library
libjlibnxt-devel-0.9-0.9.1beta-3.15.x86_64.rpm Lejos nxj native library include
libjnidispatch-4.2.2-44.1.x86_64.rpm Java Native Access (shared library)
libklu-1_3_8-1.3.8-70.1.x86_64.rpm Sparse LU Factorization, for Circuit Simulation
libkpmcore4-3.0.3-1.1.x86_64.rpm KDE Partition Manager core library
liblapack3-3.8.0-74.1.x86_64.rpm LAPACK Shared Library
liblapacke3-3.8.0-74.1.x86_64.rpm LAPACKE development files
Advertisement
Advertisement