epoptes-0.5.9_bzr0.545-68.1.noarch.rpm


Advertisement

Description

epoptes - Computer lab management tool

Distribution: openSUSE 42.2
Repository: openSUSE Education all
Package name: epoptes
Package version: 0.5.9_bzr0.545
Package release: 68.1
Package architecture: noarch
Package type: rpm
Installed size: 1.77 MB
Download size: 234.83 KB
Official Mirror: ftp.gwdg.de
Epoptes (??????? - a Greek word for overseer) is an open source computer lab management and monitoring tool. It allows for screen broadcasting and monitoring, remote command execution, message sending, imposing restrictions like screen locking or sound muting the clients and much more! Visit http://epoptes.org for more information.

Alternatives

Provides

  • application()
  • application(epoptes.desktop)
  • config(epoptes) = 0.5.9_bzr0.545-68.1
  • epoptes = 0.5.9_bzr0.545-68.1

    Install Howto

    1. Add the openSUSE Education repository:
      # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Education/openSUSE_Leap_42.2/ opensuse-education
    2. Install epoptes rpm package:
      # zypper install epoptes

    Files

    • /etc/default/epoptes
    • /etc/sysconfig/SuSEfirewall2.d/services/epoptes
    • /usr/bin/epoptes
    • /usr/lib/python2.7/site-packages/epoptes-0.5.10_1-py2.7.egg-info
    • /usr/lib/python2.7/site-packages/epoptes/__init__.py
    • /usr/lib/python2.7/site-packages/epoptes/__init__.pyc
    • /usr/lib/python2.7/site-packages/epoptes/common/__init__.py
    • /usr/lib/python2.7/site-packages/epoptes/common/__init__.pyc
    • /usr/lib/python2.7/site-packages/epoptes/common/config.py
    • /usr/lib/python2.7/site-packages/epoptes/common/config.pyc
    • /usr/lib/python2.7/site-packages/epoptes/common/constants.py
    • /usr/lib/python2.7/site-packages/epoptes/common/constants.pyc
    • /usr/lib/python2.7/site-packages/epoptes/common/ltsconf.py
    • /usr/lib/python2.7/site-packages/epoptes/common/ltsconf.pyc
    • /usr/lib/python2.7/site-packages/epoptes/common/xdg_dirs.py
    • /usr/lib/python2.7/site-packages/epoptes/common/xdg_dirs.pyc
    • /usr/lib/python2.7/site-packages/epoptes/core/__init__.py
    • /usr/lib/python2.7/site-packages/epoptes/core/__init__.pyc
    • /usr/lib/python2.7/site-packages/epoptes/core/lib_users.py
    • /usr/lib/python2.7/site-packages/epoptes/core/lib_users.pyc
    • /usr/lib/python2.7/site-packages/epoptes/core/structs.py
    • /usr/lib/python2.7/site-packages/epoptes/core/structs.pyc
    • /usr/lib/python2.7/site-packages/epoptes/core/wol.py
    • /usr/lib/python2.7/site-packages/epoptes/core/wol.pyc
    • /usr/lib/python2.7/site-packages/epoptes/daemon/__init__.py
    • /usr/lib/python2.7/site-packages/epoptes/daemon/__init__.pyc
    • /usr/lib/python2.7/site-packages/epoptes/daemon/bashplex.py
    • /usr/lib/python2.7/site-packages/epoptes/daemon/bashplex.pyc
    • /usr/lib/python2.7/site-packages/epoptes/daemon/commands.py
    • /usr/lib/python2.7/site-packages/epoptes/daemon/commands.pyc
    • /usr/lib/python2.7/site-packages/epoptes/daemon/exchange.py
    • /usr/lib/python2.7/site-packages/epoptes/daemon/exchange.pyc
    • /usr/lib/python2.7/site-packages/epoptes/daemon/guiplex.py
    • /usr/lib/python2.7/site-packages/epoptes/daemon/guiplex.pyc
    • /usr/lib/python2.7/site-packages/epoptes/daemon/uiconnection.py
    • /usr/lib/python2.7/site-packages/epoptes/daemon/uiconnection.pyc
    • /usr/lib/python2.7/site-packages/epoptes/ui/__init__.py
    • /usr/lib/python2.7/site-packages/epoptes/ui/__init__.pyc
    • /usr/lib/python2.7/site-packages/epoptes/ui/about_dialog.py
    • /usr/lib/python2.7/site-packages/epoptes/ui/about_dialog.pyc
    • /usr/lib/python2.7/site-packages/epoptes/ui/benchmark.py
    • /usr/lib/python2.7/site-packages/epoptes/ui/benchmark.pyc
    • /usr/lib/python2.7/site-packages/epoptes/ui/client_information.py
    • /usr/lib/python2.7/site-packages/epoptes/ui/client_information.pyc
    • /usr/lib/python2.7/site-packages/epoptes/ui/execcommand.py
    • /usr/lib/python2.7/site-packages/epoptes/ui/execcommand.pyc
    • /usr/lib/python2.7/site-packages/epoptes/ui/graph.py
    • /usr/lib/python2.7/site-packages/epoptes/ui/graph.pyc
    • /usr/lib/python2.7/site-packages/epoptes/ui/gui.py
    • /usr/lib/python2.7/site-packages/epoptes/ui/gui.pyc
    • /usr/lib/python2.7/site-packages/epoptes/ui/notifications.py
    • /usr/lib/python2.7/site-packages/epoptes/ui/notifications.pyc
    • /usr/lib/python2.7/site-packages/epoptes/ui/remote_assistance.py
    • /usr/lib/python2.7/site-packages/epoptes/ui/remote_assistance.pyc
    • /usr/lib/python2.7/site-packages/epoptes/ui/sendmessage.py
    • /usr/lib/python2.7/site-packages/epoptes/ui/sendmessage.pyc
    • /usr/lib/python2.7/site-packages/twisted/
    • /usr/lib/python2.7/site-packages/twisted/plugins/epoptesd.py
    • /usr/lib/python2.7/site-packages/twisted/plugins/epoptesd.pyc
    • /usr/lib/systemd/system/epoptes-server.service
    • /usr/sbin/rcepoptes-server
    • /usr/share/applications/epoptes.desktop
    • /usr/share/doc/epoptes/README
    • /usr/share/epoptes/about_dialog.ui
    • /usr/share/epoptes/client-functions
    • /usr/share/epoptes/client_information.ui
    • /usr/share/epoptes/epoptes.ui
    • /usr/share/epoptes/executeCommand.ui
    • /usr/share/epoptes/netbenchmark.ui
    • /usr/share/epoptes/remote_assistance.ui
    • /usr/share/epoptes/sendMessage.ui
    • /usr/share/epoptes/images/assist.svg
    • /usr/share/epoptes/images/broadcast-stop.svg
    • /usr/share/epoptes/images/broadcast-windowed.svg
    • /usr/share/epoptes/images/broadcast.svg
    • /usr/share/epoptes/images/execute.svg
    • /usr/share/epoptes/images/fat.svg
    • /usr/share/epoptes/images/graph.png
    • /usr/share/epoptes/images/info.svg
    • /usr/share/epoptes/images/lock-screen.svg
    • /usr/share/epoptes/images/login.png
    • /usr/share/epoptes/images/logout.svg
    • /usr/share/epoptes/images/message.svg
    • /usr/share/epoptes/images/mute.svg
    • /usr/share/epoptes/images/observe.svg
    • /usr/share/epoptes/images/off.png
    • /usr/share/epoptes/images/offline.svg
    • /usr/share/epoptes/images/on.png
    • /usr/share/epoptes/images/poweron.svg
    • /usr/share/epoptes/images/restart.svg
    • /usr/share/epoptes/images/root-terminal.svg
    • /usr/share/epoptes/images/shutdown.svg
    • /usr/share/epoptes/images/standalone.svg
    • /usr/share/epoptes/images/systemgrp.png
    • /usr/share/epoptes/images/terminal.svg
    • /usr/share/epoptes/images/thin.svg
    • /usr/share/epoptes/images/unlock-screen.svg
    • /usr/share/epoptes/images/unmute.svg
    • /usr/share/epoptes/images/usersgrp.png
    • /usr/share/epoptes/images/16/assist.png
    • /usr/share/epoptes/images/16/broadcast-stop.png
    • /usr/share/epoptes/images/16/broadcast-windowed.png
    • /usr/share/epoptes/images/16/broadcast.png
    • /usr/share/epoptes/images/16/execute.png
    • /usr/share/epoptes/images/16/graph.png
    • /usr/share/epoptes/images/16/info.png
    • /usr/share/epoptes/images/16/lock-screen.png
    • /usr/share/epoptes/images/16/logout.png
    • /usr/share/epoptes/images/16/message.png
    • /usr/share/epoptes/images/16/mute.png
    • /usr/share/epoptes/images/16/observe.png
    • /usr/share/epoptes/images/16/poweron.png
    • /usr/share/epoptes/images/16/restart.png
    • /usr/share/epoptes/images/16/root-terminal.png
    • /usr/share/epoptes/images/16/shutdown.png
    • /usr/share/epoptes/images/16/terminal.png
    • /usr/share/epoptes/images/16/unlock-screen.png
    • /usr/share/epoptes/images/16/unmute.png
    • /usr/share/icons/hicolor/
    • /usr/share/icons/hicolor/scalable/
    • /usr/share/icons/hicolor/scalable/apps/epoptes.svg
    • /usr/share/locale/ar/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/bg/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/ca/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/ca@valencia/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/cs/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/da/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/de/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/el/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/en_AU/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/en_GB/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/es/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/eu/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/fa/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/fi/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/fr/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/gl/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/he/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/hu/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/id/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/it/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/lt/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/ml/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/nb/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/nl/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/pl/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/pt/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/pt_BR/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/ro/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/ru/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/sk/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/sl/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/sq/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/sr/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/sr@latin/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/sv/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/tr/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/uk/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/vi/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/zh_CN/LC_MESSAGES/epoptes.mo
    • /usr/share/locale/zh_TW/LC_MESSAGES/epoptes.mo
    • /usr/share/ltsp/
    • /usr/share/ltsp/plugins/
    • /usr/share/ltsp/plugins/ltsp-build-client/
    • /usr/share/ltsp/plugins/ltsp-build-client/common/040-epoptes-certificate
    • /usr/share/man/man1/epoptes.1.gz

    Changelog

    2016-02-24 - cyberorg@opensuse.org - update to 0.5.9_bzr0.509 - add support for tightvncviewer as tigervnc lack needed feature https://github.com/TigerVNC/tigervnc/issues/227 - add _service thanks lbsousajr@gmail.com

    2015-10-01 - cyberorg@opensuse.org - Regenerate certificates if it is still old style - Add python-netifaces dep

    2015-09-30 - cyberorg@opensuse.org - Update to bzr revision 436 - Add openssl.cnf to add CommonName, new socat requires it

    2015-09-24 - cyberorg@opensuse.org - use tightvncviewer as other vncviewers are brokenn bnc #939259

    2015-03-02 - lbsousajr@gmail.com - Fix VNC viewer related requirements from official repositories. Old requirement tightvncviewer is broken since openSUSE 13.2. + For openSUSE 13.2 and newer, now requires package tigervnc. + For openSUSE 13.1, now requires package tightvnc.

    2014-12-15 - lbsousajr@gmail.com - Add new patch to fix epoptes-client's script get-display in openSUSE new contexts: + systemd-logind has replaced ConsoleKit. + XAUTHORITY file may not be found at ~/.Xauthority. GDM/GNOME and KDE store this file in different paths.

    2014-12-11 - lbsousajr@gmail.com - Small changes in file epoptes-client.service: + Don't fail if file /etc/default/epoptes-client can't be read. + Run command "epoptes-client -c" also if certificate file exists, but is empty.

    2014-12-11 - lbsousajr@gmail.com - More improvements on file epoptes-client-enable-wol@.service: + Simplify dependencies. + Don't fail if file /etc/default/epoptes-client can't be read. + Replace /bin/sh invocation with systemd directives.

    2014-12-10 - lbsousajr@gmail.com - Drop epoptes-client if-up.d/if-down.d scripts for openSUSE 13.2+, since its new Wicked network management tool doesn't support starting these scripts. Fortunately, now both Wicked and NetworkManager services trigger network-online.target, so we can just add it as a dependency for epoptes-client.service. This one now must be enabled explicitly (systemctl enable epoptes-client). - For the same reason, we don't build package epoptes-client-nm-dispatcher for openSUSE 13.2+. - epoptes-client-fetch-certificate.service was merged into epoptes-client.service at ExecStartPre level. - epoptes-client-ethtool@.service was enhanced and renamed to epoptes-client-enable-wol@.service. It must be enabled explicitly for openSUSE 13.2+.

    2014-12-08 - lbsousajr@gmail.com - Drop non-systemd init scripts, and fix latest rpmlint warnings.

    Advertisement
    Advertisement