blog-2.18-1.2.i586.rpm


Advertisement

Description

blog - Boot logging

Property Value
Distribution openSUSE Leap 42.2
Repository j.eng all
Package name blog
Package version 2.18
Package release 1.2
Package architecture i586
Package type rpm
Installed size 120.01 KB
Download size 47.91 KB
Official Mirror jftp.inai.de
The blogd daemon determines the real underlying character device of
/dev/console. Blogd spawns a pty/tty pair to reconnect the current
/dev/console with the slave of the pty/tty pair. During writing
information from this slave to the real character device a ring
buffer is used to hold the information for writing it to an existing
logging file.

Alternatives

Package Version Architecture Repository
blog-2.18-1.2.x86_64.rpm 2.18 x86_64 j.eng
blog - - -

Requires

Name Value
libc.so.6(GLIBC_2.10) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.3.2) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -
libutil.so.1 -
libutil.so.1(GLIBC_2.0) -

Provides

Name Value
blog = 2.18-1.2
blog(x86-32) = 2.18-1.2
libblogger.so.2 -
sysvinit-tools:/sbin/blogd -

Download

Type URL
Binary Package blog-2.18-1.2.i586.rpm
Source Package blog-2.18-1.2.src.rpm

Install Howto

  1. Add the j.eng repository:
    # zypper addrepo http://jftp.inai.de/openSUSE_Leap_42.2/ j.eng
  2. Install blog rpm package:
    # zypper install blog

Files

Path
/sbin/blogctl
/sbin/blogd
/sbin/blogger
/sbin/isserial
/sbin/setconsole
/sbin/showconsole
/usr/lib/libblogger.so.2
/usr/lib/libblogger.so.2.18
/usr/share/doc/packages/blog/COPYING
/usr/share/doc/packages/blog/README
/usr/share/man/man8/blogctl.8.gz
/usr/share/man/man8/blogd.8.gz
/usr/share/man/man8/blogger.8.gz
/usr/share/man/man8/isserial.8.gz
/usr/share/man/man8/setconsole.8.gz
/usr/share/man/man8/showconsole.8.gz

Changelog

2016-08-11 - olaf@aepfle.de
- Install binaries with read permissions (bnc#990837)
2016-02-22 - werner@suse.de
- Do not use privata glibc API (boo#967437) but implement
missing shared memory mkstemp()
- Remove patch remove-bad-symbol-use.patch
2016-02-22 - schwab@suse.de
- remove-bad-symbol-use.patch: Remove bad use of internal glibc interface
(bnc#967437)
2016-02-19 - werner@suse.de
- Make clear that blog is split off from sysvinit-tools
- Avoid to be tagged with GLIBC_PRIVATE
- Use libblogger.so with version, that is major and minor
2016-02-19 - werner@suse.de
- Bug fix version: Handle chached password request gracefully
2016-02-10 - meissner@suse.com
- add blog-rpmlintrc. The all-manual handling of systemd services
is required according to Werner.
2016-02-04 - werner@suse.de
- Let libblogger become a shared library
2016-01-22 - werner@suse.de
- Clean up service uits for close and umount
2016-01-15 - werner@suse.de
- First initial package after splitting apart from sysvinit
* Now blogd can replace plymouth(9) even from initrd
* Also blogd is able to handle password requests from
from systemd API
* The blogd daemon writes out console messages even on reboot
or halt up to the file systems become unavailable.
* No locking of the console devices, no frame buffer switching.

See Also

Package Description
blog-devel-2.18-1.2.i586.rpm Provides library and header for boot logging
blog-devel-2.18-1.2.x86_64.rpm Provides library and header for boot logging
blog-plymouth-2.18-1.2.i586.rpm Replaces plymouth by blogd
blog-plymouth-2.18-1.2.x86_64.rpm Replaces plymouth by blogd
bnh-lucida-fonts-2.00-3.2.noarch.rpm B&H Lucida font family
build-essentials-packages-42.2-2.2.noarch.rpm Build essential metapackage for C/C++
coreutils-8.25-2.4.1.i586.rpm GNU Core Utilities
coreutils-8.25-2.4.1.x86_64.rpm GNU Core Utilities
coreutils-lang-8.25-2.4.1.noarch.rpm Languages for package coreutils
edict-20170706-7.1.noarch.rpm The Japanese Dictionary Files from the EDRDG project
fd0ssh-20170430-2.1.i586.rpm Helper program for using a pipe for SSH authentication
fd0ssh-20170430-2.1.x86_64.rpm Helper program for using a pipe for SSH authentication
gcal-4-8.2.i586.rpm A Program for Printing Calendars
gcal-4-8.2.x86_64.rpm A Program for Printing Calendars
gcal-lang-4-8.2.noarch.rpm Languages for package gcal
Advertisement
Advertisement