guile-2.0.9-7.1.x86_64.rpm


Advertisement

Description

guile - GNU's Ubiquitous Intelligent Language for Extension

Distribution: openSUSE 42.1
Repository: openSUSE Update Oss all
Package name: guile
Package version: 2.0.9
Package release: 7.1
Package architecture: x86_64
Package type: rpm
Installed size: 2.33 MB
Download size: 557.49 KB
Official Mirror: ftp.gwdg.de
This is Guile, a portable, embeddable Scheme implementation written in C. Guile provides a machine independent execution platform that can be linked in as a library when building extensible programs.

Alternatives

Provides

  • guile = 2.0.9-7.1
  • guile(x86-64) = 2.0.9-7.1

Conflicts

  • slib < 3a5

    Download

    Source package: guile-2.0.9-7.1.src.rpm

    Install Howto

    Install guile rpm package:

    # zypper install guile

    Files

    • /usr/bin/guild
    • /usr/bin/guile
    • /usr/bin/guile-tools
    • /usr/share/doc/packages/guile/ABOUT-NLS
    • /usr/share/doc/packages/guile/AUTHORS
    • /usr/share/doc/packages/guile/COPYING
    • /usr/share/doc/packages/guile/COPYING.LESSER
    • /usr/share/doc/packages/guile/ChangeLog
    • /usr/share/doc/packages/guile/GUILE-VERSION
    • /usr/share/doc/packages/guile/HACKING
    • /usr/share/doc/packages/guile/LICENSE
    • /usr/share/doc/packages/guile/NEWS
    • /usr/share/doc/packages/guile/README
    • /usr/share/doc/packages/guile/THANKS
    • /usr/share/man/man1/guile.1.gz

    Changelog

    2016-10-17 - pgajdos@suse.com - security update * CVE-2016-8605 [bsc#1004221] + guile-CVE-2016-8605.patch

    2013-04-15 - pgajdos@suse.com - updated to 2.0.9: * * New keyword arguments for procedures that open files * * Numerics improvements * * New optimizations * * `peek-char' no longer consumes EOF * * SLIB compatibility restored * * Better ,trace REPL command * * Better docstring syntax supported for `case-lambda' * * Improved handling of Unicode byte order marks etc. see NEWS for more/details - removed unneeded gc-test.patch

    2013-02-05 - dmitry_r@opensuse.org - move .so file to libguilereadline package [bnc#765436]

    2012-12-17 - pgajdos@suse.com - fixed build: net-db.test takes EAI_SYSTEM error by * net-db-test.patch [bnc#794696] - turn off one test in gc.test * gc-test.patch http://lists.gnu.org/archive/html/bug-guile/2012-07/msg00069.html

    2012-12-03 - pgajdos@suse.com - update to 2.0.7: * Notable changes * * SRFI-105 curly infix expressions are supported * * Reader options may now be per-port * * Futures may now be nested * * `GUILE_LOAD_PATH' et al can now add directories to the end of the path * * `load-in-vicinity' search for `.go' files in `%load-compiled-path' * * Extension search order fixed, and LD_LIBRARY_PATH preserved * * Optimize calls to `equal?' or `eqv?' with a constant argument * Manual updates * * SRFI-9 records now documented under "Compound Data Types" * * (ice-9 and-let-star) and (ice-9 curried-definitions) now documented * New interfaces * * New "functional record setters" as a GNU extension of SRFI-9 * * web: New `http-get*', `response-body-port', and `text-content-type?' procedures * * `string-split' accepts character sets and predicates * * R6RS SRFI support * * `define-public' is no a longer curried definition by default etc. see NEWS

    Advertisement
    Advertisement