perl-indirect-0.36-4.2.x86_64.rpm


Advertisement

Description

perl-indirect - Lexically warn about using the indirect method call syntax

Distribution: openSUSE 42.1
Repository: openSUSE Oss all
Package name: perl-indirect
Package version: 0.36
Package release: 4.2
Package architecture: x86_64
Package type: rpm
Installed size: 66.61 KB
Download size: 33.44 KB
Official Mirror: ftp.gwdg.de
When enabled, this pragma warns about indirect method calls that are present in your code. The indirect syntax is now considered harmful, since its parsing has many quirks and its use is error prone : when the subroutine 'foo' has not been declared in the current package, 'foo $x' actually compiles to '$x->foo', and 'foo { key => 1 }' to ''key'->foo(1)'. Please refer to the the /REFERENCES manpage section for a more complete list of reasons for avoiding this construct. This pragma currently does not warn for core functions ('print', 'say', 'exec' or 'system'). This may change in the future, or may be added as optional features that would be enabled by passing options to 'unimport'. This module is *not* a source filter.

Alternatives

Requires

Provides

  • indirect.so()(64bit)
  • perl(indirect) = 0.36
  • perl-indirect = 0.36-4.2
  • perl-indirect(x86-64) = 0.36-4.2

    Download

    Install Howto

    Install perl-indirect rpm package:

    # zypper install perl-indirect
    Advertisement
    Advertisement