perl-Scope-Upper-0.28-6.2.x86_64.rpm


Advertisement

Description

perl-Scope-Upper - Act on upper scopes

Distribution: openSUSE 42.1
Repository: openSUSE Oss all
Package name: perl-Scope-Upper
Package version: 0.28
Package release: 6.2
Package architecture: x86_64
Package type: rpm
Installed size: 123.38 KB
Download size: 55.28 KB
Official Mirror: ftp.gwdg.de
This module lets you defer actions _at run-time_ that will take place when the control flow returns into an upper scope. Currently, you can: * * hook an upper scope end with the /reap manpage ; * * localize variables, array/hash values or deletions of elements in higher contexts with respectively the /localize manpage, the /localize_elem manpage and the /localize_delete manpage ; * * return values immediately to an upper level with the /unwind manpage, the /yield manpage and the /leave manpage ; * * gather information about an upper context with the /want_at manpage and the /context_info manpage ; * * execute a subroutine in the setting of an upper subroutine stack frame with the /uplevel manpage ; * * uniquely identify contexts with the /uid manpage and the /validate_uid manpage.

Alternatives

Requires

Provides

  • Upper.so()(64bit)
  • perl(Scope::Upper) = 0.28
  • perl-Scope-Upper = 0.28-6.2
  • perl-Scope-Upper(x86-64) = 0.28-6.2

    Install Howto

    Install perl-Scope-Upper rpm package:

    # zypper install perl-Scope-Upper
    Advertisement
    Advertisement