perl-MooseX-Role-WithOverloading-0.16-1.1.x86_64.rpm


Advertisement

Description

perl-MooseX-Role-WithOverloading - Roles which support overloading

Distribution: openSUSE 42.1
Repository: openSUSE Oss all
Package name: perl-MooseX-Role-WithOverloading
Package version: 0.16
Package release: 1.1
Package architecture: x86_64
Package type: rpm
Installed size: 76.89 KB
Download size: 44.18 KB
Official Mirror: ftp.gwdg.de
MooseX::Role::WithOverloading allows you to write a the Moose::Role manpage which defines overloaded operators and allows those overload methods to be composed into the classes/roles/instances it's compiled to, where plain the Moose::Role manpages would lose the overloading. Starting with the Moose manpage version 2.1300, this module is no longer necessary, as the functionality is available already. In that case, 'use MooseX::Role::WithOverloading' behaves identically to 'use Moose::Role'.

Alternatives

Provides

  • WithOverloading.so()(64bit)
  • perl(MooseX::Role::WithOverloading) = 0.16
  • perl(MooseX::Role::WithOverloading::Meta::Role) = 0.16
  • perl(MooseX::Role::WithOverloading::Meta::Role::Application) = 0.16
  • perl(MooseX::Role::WithOverloading::Meta::Role::Application::Composite) = 0.16
  • perl(MooseX::Role::WithOverloading::Meta::Role::Application::Composite::ToClass) = 0.16
  • perl(MooseX::Role::WithOverloading::Meta::Role::Application::Composite::ToInstance) = 0.16
  • perl(MooseX::Role::WithOverloading::Meta::Role::Application::Composite::ToRole) = 0.16
  • perl(MooseX::Role::WithOverloading::Meta::Role::Application::FixOverloadedRefs) = 0.16
  • perl(MooseX::Role::WithOverloading::Meta::Role::Application::ToClass) = 0.16
  • perl(MooseX::Role::WithOverloading::Meta::Role::Application::ToInstance) = 0.16
  • perl(MooseX::Role::WithOverloading::Meta::Role::Application::ToRole) = 0.16
  • perl(MooseX::Role::WithOverloading::Meta::Role::Composite) = 0.16
  • perl-MooseX-Role-WithOverloading = 0.16-1.1
  • perl-MooseX-Role-WithOverloading(x86-64) = 0.16-1.1

    Install Howto

    Install perl-MooseX-Role-WithOverloading rpm package:

    # zypper install perl-MooseX-Role-WithOverloading
    Advertisement
    Advertisement