perl-B-Hooks-OP-Annotation-0.44-3.1.x86_64.rpm


Advertisement

Description

perl-B-Hooks-OP-Annotation - annotate and delegate hooked OPs

Distribution: openSUSE 42.1
Repository: openSUSE Oss all
Package name: perl-B-Hooks-OP-Annotation
Package version: 0.44
Package release: 3.1
Package architecture: x86_64
Package type: rpm
Installed size: 24.69 KB
Download size: 18.34 KB
Official Mirror: ftp.gwdg.de
This module provides a way for XS code that hijacks OP 'op_ppaddr' functions to delegate to (or restore) the previous functions, whether assigned by perl or by another module. Typically this should be used in conjunction with B::Hooks::OP::Check. 'B::Hooks::OP::Annotation' makes its types and functions available to XS code by means of ExtUtils::Depends. Modules that wish to use these exports in their XS code should 'use B::OP::Hooks::Annotation' in the Perl module that loads the XS, and include something like the following in their Makefile.PL: use ExtUtils::MakeMaker; use ExtUtils::Depends; our %XS_PREREQUISITES = ( 'B::Hooks::OP::Annotation' => '0.44', 'B::Hooks::OP::Check' => '0.15', ); our %XS_DEPENDENCIES = ExtUtils::Depends->new( 'Your::XS::Module', keys(%XS_PREREQUISITES) )->get_makefile_vars(); WriteMakefile( NAME => 'Your::XS::Module', VERSION_FROM => 'lib/Your/XS/Module.pm', PREREQ_PM => { 'B::Hooks::EndOfScope' => '0.07', %XS_PREREQUISITES }, ($ExtUtils::MakeMaker::VERSION >= 6.46 ? (META_MERGE => { configure_requires => { 'ExtUtils::Depends' => '0.301', %XS_PREREQUISITES }}) : () ), %XS_DEPENDENCIES, );

Alternatives

Requires

Provides

  • Annotation.so()(64bit)
  • perl(B::Hooks::OP::Annotation) = 0.44
  • perl(B::Hooks::OP::Annotation::Install::Files)
  • perl-B-Hooks-OP-Annotation = 0.44-3.1
  • perl-B-Hooks-OP-Annotation(x86-64) = 0.44-3.1

    Install Howto

    Install perl-B-Hooks-OP-Annotation rpm package:

    # zypper install perl-B-Hooks-OP-Annotation
    Advertisement
    Advertisement