oniguruma-devel-5.9.2-3.2.x86_64.rpm


Advertisement

Description

oniguruma-devel - Regex Library Supporting Different Character Encodings - Development Files

Distribution: openSUSE 42.1
Repository: openSUSE Oss all
Package name: oniguruma-devel
Package version: 5.9.2
Package release: 3.2
Package architecture: x86_64
Package type: rpm
Installed size: 1.88 MB
Download size: 319.62 KB
Official Mirror: ftp.gwdg.de
Oniguruma is a regular expressions library. The characteristics of this library is that different character encoding for every regular expression object can be specified. Supported character encodings: ASCII, UTF-8, UTF-16BE, UTF-16LE, UTF-32BE, UTF-32LE, EUC-JP, EUC-TW, EUC-KR, EUC-CN, Shift_JIS, Big5, GB 18030, KOI8-R, KOI8, ISO-8859-1, ISO-8859-2, ISO-8859-3, ISO-8859-4, ISO-8859-5, ISO-8859-6, ISO-8859-7, ISO-8859-8, ISO-8859-9, ISO-8859-10, ISO-8859-11, ISO-8859-13, ISO-8859-14, ISO-8859-15, ISO-8859-16. This package contains all necessary include files and libraries needed to develop applications that require it.

Alternatives

Requires

  • libonig2 = 5.9.2
  • rpmlib(CompressedFileNames) <= 3.0.4-1
  • rpmlib(PayloadFilesHavePrefix) <= 4.0-1
  • rpmlib(PayloadIsLzma) <= 4.4.6-1

Provides

  • oniguruma-devel = 5.9.2-3.2
  • oniguruma-devel(x86-64) = 5.9.2-3.2

Obsoletes

  • oniguruma <= 2.5.7

    Download

    Install Howto

    Install oniguruma-devel rpm package:

    # zypper install oniguruma-devel

    Files

    • /usr/bin/onig-config
    Advertisement
    Advertisement