ipvsadm-1.29-337.2.x86_64.rpm


Advertisement

Description

ipvsadm - A Utility for Administering the Linux Virtual Server

Distribution: openSUSE 42.1
Repository: openSUSE Network Utilities all
Package name: ipvsadm
Package version: 1.29
Package release: 337.2
Package architecture: x86_64
Package type: rpm
Installed size: 73.05 KB
Download size: 42.56 KB
Official Mirror: ftp.gwdg.de
ipvsadm is a utility for administering the IP virtual server services offered by the Linux kernel with Linux Virtual Server support.

Alternatives

Provides

  • config(ipvsadm) = 1.29-337.2
  • ipvsadm = 1.29-337.2
  • ipvsadm(x86-64) = 1.29-337.2
  • ipvsadm-1.29

    Download

    Install Howto

    1. Add the openSUSE Network Utilities repository:
      # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/network:/utilities/openSUSE_Leap_42.1/ opensuse-network-utilities
    2. Install ipvsadm rpm package:
      # zypper install ipvsadm

    Files

    • /etc/ipvsadm.rules
    • /sbin/ipvsadm
    • /sbin/ipvsadm-restore
    • /sbin/ipvsadm-save
    • /usr/lib/systemd/system/ipvsadm.service
    • /usr/sbin/rcipvsadm
    • /usr/share/doc/packages/ipvsadm/README
    • /usr/share/man/man8/ipvsadm-restore.8.gz
    • /usr/share/man/man8/ipvsadm-save.8.gz
    • /usr/share/man/man8/ipvsadm.8.gz
    • /var/adm/fillup-templates/sysconfig.ipvsadm

    Changelog

    2017-01-05 - p.drouand@gmail.com - Update to version 1.29 * No changelog available

    2016-12-20 - mt@suse.de - fixed systemd service file to restore correct config file at start (/etc/ipvsadm.rules) and do not break boot-time config at stop (bsc#1013581).

    2015-12-01 - p.drouand@gmail.com - Update to version 1.28 * No changelog available - Update download Url - Remove obsolete patches * 03_libnl-3-linking.patch * ipvsadm-1.26-ipvs_dests_parse_cb-memory-corruption.diff * ipvsadm-1.26-wrong-error-with--ops-option.bnc847005.diff - Update ipvsadm-1.26-print_largenum.diff > ipvsadm-print_largenum.diff

    2014-05-28 - crrodriguez@opensuse.org - 03_libnl-3-linking.patch from debian, allow use of libnl3 instead of libnl1

    2014-05-21 - jsegitz@novell.com - added necessary macros for systemd files

    2014-02-13 - mt@suse.de - Fix segfault when running 'ipvsadm -Ln' caused by buffer overrun in ipvs_dests_parse_cb() function (bnc#775051), by Tim Serong. [+ ipvsadm-1.26-ipvs_dests_parse_cb-memory-corruption.diff] - Fix wrong error message when using ipvsadm with option "--ops" (bnc#847005), by Paul Zirnik. [+ ipvsadm-1.26-wrong-error-with--ops-option.bnc847005.diff]

    2013-10-28 - p.drouand@gmail.com - Add systemd support and drop sysvinit support - Remove AUTHORS section - Remove redundant %clean section

    2011-09-16 - jengelh@medozas.de - Select libnl-1_1-devel

    2011-02-08 - mt@suse.de - Updated to ipvsadm-1.26 (for kernel 2.6.28-rc3 or later) adding IPv6 support, netlink interface and code cleanups. - Adopted patches and spec file, switched to use new netlink interface and popt (getopt support dropped). - Fixed rpmlint warnings in the init script and spec file.

    2008-08-25 - mt@suse.de - init script: copy LSB *-Start tags to *-Stop

    Advertisement
    Advertisement