gstreamer-0_10-plugins-ugly-0.10.19-43.1.x86_64.rpm


Advertisement

Description

gstreamer-0_10-plugins-ugly - GStreamer Streaming-Media Framework Plug-Ins

Distribution: openSUSE 42.1
Repository: openSUSE Multimedia Libs all
Package name: gstreamer-0_10-plugins-ugly
Package version: 0.10.19
Package release: 43.1
Package architecture: x86_64
Package type: rpm
Installed size: 359.49 KB
Download size: 131.38 KB
Official Mirror: ftp.gwdg.de
GStreamer is a streaming media framework based on graphs of filters that operate on media data. Applications using this library can do anything media-related, from real-time sound processing to playing videos. Its plug-in-based architecture means that new data types or processing capabilities can be added simply by installing newplug-ins. This package contains well-written plug-ins that can't be shipped in gstreamer-plugins-good because: - the license is not LGPL - the license of the library is not LGPL - there are possible licensing issues with the code.

Provides

  • gst-plugins-ugly = 0.10.19
  • gstreamer-0_10-plugins-ugly = 0.10.19-43.1
  • gstreamer-0_10-plugins-ugly(x86-64) = 0.10.19-43.1
  • gstreamer0.10(decoder-application/vnd.rn-realmedia)()(64bit)
  • gstreamer0.10(decoder-application/x-pn-realaudio)()(64bit)
  • gstreamer0.10(decoder-application/x-rdt)()(64bit)
  • gstreamer0.10(decoder-audio/x-lpcm)()(64bit)
  • gstreamer0.10(decoder-audio/x-private1-lpcm)()(64bit)
  • gstreamer0.10(decoder-audio/x-sid)()(64bit)
  • gstreamer0.10(element-cdiocddasrc)()(64bit)
  • gstreamer0.10(element-dvdlpcmdec)()(64bit)
  • gstreamer0.10(element-dvdreadsrc)()(64bit)
  • gstreamer0.10(element-dvdsubdec)()(64bit)
  • gstreamer0.10(element-dvdsubparse)()(64bit)
  • gstreamer0.10(element-pnmsrc)()(64bit)
  • gstreamer0.10(element-rademux)()(64bit)
  • gstreamer0.10(element-rdtdepay)()(64bit)
  • gstreamer0.10(element-rdtmanager)()(64bit)
  • gstreamer0.10(element-rmdemux)()(64bit)
  • gstreamer0.10(element-rtspreal)()(64bit)
  • gstreamer0.10(element-siddec)()(64bit)
  • gstreamer0.10(element-synaesthesia)()(64bit)
  • gstreamer0.10(urisource-cdda)()(64bit)
  • gstreamer0.10(urisource-dvd)()(64bit)
  • gstreamer0.10(urisource-pnm)()(64bit)
  • gstreamer010-plugins-ugly = 0.10.19
  • libgstcdio.so()(64bit)
  • libgstdvdlpcmdec.so()(64bit)
  • libgstdvdread.so()(64bit)
  • libgstdvdsub.so()(64bit)
  • libgstrmdemux.so()(64bit)
  • libgstsid.so()(64bit)
  • libgstsynaesthesia.so()(64bit)
  • patched_subset

Obsoletes

  • gstreamer010-plugins-ugly < 0.10.19

    Install Howto

    1. Add the openSUSE Multimedia Libs repository:
      # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Leap_42.1/ opensuse-multimedia-libs
    2. Install gstreamer-0_10-plugins-ugly rpm package:
      # zypper install gstreamer-0_10-plugins-ugly

    Files

    • /usr/lib64/gstreamer-0.10/libgstcdio.so
    • /usr/lib64/gstreamer-0.10/libgstdvdlpcmdec.so
    • /usr/lib64/gstreamer-0.10/libgstdvdread.so
    • /usr/lib64/gstreamer-0.10/libgstdvdsub.so
    • /usr/lib64/gstreamer-0.10/libgstrmdemux.so
    • /usr/lib64/gstreamer-0.10/libgstsid.so
    • /usr/lib64/gstreamer-0.10/libgstsynaesthesia.so
    • /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/AUTHORS
    • /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/COPYING
    • /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/NEWS
    • /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/README
    • /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/RELEASE
    • /usr/share/doc/packages/gstreamer-0_10-plugins-ugly/REQUIREMENTS

    Changelog

    2016-04-08 - dimstar@opensuse.org - Add gstreamer-0_10-plugins-ugly-gtk-doc-1.25.patch: Fix build with gtk-doc 1.25. index.sgml is an internal file and must not be messed with (and with gtk-doc 1.25 it is no longer created). (Fate#318572)

    2015-06-02 - dimstar@opensuse.org - minor: fix patch tag line (case sensitive). - Add baselibs.conf to source list.

    2012-05-31 - seife+obs@b1-systems.com - add patch to fix build with new libcdio - readd libcdio to build

    2012-05-29 - davejplater@gmail.com - Removed libcdio from build

    2012-03-01 - reddwarf@opensuse.org - Fix build with opencore-amr 0.1.3

    2012-02-21 - vuntz@opensuse.org - Update to version 0.10.19: + a52dec: don't claim to support upstream renegotiation + dvddemux: tweak subtitle stream setup based on dvd language codes event + dvdreadsrc: - fix off by one in cell calculation for the last chapter - fix sector search for packed titles; fix sector seeking - map subtitle language tag to stream indicated in PGC data - take into account first sector of the current title + lame, lamemp3enc: - ensure parsed output (most muxers need framed mp3 as input) - post CODEC and BITRATE tags + mad: remove id3tag dependency used by in practice unreachable legacy code + mpeg2dec: - don't treat non-fatal errors as fatal and fix spurious failure to decode some files - post QoS messages when dropping a frame due to QoS + rtpasfdepay: avoid re-sending header; fix fragmented packet handling and packet padding + twolame: improve output framing and timestamping + x264enc: - allow renegotiation but prefer current caps - negotiate profile, level and output stream-format from downstream caps where appropriate + Bugs fixed: bgo#391543, bgo#429476, bgo#644233, bgo#653473, bgo#655223, bgo#658297, bgo#659252, bgo#660562, bgo#662964, bgo#664175, bgo#665101. - Update gstreamer-0_10-plugins-bad-patch-source.sh (and pre_checkin.sh) to deal with xz tarballs. - Add explicit glib2-devel BuildRequires so it can be versioned. - Add xz BuildRequires on openSUSE <= 12.1, to be able to decompress the xz tarball. - Remove libid3tag-devel: dependency is gone upstream.

    2011-10-15 - coolo@suse.com - add libtool as buildrequire to make the spec file more reliable

    2011-05-11 - dimstar@opensuse.org - Update to version 0.10.18: + amrwbdec: avoid stalling on invalid frame + asfpacket: don't rely on data from duration extension + dvdsubdec: - Implement clipping if the video size is smaller than the subpicture size - Output only a single buffer per subpicture and set the correct duration + lamemp3enc: implement sinkpad get_caps() function to proxy rate and channels restrictions from downstream + mad: build the mad plugin even if libid3tag is not available + mpeg2dec: - do not fail fatally when downstream is unlinked - don't deadlock when setting an index + mpegstream: increase allowable gap between streams + x264enc: - allow changing the bitrate and quantitizers dynamically - don't register flags with a value of 0 - implement getcaps function to proxy downstream caps restrictions upstream - make tag event writable before modifying tag list in place - set max bitrate in quality mode + Bugs fixed: bgo#539708, bgo#607698, bgo#619136, bgo#621663, bgo#639291, bgo#639715, bgo#640272, bgo#641151, bgo#642360, bgo#644704, bgo#647709.

    2011-04-24 - toddrme2178@gmail.com - Add 32bit compatibility libraries - Removed test for obsolete openSUSE version

    Advertisement
    Advertisement