angelscript-devel-2.31.2-1.1.x86_64.rpm


Advertisement

Description

angelscript-devel - It is an extremely flexible cross-platform scripting library

Distribution: openSUSE 42.1
Repository: openSUSE Games all
Package name: angelscript-devel
Package version: 2.31.2
Package release: 1.1
Package architecture: x86_64
Package type: rpm
Installed size: 67.56 KB
Download size: 18.59 KB
Official Mirror: ftp.gwdg.de
It supports Unix sockets and TCP/IP sockets with optional SSL/TLS (OpenSSL) support. It allows you to write portable and secure network applications quickly without needing to spend time learning low-level system functions or reading OpenSSL manuals.

Alternatives

Provides

  • angelscript-devel = 2.31.2-1.1
  • angelscript-devel(x86-64) = 2.31.2-1.1

    Install Howto

    1. Add the openSUSE Games repository:
      # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/games/openSUSE_Leap_42.1/ opensuse-games
    2. Install angelscript-devel rpm package:
      # zypper install angelscript-devel

    Files

    • /usr/include/angelscript.h
    • /usr/lib64/libangelscript.so

    Changelog

    2017-02-28 - rpm@fthiessen.de - Update to new upstream release 2.31.2 * Fixed big endian errors in the compiler related to enum values * CreateScriptObject crashed when called for template value types * Fixed crash when discarding modules containing shared funcdefs * Fixed big endian errors in the compiler related to implicit conversions of constants * Fixed bug with saved byte code not being portable between 32bit and 64bit platforms when including ChkNullS instruction * Fixed assert failure in compiler when compiling invalid switch case * Fixed bug in compiler when passing a @& argument to a function * Fixed bug when compiling get property accessor returning a registered type that is then implicitly converted to another * Fixed assert failure when compiling boolean not operator on constant * Fixed incorrect compiler warning about too large value when assigning negative value to const int8/int16 * Compiler emits warnings if 64bit integer constants cannot fit when implicitly converted to smaller types * Compiler didn't support implicitly converting constant uint64 values to uint32 values * Fixed assert failure when compiling comparison operator on boolean constant * Fixed bug in bytecode serialization when adjusting pointer sizes for calls using asBC_ALLOC * Fixed problem with registering types using the asOBJ_IMPLICIT_HANDLE flag * Fixed assert failure on implicit conversion from 8/16 bit uint constant to integer * opCast(?&out) on null handle now works without raising null pointer exceptions * Corrected as_config.h so Linux for 64bit ARM doesn't try to compile as_callfunc_x64_gcc.cpp * Fixed crash on GCC 6 due to CastToObjectType accepting this == null

    2016-08-18 - rpm@fthiessen.de - Update to new upstream release 2.31.1

    2014-11-23 - mailaender@opensuse.org - Build version 2.29.2 - Use en.opensuse.org/SourceUrls - Remove upstreamed makefile-flags.diff and angelscript-makefile.patch

    2012-12-09 - joop.boonen@opensuse.org - Build version 2.25.2

    2012-11-15 - joop.boonen@opensuse.org - Build version 2.25.1

    2012-04-04 - jengelh@medozas.de - Avoid use of descending relative paths in %files - Add patch to allow using %optflags and resolve the prior rpmlint message about the lack of it

    2012-03-04 - joop.boonen@opensuse.org - added docs - corrected the patch now it the soname and the devel file are symlinked to the version file

    2012-03-04 - joop.boonen@opensuse.org - cleaned the spec file by means of spec-cleaner

    2012-03-03 - joop.boonen@opensuse.org - corrected the license - adapted the spec file to the openSUSE standard

    2012-02-24 - virus0025@gmail.com - initial version

    Advertisement
    Advertisement