3omns-0.2-23.2.x86_64.rpm


Advertisement

Description

3omns - Old-school Arcade-style Tile-based Bomb-dropping Deathmatch Game

Distribution: openSUSE 42.1
Repository: openSUSE Games all
Package name: 3omns
Package version: 0.2
Package release: 23.2
Package architecture: x86_64
Package type: rpm
Installed size: 179.41 KB
Download size: 65.22 KB
Official Mirror: ftp.gwdg.de
3omns is an old-school arcade-style tile-based bomb-dropping deathmatch game.

Alternatives

Provides

  • 3omns = 0.2-23.2
  • 3omns(x86-64) = 0.2-23.2
  • appdata()
  • appdata(3omns.appdata.xml)
  • application()
  • application(3omns.desktop)

    Download

    Binary package: 3omns-0.2-23.2.x86_64.rpm
    Source package: 3omns-0.2-23.2.src.rpm

    Install Howto

    1. Add the openSUSE Games repository:
      # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/games/openSUSE_Leap_42.1/ opensuse-games
    2. Install 3omns rpm package:
      # zypper install 3omns

    Files

    • /usr/bin/3omns
    • /usr/share/3omns/
    • /usr/share/3omns/base/bot.lua
    • /usr/share/3omns/base/core.lua
    • /usr/share/3omns/base/generate.lua
    • /usr/share/3omns/base/init.lua
    • /usr/share/3omns/base/object.lua
    • /usr/share/3omns/base/serial.lua
    • /usr/share/3omns/base/sync.lua
    • /usr/share/3omns/base/util.lua
    • /usr/share/3omns/base/entities/bomn.lua
    • /usr/share/3omns/base/entities/crate.lua
    • /usr/share/3omns/base/entities/dude.lua
    • /usr/share/3omns/base/entities/entities.lua
    • /usr/share/3omns/base/entities/entity.lua
    • /usr/share/3omns/base/entities/super.lua
    • /usr/share/3omns/base/sprites/blast.lua
    • /usr/share/3omns/base/sprites/sprite.lua
    • /usr/share/3omns/gfx/sprites.png
    • /usr/share/3omns/ttf/Vera.ttf
    • /usr/share/appdata/3omns.appdata.xml
    • /usr/share/applications/3omns.desktop
    • /usr/share/doc/packages/3omns/COPYING
    • /usr/share/doc/packages/3omns/NEWS
    • /usr/share/doc/packages/3omns/README
    • /usr/share/icons/hicolor/
    • /usr/share/icons/hicolor/scalable/
    • /usr/share/icons/hicolor/scalable/apps/3omns.svg
    • /usr/share/man/man6/3omns.6.gz

    Changelog

    2016-12-26 - mailaender@opensuse.org - Update to version 0.2 - Add appdata.patch

    2016-06-19 - nemysis@openSUSE.org - Remove check %if 0%{?suse_version}, because is only for openSUSE

    2016-01-23 - nemysis@openSUSE.org - Recreate tarball, new GitHub commit Please look 'git log' and announce message: * Add bot.lua to dist * Fixed some bot AI bugs * Revamped networking code to add reliability * Added the -R command line option to print resources path - license update: GPL-3.0+ No indication that this is GPL-3.0 (only) - Add BuildRequires for bitstream-vera-fonts - Add Requires for bitstream-vera-fonts, thanks dstoecker - Replace bundled font with a symlink to an identical system font - Remove COPYING.font from Documentation

    2016-01-01 - rpm@fthiessen.de - Fixed lua dependencies so it will also build on openSUSE <= 13.2

    2015-09-25 - nemysis@openSUSE.org - Recreate tarball, new GitHub commit Please look 'git log'

    2015-07-30 - dimstar@opensuse.org - BuildRequire lua52-devel on openSUSE > 13.2 (current Tumbleweed): 3omns has not been ported to LUA 5.3 yet.

    2014-11-24 - nemysis@gmx.ch - Move hicolor-icon-theme to %if 0%{?suse_version}

    2014-10-28 - nemysis@gmx.ch - Recreate tarball, new GitHub commit - Remove _service, download from GitHub and packed as tar.bz2 - Remove BuildRequires for desktop-file-utils - Use BuildRequires pkgconfig(lua) instead of lua-devel

    2014-10-16 - nemysis@gmx.ch - Change Group

    2014-10-15 - nemysis@gmx.ch - Use check for openSUSE %if 0%{?suse_version} - Use BuildRequires pkgconfig(sdl2), pkgconfig(SDL2_image) and pkgconfig(SDL2_ttf) instead of libSDL2-devel, libSDL2_image-devel and SDL2_ttf-devel

    Advertisement
    Advertisement