t1lib-5.1.2-1.3.x86_64.rpm


Advertisement

Description

t1lib - Adobe Type 1 Font Rasterizing Library

Distribution: openSUSE 42.1
Repository: openSUSE Education all
Package name: t1lib
Package version: 5.1.2
Package release: 1.3
Package architecture: x86_64
Package type: rpm
Installed size: 1.23 MB
Download size: 675.71 KB
Official Mirror: ftp.gwdg.de
T1lib is a library for generating character and string glyphs from Adobe Type 1 fonts under UNIX. T1lib uses most of the code of the X Window System rasterizer donated by IBM to the X Window System project. Some disadvantages of the rasterizer included in the X Window System have been eliminated.

Alternatives

Provides

  • config(t1lib) = 5.1.2-1.3
  • libt1.so.5()(64bit)
  • libt1x.so.5()(64bit)
  • t1lib = 5.1.2-1.3
  • t1lib(x86-64) = 5.1.2-1.3

    Download

    Source package: t1lib-5.1.2-1.3.src.rpm

    Install Howto

    1. Add the openSUSE Education repository:
      # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Education/openSUSE_Leap_42.1/ opensuse-education
    2. Install t1lib rpm package:
      # zypper install t1lib

    Files

    • /usr/bin/type1afm
    • /usr/bin/xglyph
    • /usr/lib64/libt1.so.5
    • /usr/lib64/libt1.so.5.1.2
    • /usr/lib64/libt1x.so.5
    • /usr/lib64/libt1x.so.5.1.2
    • /usr/share/doc/packages/t1lib/Changes
    • /usr/share/doc/packages/t1lib/LGPL
    • /usr/share/doc/packages/t1lib/LICENSE
    • /usr/share/doc/packages/t1lib/README.t1lib-5.1.2
    • /usr/share/doc/packages/t1lib/README.t1python
    • /usr/share/doc/packages/t1lib/README.win32
    • /usr/share/doc/packages/t1lib/t1_data.eps
    • /usr/share/doc/packages/t1lib/t1lib_doc.pdf
    • /usr/share/t1lib/t1lib.config
    • /usr/share/t1lib/doc/

    Changelog

    2012-03-26 - hillwood@linuxfans.org - license update: LGPL-2.0 and LGPL-2.1 - Fix build for openSUSE 12.2

    2010-09-26 - mrdocs@opensuse.org - update 5.1.2 + minor bug fixes and some memory out of bounds issues corrected - split out static libs in to subpackage - branched to prepare new version for Factory - bugzilla-240159-array-subscript-out-of-bounds.patch dropped no longer needed - careful check of source includes the same fix - major spec file cleanup to remove rpmlint warnings

    2007-01-31 - mfabian@suse.de - Bugzilla #240159: array subscript out of bounds.

    2007-01-17 - mfabian@suse.de - Bugzilla #137002: update to 5.1.0.

    2006-08-16 - aj@suse.de - Replace xorg-x11-devel BuildRequires with really needed libs.

    2006-06-16 - schwab@suse.de - Handle reference to datarootdir variable.

    2006-01-25 - mls@suse.de - converted neededforbuild to BuildRequires

    2005-02-14 - ro@suse.de - fix build with current tetex - remove tetex from neededforbuild and use prebuilt docu to break cycle between tetex and t1lib

    2005-02-10 - ro@suse.de - added libpng to neededforbuild (for tetex)

    2004-01-10 - adrian@suse.de - add %run_ldconfig

    Advertisement
    Advertisement