yate-devel-6.1.0-lp151.4.2.x86_64.rpm


Advertisement

Description

yate-devel - Development package for Yate

Property Value
Distribution openSUSE Leap 15.1
Repository Packman all
Package filename yate-devel-6.1.0-lp151.4.2.x86_64.rpm
Package name yate-devel
Package version 6.1.0
Package release lp151.4.2
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://www.yate.null.ro/
License GPL-2.0-only
Maintainer -
Download size 150.83 KB
Installed size 931.62 KB
This package contains all necessary include files and libraries needed
to compile and develop applications that use Yate.

Alternatives

Package Version Architecture Repository
yate-devel-6.1.0-lp151.1.4.x86_64.rpm 6.1.0 x86_64 openSUSE Oss
yate-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libyate6 = 6.1.0

Provides

Name Value
pkgconfig(yate) = 6.1.0
yate-devel = 6.1.0-lp151.4.2
yate-devel(x86-64) = 6.1.0-lp151.4.2

Download

Type URL
Mirror packman.inode.at
Binary Package yate-devel-6.1.0-lp151.4.2.x86_64.rpm
Source Package yate-6.1.0-lp151.4.2.src.rpm

Install Howto

  1. Add the Packman repository:
    # zypper addrepo http://packman.inode.at/suse/openSUSE_Leap_15.1/ packman
  2. Install yate-devel rpm package:
    # zypper install yate-devel

Files

Path
/usr/bin/yate-config
/usr/include/yate/qt4client.h
/usr/include/yate/yateasn.h
/usr/include/yate/yatecbase.h
/usr/include/yate/yateclass.h
/usr/include/yate/yatemath.h
/usr/include/yate/yatemime.h
/usr/include/yate/yatengine.h
/usr/include/yate/yatephone.h
/usr/include/yate/yateradio.h
/usr/include/yate/yatescript.h
/usr/include/yate/yateversn.h
/usr/include/yate/yatexml.h
/usr/lib64/libyate.so
/usr/lib64/libyateasn.so
/usr/lib64/libyatejabber.so
/usr/lib64/libyatemgcp.so
/usr/lib64/libyateqt4.so
/usr/lib64/libyateradio.so
/usr/lib64/libyatescript.so
/usr/lib64/libyatesig.so
/usr/lib64/pkgconfig/yate.pc
/usr/share/man/man8/yate-config.8.gz

Changelog

2019-05-20 - Christophe Giboudeaux <christophe@krop.fr>
- Explicitly require zlib at build time.
- Obsolete yate-qt4 for the factory package to avoid file conflicts.
2019-04-28 - Christophe Giboudeaux <christophe@krop.fr>
- Only build the Qt4 GUI up to suse_version 1500.
2018-07-04 - mardnh@gmx.de
- Update tp version 6.1.0
* upstream does not provide changelog
- remove patch:
* yate-openssl-1.1.patch
2018-02-26 - mardnh@gmx.de
- Build with support for sctp
2018-01-08 - jengelh@inai.de
- Implement shared library packaging guideline.
- Drop one instance of an unnecessary %if..%endif guard.
Remove marketing from description.
2018-01-05 - mardnh@gmx.de
- openh323 was dropped from factory (unmaintained and broken)
* Do not longer build against openh323
- Always build against libgsm and spandsp
- Use pkg-config style BuildRequires
- Run spec-cleaner
2018-01-04 - mardnh@gmx.de
- Update to version 6.0.0
* upstream does not provide changelog
2017-12-05 - ro@suse.de
- add patch yate-openssl-1.1.patch
to fix build against openssl-1.1
2017-09-27 - olaf@aepfle.de
- Remove dropped php5 from Requires in scripts subpkg
2017-03-15 - dimstar@opensuse.org
- Explicitly package files installed by make install into _docdir:
rpm 4.13 no longer implicitly packages those files.

See Also

Package Description
yate-qt4-6.1.0-lp151.4.2.x86_64.rpm Qt4 client package for Yate
yate-scripts-6.1.0-lp151.4.2.x86_64.rpm External scripting package for Yate
yate-with-amrnb-6.1.0-lp151.4.2.x86_64.rpm Yate with AMRNB codec support
youtube-dl-2019.09.28-lp151.1.1.noarch.rpm A tool for downloading from Youtube
youtube-dl-bash-completion-2019.09.28-lp151.1.1.noarch.rpm Bash completion for youtube-dl
youtube-dl-fish-completion-2019.09.28-lp151.1.1.noarch.rpm Fish completion for youtube-dl
youtube-dl-zsh-completion-2019.09.28-lp151.1.1.noarch.rpm Zsh Completion for youtube-dl
zbuild-1.6-lp151.1.1.noarch.rpm A tool to create rpm packages in a clean chroot
zdoom-2.8.1-lp151.2.3.x86_64.rpm Highly Advanced Doom source port
zelda-roth-se-1.2.1-lp151.1.1.noarch.rpm Remake of Zelda Return of the Hylian
zelda-xd2-mercuris-chess-1.1.1-lp151.1.1.noarch.rpm Second April fools game from the Solarus Team
zod-20110906-1.1.x86_64.rpm An Open Source Remake of the 1996 Game Z by Bitmap Brothers
zod-data-20110906-1.1.noarch.rpm Zod architecture independent data
zsdx-1.12.2-lp151.1.1.noarch.rpm Zelda Mystery of Solarus DX
Advertisement
Advertisement