vlc-vdpau-3.0.7.1-lp151.6.5.5.x86_64.rpm


Advertisement

Description

vlc-vdpau - Additional vdpau codecs for the VLC media player

Property Value
Distribution openSUSE Leap 15.1
Repository Packman all
Package filename vlc-vdpau-3.0.7.1-lp151.6.5.5.x86_64.rpm
Package name vlc-vdpau
Package version 3.0.7.1
Package release lp151.6.5.5
Package architecture x86_64
Package type rpm
Category Productivity/Multimedia/Video/Players
Homepage http://www.videolan.org
License GPL-2.0-or-later AND LGPL-2.1-or-later
Maintainer -
Download size 74.51 KB
Installed size 121.73 KB
This package enhances the functionality of the VLC media player by
vdpau codecs that are not available in the stock openSUSE distribution.

Alternatives

Package Version Architecture Repository
vlc-vdpau-3.0.8-323.1.x86_64.rpm 3.0.8 x86_64 VLC
vlc-vdpau-3.0.6-lp151.5.1.x86_64.rpm 3.0.6 x86_64 openSUSE Oss
vlc-vdpau - - -

Requires

Name Value
libX11.so.6()(64bit) -
libavcodec.so.57()(64bit) -
libavcodec.so.57(LIBAVCODEC_57)(64bit) -
libavutil.so.55()(64bit) -
libavutil.so.55(LIBAVUTIL_55)(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libvlc_vdpau.so.0()(64bit) -
libvlc_xcb_events.so.0()(64bit) -
libvlccore.so.9()(64bit) -
libxcb.so.1()(64bit) -
vlc-noX -
vlc-noX = 3.0.7.1

Provides

Name Value
libglconv_vdpau_plugin.so()(64bit) -
libvdpau_adjust_plugin.so()(64bit) -
libvdpau_avcodec_plugin.so()(64bit) -
libvdpau_chroma_plugin.so()(64bit) -
libvdpau_deinterlace_plugin.so()(64bit) -
libvdpau_display_plugin.so()(64bit) -
libvdpau_sharpen_plugin.so()(64bit) -
libvlc_vdpau.so.0()(64bit) -
vlc-vdpau = 3.0.7.1-lp151.6.5.5
vlc-vdpau(x86-64) = 3.0.7.1-lp151.6.5.5

Download

Type URL
Mirror packman.inode.at
Binary Package vlc-vdpau-3.0.7.1-lp151.6.5.5.x86_64.rpm
Source Package vlc-3.0.7.1-lp151.6.5.5.src.rpm

Install Howto

  1. Add the Packman repository:
    # zypper addrepo http://packman.inode.at/suse/openSUSE_Leap_15.1/ packman
  2. Install vlc-vdpau rpm package:
    # zypper install vlc-vdpau

Files

Path
/usr/lib64/vlc/libvlc_vdpau.so.0
/usr/lib64/vlc/libvlc_vdpau.so.0.0.0
/usr/lib64/vlc/plugins/vdpau/libvdpau_adjust_plugin.so
/usr/lib64/vlc/plugins/vdpau/libvdpau_avcodec_plugin.so
/usr/lib64/vlc/plugins/vdpau/libvdpau_chroma_plugin.so
/usr/lib64/vlc/plugins/vdpau/libvdpau_deinterlace_plugin.so
/usr/lib64/vlc/plugins/vdpau/libvdpau_display_plugin.so
/usr/lib64/vlc/plugins/vdpau/libvdpau_sharpen_plugin.so
/usr/lib64/vlc/plugins/video_output/libglconv_vdpau_plugin.so

Changelog

2019-07-31 - Dominique Leuenberger <dimstar@opensuse.org>
- Add vlc-CVE-2019-13602_1.patch and vlc-CVE-2019-13602_2.patch:
fix integer underflow in mp4 demuxer (CVE-2019-13602,
boo#1141522).
- Add vlc-CVE-2019-13962.patch: codec: avcodec: fix broken check
before copy (CVE-2019-13962, boo#1142161).
2019-06-14 - Dominique Leuenberger <dimstar@opensuse.org>
- Update to version 3.0.7.1 (CVE-2019-5439, CVE-2019-5459,
CVE-2019-5460, CVE-2019-12874, boo#1138933, boo#1143549, boo#1138354, boo#1143547)
+ Access: Update libbluray to 1.1.2.
+ Video Output:
* Fix hardware acceleration with some AMD drivers
* Improve direct3d11 HDR support
- Changes from version 3.0.7:
+ Access:
* Improve Blu-ray support
* Fix sftp module build with libssh >= 1.8.1
+ Audio output:
* Fix pass-through on Android-23
* Fix DirectSound drain
+ Demux: Improve MP4 support
+ Video Output:
* Fix 12 bits sources playback with Direct3D11
* Fix crash on iOS
* Fix midstream aspect-ratio changes when Windows hardware decoding is on
* Fix HLG display with Direct3D11
+ Stream Output: Improve Chromecast support with new ChromeCast apps
+ Misc:
* Update Youtube, Dailymotion, Vimeo, Soundcloud scripts
* Work around busy looping when playing an invalid item with loop enabled
+ Updated translations.
- Drop vlc-libssh2-ECDSA-version.patch and 0001-codec-vpx-Detect-libvpx-1.8.0.patch: fixed upstream
- Rebase patches/0002-Add-Avahi-implementation-for-chromecast-renderer-dis.patch
2019-05-16 - Fabian Vogt <fvogt@suse.com>
- Require vlc-noX instead of full vlc in vlc-devel
2019-05-02 - olaf@aepfle.de
- The license of fdk-aac is not GPL compatible, therefore this pkg
can not possibly be built with fdk-aac by default
To gain fdk-aac support, recompile it at home and keep it there
- Restore code to handle faad
2019-04-24 - Martin Liška <mliska@suse.cz>
- Disable LTO (boo#1133290).
2019-03-20 - Dominique Leuenberger <dimstar@opensuse.org>
- Add vlc-libssh2-ECDSA-version.patch: sftp: fix version for ECDSA
known hosts (fixes vlc#22060).
2019-03-16 - Bjørn Lie <bjorn.lie@gmail.com>
- Add conditional pkgconfig(dav1d) BuildRequires: build av1
decoding via dav1d decoder.
2019-03-05 - Dominique Leuenberger <dimstar@opensuse.org>
- Limit the use of projectM-qt5 to suse_version > 1320 < 1550.
On Tumbleweed, we now have projectM 3.1.0, which is equivalent
to what our projectM-qt5 used to be.
2019-02-18 - bjorn.lie@gmail.com
- Move vdpau sub-package and it's dependencies out of BUILD_ORIG
conditional, everything it needs is provided by openSUSE.
- Refresh patches with refresh_patches service.
- Drop BUILD_ORIG guarded faad2-devel and libfaac-devel
BuildRequires and stop passing conditional --enable-faad to
configure, libfdkaac is sufficient for aac encoding/decoding.
- Add pkgconfig(aom), pkgconfig(libnfs) and pkgconfig(soxr)
BuildRequires, build the codecs/filters/plugins.
2019-02-12 - Antonio Larrosa <alarrosa@suse.com>
- Add fix-build-with-fdk-2.0.patch to fix building vlc with
libfdk-aac v2
- Add 0001-codec-vpx-Detect-libvpx-1.8.0.patch to fix building vlc
with libvpx 1.8.0
- Add the libx26410b_plugin.so codec plugin when building with
BUILD_ORIG

See Also

Package Description
vlmc-0.2.0ff+git1355-lp151.3.5.aarch64.rpm VideoLAN Movie Creator
vlmc-0.2.0ff+git1355-lp151.3.5.armv7hl.rpm VideoLAN Movie Creator
vlmc-0.2.0ff+git1355-lp151.3.6.x86_64.rpm VideoLAN Movie Creator
vmmlib-devel-1.8.0-lp151.5.1.aarch64.rpm Development files for vmmlib
vmmlib-devel-1.8.0-lp151.5.1.armv7hl.rpm Development files for vmmlib
vmmlib-devel-1.8.0-lp151.5.1.x86_64.rpm Development files for vmmlib
vmmlib-doc-1.8.0-lp151.5.1.noarch.rpm Documentation for vmmlib
vobcopy-1.2.0-lp151.3.3.aarch64.rpm Vobcopy copies DVD .vob files to harddisk
vobcopy-1.2.0-lp151.3.3.armv7hl.rpm Vobcopy copies DVD .vob files to harddisk
vobcopy-1.2.0-lp151.3.3.x86_64.rpm Vobcopy copies DVD .vob files to harddisk
wineasio-0.9.2-lp151.3.1.x86_64.rpm ASIO to JACK driver for wine
winff-1.5.5-lp151.2.28.x86_64.rpm Multimedia File Converter
winff-lang-1.5.5-lp151.2.28.noarch.rpm Translations for package winff
wput-0.6.2-lp151.2.3.x86_64.rpm A utility for uploading files or whole directories to remote ftp-servers
wput-lang-0.6.2-lp151.2.3.noarch.rpm Translations for package wput
Advertisement
Advertisement