liblash1-0.5.4-28.2.armv7hl.rpm


Advertisement

Description

liblash1 - Development package for LASH

Property Value
Distribution openSUSE Leap 15.1
Repository Packman all
Package filename liblash1-0.5.4-28.2.armv7hl.rpm
Package name liblash1
Package version 0.5.4
Package release 28.2
Package architecture armv7hl
Package type rpm
Category Development/Libraries/C and C++
Homepage http://git.savannah.gnu.org/cgit/lash.git
License GPL-2.0+
Maintainer -
Download size 22.78 KB
Installed size 38.02 KB
This package contains the library for the LASH system.

Alternatives

Package Version Architecture Repository
liblash1-0.5.4-28.2.aarch64.rpm 0.5.4 aarch64 Packman
liblash1-0.5.4-lp151.28.2.x86_64.rpm 0.5.4 x86_64 Packman
liblash1 - - -

Requires

Name Value
/sbin/ldconfig -
ld-linux-armhf.so.3 -
ld-linux-armhf.so.3(GLIBC_2.4) -
libc.so.6 -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.5) -
libm.so.6 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.4) -
libreadline.so.7 -
libuuid.so.1 -
libuuid.so.1(UUID_1.0) -

Provides

Name Value
liblash.so.1 -
liblash1 = 0.5.4-28.2
liblash1(armv7hl-32) = 0.5.4-28.2

Download

Type URL
Mirror packman.inode.at
Binary Package liblash1-0.5.4-28.2.armv7hl.rpm
Source Package lash-0.5.4-28.2.src.rpm

Install Howto

  1. Add the Packman repository:
    # zypper addrepo http://packman.inode.at/suse/openSUSE_Leap_15.1/ packman
  2. Install liblash1 rpm package:
    # zypper install liblash1

Files

Path
/usr/lib/liblash.so.1
/usr/lib/liblash.so.1.1.1
/usr/lib/liblash.so.2
/usr/lib/liblash.so.2.0.0

Changelog

2015-08-11 - dimstar@opensuse.org
- Add lash-glibc-2.22.patch: Fix build with glibc 2.22. getattrinfo
is now only declared in _POSIX_C_SOURCE >= 200112L.
2015-08-11 - idonmez@suse.com
- Add baselibs.conf as source
2012-07-29 - aj@suse.de
- Add missing sys/resource.h include (glibc 2.16)
2011-11-13 - coolo@suse.com
- add libtool as explicit buildrequire to avoid implicit dependency from prjconf
2011-09-19 - crrodriguez@opensuse.org
- Link with libm as well.
2011-05-26 - idonmez@novell.com
- Add lash-swig-2x.patch: support swig 2.x
2011-05-01 - toddrme2178@gmail.com
- Added 32bit compatibility libraries
- Removed test for obsolete openSUSE versions
2010-09-12 - stephan.barth@novell.com
- update to version 0.5.4 which contains a lot of changes
- reworked the spec file to remove all warnings
- added version specific datadir tags
- added python package
- needed to create links for liblash.so.2 for downward compatibility
- removed obsolete lash-nogtk1.diff which was there for GTK1
- removed now obsolete lash-automake-fix.diff
2009-06-29 - tiwai@suse.de
- fix buildrequires to use libjack-devel
- fix URL
2009-03-23 - crrodriguez@suse.de
- remove static libraries and "la" files
- fix -devel package dependencies and pkgconfig files

See Also

Package Description
liblash1-64bit-0.5.4-28.2.aarch64_ilp32.rpm Development package for LASH
liblinuxsampler-devel-2.1.0-lp151.16.84.x86_64.rpm Development files for linuxsampler
liblinuxsampler5-2.1.0-lp151.16.84.x86_64.rpm Shared libraries for linuxsampler
libliveMedia-devel-2012.02.04-lp151.3.2.aarch64.rpm Libraries from live555.com
libliveMedia-devel-2012.02.04-lp151.3.2.armv7hl.rpm Libraries from live555.com
libliveMedia-devel-2012.02.04-lp151.3.3.x86_64.rpm Libraries from live555.com
liblsmash2-2.14.5-lp151.1.1.x86_64.rpm Libraries of L-SMASH
libmac-devel-3.99_u4_b5_s7-lp151.5.1.aarch64.rpm Monkey's Audio Codec, a lossless audio codec - API libraries and include files
libmac-devel-3.99_u4_b5_s7-lp151.5.1.armv7hl.rpm Monkey's Audio Codec, a lossless audio codec - API libraries and include files
libmac-devel-3.99_u4_b5_s7-lp151.5.1.x86_64.rpm Monkey's Audio Codec, a lossless audio codec - API libraries and include files
libmac2-3.99_u4_b5_s7-lp151.5.1.aarch64.rpm Monkey's Audio Codec, a lossless audio codec
libmac2-3.99_u4_b5_s7-lp151.5.1.armv7hl.rpm Monkey's Audio Codec, a lossless audio codec
libmac2-3.99_u4_b5_s7-lp151.5.1.x86_64.rpm Monkey's Audio Codec, a lossless audio codec
libmakemkv1-1.14.5-lp151.1.1.x86_64.rpm MakeMKV libmakemkv
libmcli-0.9.186-lp151.5.3.x86_64.rpm Shared library vdr-plugin-mcli
Advertisement
Advertisement