python2-pytz-2018.5-lp151.1.1.noarch.rpm


Advertisement

Description

python2-pytz - World timezone definitions, modern and historical

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename python2-pytz-2018.5-lp151.1.1.noarch.rpm
Package name python2-pytz
Package version 2018.5
Package release lp151.1.1
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage http://pytz.sourceforge.net
License MIT
Maintainer -
Download size 51.05 KB
Installed size 258.13 KB
pytz - World Timezone Definitions for Python
pytz brings the Olson tz database into Python. This library allows
accurate and cross platform timezone calculations using Python 2.4
or higher. It also solves the issue of ambiguous times at the end
of daylight savings, which you can read more about in the Python
Library Reference (``datetime.tzinfo``).
Amost all of the Olson timezones are supported.

Alternatives

Package Version Architecture Repository
python2-pytz - - -

Requires

Name Value
python(abi) = 2.7
timezone -

Provides

Name Value
python-pytz = 2018.5-lp151.1.1
python-tz = 2018.5
python2-pytz = 2018.5-lp151.1.1

Obsoletes

Name Value
python-pytz < 2018.5-lp151.1.1
python-tz < 2018.5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-pytz-2018.5-lp151.1.1.noarch.rpm
Source Package python-pytz-2018.5-lp151.1.1.src.rpm

Install Howto

Install python2-pytz rpm package:

# zypper install python2-pytz

Files

Path
/usr/lib/python2.7/site-packages/pytz/__init__.py
/usr/lib/python2.7/site-packages/pytz/__init__.pyc
/usr/lib/python2.7/site-packages/pytz/__init__.pyo
/usr/lib/python2.7/site-packages/pytz/exceptions.py
/usr/lib/python2.7/site-packages/pytz/exceptions.pyc
/usr/lib/python2.7/site-packages/pytz/exceptions.pyo
/usr/lib/python2.7/site-packages/pytz/lazy.py
/usr/lib/python2.7/site-packages/pytz/lazy.pyc
/usr/lib/python2.7/site-packages/pytz/lazy.pyo
/usr/lib/python2.7/site-packages/pytz/reference.py
/usr/lib/python2.7/site-packages/pytz/reference.pyc
/usr/lib/python2.7/site-packages/pytz/reference.pyo
/usr/lib/python2.7/site-packages/pytz/tzfile.py
/usr/lib/python2.7/site-packages/pytz/tzfile.pyc
/usr/lib/python2.7/site-packages/pytz/tzfile.pyo
/usr/lib/python2.7/site-packages/pytz/tzinfo.py
/usr/lib/python2.7/site-packages/pytz/tzinfo.pyc
/usr/lib/python2.7/site-packages/pytz/tzinfo.pyo
/usr/lib/python2.7/site-packages/pytz-2018.5-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/pytz-2018.5-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/pytz-2018.5-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/pytz-2018.5-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/pytz-2018.5-py2.7.egg-info/zip-safe
/usr/share/doc/packages/python2-pytz/README.txt
/usr/share/licenses/python2-pytz/LICENSE.txt

Changelog

2018-06-30 - astieger@suse.com
- update to 2018.5:
* various python compatibility fixes
- fix upstream signing key
2018-02-17 - arun@gmx.de
- specfile:
* update copyright year
* move from zip to tar.gz
* updated line number in patches and fixed whitespace issues:
o 0001-Fix-tests-for-older-timezone-versions.patch
o fix-tests.patch
o system-zoneinfo.patch
- update to version 2018.3:
* Test updates for Iana 2018c changes
* delint
* lint target & update iana build rule
* Bump version numbers to 2018.3/2018c
* Include license file in the generated wheel package
* Update travis config
2017-11-02 - arun@gmx.de
- updated system_zoneinfo.patch
- update to version 2017.3:
* PYTZ_TZDATADIR environment variable override of database location
* Allow pickles from Python2 to be unpickled with Python3
* Remove unmaintained CHANGES.txt
* Test with Python 3.6
* Detect compiled tzfiles by sniffing magic
* Squashed 'tz/' changes from f8ebe3a64..e6ff702de
* Be explicit about supported Python versions
* Fixed README.txt to not issue warnings.
2017-06-28 - tbechtold@suse.com
- add 0001-Fix-tests-for-older-timezone-versions.patch?. This fixes
the tests on SLE12SP2 and SLE12SP3
2017-04-05 - jmatejek@suse.com
- create correct backwards-compatible Obsoletes/Provides
- revert to semantic PyPI URLs
2017-04-03 - astieger@suse.com
- update to 2017.2:
* include IANA 2017b, tests assume >= 2017a is used
* drop pytz-2016.10-fix-tests-with-2017a.patch, upstream
2017-03-20 - dimstar@opensuse.org
- Apply pytz-2016.10-fix-tests-with-2017a.patch for Tumbleweed
buildin.
2017-03-16 - toddrme2178@gmail.com
- Implement single-spec version
2017-03-15 - astieger@suse.com
- update to 2016.10:
* includes IANA 2016j
* No longer fails with timezone-2017a bsc#1027705
add pytz-2016.10-fix-tests-with-2017a.patch
2016-04-25 - astieger@suse.com
- update to 2016.4
* including fixes for Venezuela (America/Caracas) boo#975875

See Also

Package Description
python2-pyuca-1.2-lp151.1.1.noarch.rpm Python implementation of the Unicode Collation Algorithm
python2-pyudev-0.21.0-lp151.4.2.noarch.rpm Udev bindings for Python
python2-pyviz-comms-0.7.0-lp151.1.1.noarch.rpm Tool to launch jobs, organize the output, and dissect the results
python2-pyvmomi-6.7.1.2018.12-lp151.1.1.noarch.rpm VMware vSphere Python SDK
python2-pywbem-0.11.0-lp151.3.2.noarch.rpm Python module for making CIM operation calls using the WBEM protocol
python2-pywinrm-0.3.0-lp151.3.1.noarch.rpm Python library for Windows Remote Management
python2-pyxdg-0.25-lp151.2.1.noarch.rpm Implementations of freedesktop.org standards in python
python2-pyzmq-17.0.0-lp151.2.3.x86_64.rpm Python bindings for 0MQ
python2-pyzmq-devel-17.0.0-lp151.2.3.x86_64.rpm Development files for python2-pyzmq
python2-qrcode-5.3-lp151.2.2.noarch.rpm QR Code image generator
python2-qscintilla-qt4-2.10.4-lp151.2.78.x86_64.rpm Python Bindings for the C++ Editor Class Library
python2-qscintilla-qt5-2.10.4-lp151.2.78.x86_64.rpm Python Bindings for the C++ Editor Class Library
python2-qt4-4.12.1-lp151.3.5.x86_64.rpm PyQt - python bindings for Qt 4
python2-qt4-devel-4.12.1-lp151.3.5.x86_64.rpm PyQt - devel part of python bindings for Qt 4
python2-qt5-5.11.3-lp151.1.2.x86_64.rpm PyQt - python bindings for Qt 5
Advertisement
Advertisement