libspice-server1-0.14.1-lp151.2.1.x86_64.rpm


Advertisement

Description

libspice-server1 - Library for SPICE-server

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename libspice-server1-0.14.1-lp151.2.1.x86_64.rpm
Package name libspice-server1
Package version 0.14.1
Package release lp151.2.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://www.spice-space.org/
License LGPL-2.1-or-later OR GPL-2.0-or-later
Maintainer -
Download size 590.76 KB
Installed size 2.11 MB
Library for SPICE-server
The SPICE server is used to expose a remote machine's display
and devices.

Alternatives

Package Version Architecture Repository
libspice-server1 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.14)(64bit) -
libcrypto.so.1.1()(64bit) -
libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgstapp-1.0.so.0()(64bit) -
libgstreamer-1.0.so.0()(64bit) -
libjpeg.so.8()(64bit) -
libjpeg.so.8(LIBJPEG_8.0)(64bit) -
liblz4.so.1()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libopus.so.0()(64bit) -
liborc-0.4.so.0()(64bit) -
libpixman-1.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.12)(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.2.5)(64bit) -
libsasl2.so.3()(64bit) -
libssl.so.1.1()(64bit) -
libssl.so.1.1(OPENSSL_1_1_0)(64bit) -
libz.so.1()(64bit) -

Provides

Name Value
libspice-server.so.1()(64bit) -
libspice-server.so.1(SPICE_SERVER_0.10.0)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.10.1)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.10.2)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.10.3)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.10.4)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.11.2)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.11.4)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.12.2)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.12.3)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.12.4)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.12.5)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.12.6)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.13.1)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.13.2)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.6.0)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.6.1)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.8.0)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.8.1)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.8.2)(64bit) -
libspice-server.so.1(SPICE_SERVER_0.8.3)(64bit) -
libspice-server1 = 0.14.1-lp151.2.1
libspice-server1(x86-64) = 0.14.1-lp151.2.1

Obsoletes

Name Value
spice-client < 0.14.1-lp151.2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libspice-server1-0.14.1-lp151.2.1.x86_64.rpm
Source Package spice-0.14.1-lp151.2.1.src.rpm

Install Howto

Install libspice-server1 rpm package:

# zypper install libspice-server1

Files

Path
/usr/lib64/libspice-server.so.1
/usr/lib64/libspice-server.so.1.12.5
/usr/share/doc/packages/libspice-server1/ChangeLog
/usr/share/doc/packages/libspice-server1/NEWS
/usr/share/doc/packages/libspice-server1/README
/usr/share/licenses/libspice-server1/COPYING

Changelog

2019-01-28 - Bruce Rogers <brogers@suse.com>
- Fix OOB memory access in internal tracking of slot_ids and
group_ids. (CVE-2019-3813 bsc#1122706)
* 0001-memslot-Fix-off-by-one-error-in-group-slot-boundary-.patch
- Remove celt051 Requires directive
2018-09-19 - astieger@suse.com
- Upstream disabled support for the celt051 audio codec by default,
do likewise in the spec
- Note updated 0.14.1 build dependencies in the spec:
* OpenSSL 1.0.0 or newer is now required
* glib 2.32 required
- add upstream signing key and verify source signature
2018-09-19 - Bruce Rogers <brogers@suse.com>
- Update to v0.14.1 stable release
The announcement email describes this release as follows:
The main change in this release is the addition of a new protocol
extension in order to support streaming the remote display as a
video stream rather than going through the QXL protocol. Together
with spice-streaming-agent, and/or with more work on the qemu/
spice-server side, this should allow streaming of 3D accelerated
VMs in the future. At this point, this part of spice-server is
still a work in progress (multi-monitor support and various
features are missing).
* avoid performance issues on Windows 10 KVM guests (boo#1109044)
* add new org.spice-space.stream.0 channel used for passing an
encoded video stream from the guest to the client
* add support for TCP_CORK to reduce the amount of packets that
we send
* fix CVE-2018-10873 (maintainer note: we already carried fix)
* fix cursor related migration crash
* fix regression causing sound recording to be muted after client
disconnection/reconnection (introduced in 0.13.90)
* fix regression in corner cases where images could be sent
uncompressed when they used to be compressed with QUIC
* disable TLS 1.0 support
* CELT 0.5.1 support is now disabled by default. If celt051-devel
is installed at build-time, --enable-celt051/--disable-celt051
must be explicitly specified
* drop support for unsupported OpenSSL version. OpenSSL 1.0.0 or
newer is now required
* bumped minimum required glib version to 2.32
* endianness fixes
* (small) leak fixes
* usual round of code cleanups
* not directly related to this release, but the upstream git
repository is now hosted on gitlab.freedesktop.org
- Removed patches:
bb15d481-Fix-flexible-array-buffer-overflow.patch
2018-08-20 - cbosdonnat@suse.com
- Fix potential heap corruption when demarshalling (CVE-2018-10873,
bsc#1104448)
Added patch:
bb15d481-Fix-flexible-array-buffer-overflow.patch
2018-07-16 - cbosdonnat@suse.com
- Avoid buffer overflow on image lz cheks (CVE-2018-10893, bsc#1101295)
Added patches:
0001-lz-Avoid-buffer-reading-overflow-checking-for-image-.patch
0002-lz-More-checks-on-image-sizes.patch
2018-01-30 - jengelh@inai.de
- Correct RPM group for shared library.
2018-01-30 - tchvatal@suse.com
- Split the sle condition again for exact features to allow their
override
2018-01-18 - tchvatal@suse.com
- Enable smartcards on sle15 as the supportlib is available
* Condition it using name everywhere instead of suse versions
and join together with lz4
- Format with spec-cleaner
- Convert dependencies to pkgconfig style
- Install documentation and license file
- Add configure arguments to most of the options to not rely on
autotools automatic behavior
* Also enable gstreamer and lz4 options
- Drop the not needed python dependencies, they are needed only
when building from git snapshot

See Also

Package Description
libspiro-devel-0.5.20150702-lp151.2.2.x86_64.rpm Development Files for libspiro
libspiro0-0.5.20150702-lp151.2.2.x86_64.rpm A clothoid to bezier spline converter
libsplinter-3-0-3.0-lp151.3.4.x86_64.rpm A library for multivariate function approximation implemented in C++
libspnav-devel-0.2.3-lp151.2.3.x86_64.rpm Include files for libspnav
libspnav0-0.2.3-lp151.2.3.x86_64.rpm Library for accessing 3D connexion devices
libspqr2-2.0.8-lp151.4.1.x86_64.rpm Multifrontal Sparse QR
libspread-sheet-widget0-0.3-lp151.1.1.x86_64.rpm GNU Spread Sheet Widget library for Gtk+
libsqlcipher-3_20_1-0-3.4.2-lp151.2.4.x86_64.rpm Shared library for SQLCipher
libsqlite3-0-3.28.0-lp151.1.1.x86_64.rpm Shared libraries for the Embeddable SQL Database Engine
libsqlite3-0-32bit-3.28.0-lp151.1.1.x86_64.rpm Shared libraries for the Embeddable SQL Database Engine
libsratom-0-0-0.6.0-lp151.2.3.x86_64.rpm A library for serialising LV2 atoms to/from RDF
libsratom-0-0-32bit-0.6.0-lp151.2.3.x86_64.rpm A library for serialising LV2 atoms to/from RDF
libsrecord0-1.64-lp151.2.47.x86_64.rpm Srecord libraries
libsrt1-1.3.1-lp151.1.3.x86_64.rpm Secure Reliable Transport (SRT) library
libsrtp-devel-1.6.0-lp151.3.2.x86_64.rpm Development files for the Secure Real-Time Transport Protocol (SRTP) library
Advertisement
Advertisement