libexpat-devel-2.2.5-lp151.2.4.x86_64.rpm


Advertisement

Description

libexpat-devel - Development files for expat, an XML parser toolkit

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename libexpat-devel-2.2.5-lp151.2.4.x86_64.rpm
Package name libexpat-devel
Package version 2.2.5
Package release lp151.2.4
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://libexpat.github.io
License MIT
Maintainer -
Download size 33.00 KB
Installed size 51.53 KB
Expat is an XML parser library written in C. It is a stream-oriented
parser in which an application registers handlers for things the
parser might find in the XML document (like start tags).
This package contains the development headers for the library found
in libexpat.

Alternatives

Package Version Architecture Repository
libexpat-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
glibc-devel -
libexpat1 = 2.2.5

Provides

Name Value
libexpat-devel = 2.2.5-lp151.2.4
libexpat-devel(x86-64) = 2.2.5-lp151.2.4
pkgconfig(expat) = 2.2.5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libexpat-devel-2.2.5-lp151.2.4.x86_64.rpm
Source Package expat-2.2.5-lp151.2.4.src.rpm

Install Howto

Install libexpat-devel rpm package:

# zypper install libexpat-devel

Files

Path
/usr/include/expat.h
/usr/include/expat_config.h
/usr/include/expat_external.h
/usr/lib64/libexpat.so
/usr/lib64/pkgconfig/expat.pc

Changelog

2017-11-16 - jengelh@inai.de
- Expand description of expat-devel.
2017-11-16 - mpluskal@suse.com
- Do not generate manpages from docbook
- Temporarily disable profiling due to bug in build system
2017-11-08 - aavindraa@gmail.com
- Version update to 2.2.5 Tue October 31 2017
* Bug fixes:
- If the parser runs out of memory, make sure its internal
state reflects the memory it actually has, not the memory
it wanted to have.
- The default handler wasn't being called when it should for
a SYSTEM or PUBLIC doctype if an entity declaration handler
was registered.
- Fix a case of mistakenly reported parsing success where
XML_StopParser was called from an element handler
- Function XML_ErrorString was returning NULL rather than
a message for code XML_ERROR_INVALID_ARGUMENT
introduced with release 2.2.1
* Other changes:
- Add argument -N adding notation declarations
- various compiler-specific fixes
- Improve docbook2x-man detection
- drop expat-docbook.patch
* fixed in 0f5186c7b8e503c669e332d944712de010b265f3
- switch to github for release tarballs and website

See Also

Package Description
libexpat-devel-32bit-2.2.5-lp151.2.4.x86_64.rpm Development files for expat, an XML parser toolkit
libexpat1-2.2.5-lp151.2.4.x86_64.rpm XML Parser Toolkit
libexpat1-32bit-2.2.5-lp151.2.4.x86_64.rpm XML Parser Toolkit
libexplain-devel-1.4-lp151.2.59.x86_64.rpm Development files for libexplain
libexplain51-1.4-lp151.2.59.x86_64.rpm Explains system call error reports
libext2fs-devel-1.43.8-lp151.4.60.x86_64.rpm Development files for libext2fs
libext2fs-devel-32bit-1.43.8-lp151.4.60.x86_64.rpm Development files for libext2fs
libext2fs-devel-static-1.43.8-lp151.4.60.x86_64.rpm Development files for libext2fs
libext2fs2-1.43.8-lp151.4.60.x86_64.rpm Ext2fs library
libext2fs2-32bit-1.43.8-lp151.4.60.x86_64.rpm Ext2fs library
libexttextcat-2_0-0-3.4.5-lp151.2.2.x86_64.rpm Text categorization library
libexttextcat-3.4.5-lp151.2.2.x86_64.rpm Text categorization library datafiles and documents
libexttextcat-devel-3.4.5-lp151.2.2.x86_64.rpm Files for Developing with libexttextcat
libexttextcat-tools-3.4.5-lp151.2.2.x86_64.rpm Tool for creating custom document fingerprints
libf2fs1-1.7.0-lp151.2.4.x86_64.rpm Library to manipulate F2 filesystems
Advertisement
Advertisement