gvim-8.0.1568-lp151.4.4.x86_64.rpm


Advertisement

Description

gvim - A GUI for Vi

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss x86_64
Package filename gvim-8.0.1568-lp151.4.4.x86_64.rpm
Package name gvim
Package version 8.0.1568
Package release lp151.4.4
Package architecture x86_64
Package type rpm
Category Productivity/Text/Editors
Homepage http://www.vim.org/
License Vim
Maintainer -
Download size 1.56 MB
Installed size 3.23 MB
Package gvim contains the largest set of features of vim, which is
graphical windows and language interpreter, like python, ruby, or perl.
You need package vim for the help and other documentation too. If you
want less features, you might want to install vim instead.

Alternatives

Package Version Architecture Repository
gvim-8.0.1568-lp151.5.3.1.i586.rpm 8.0.1568 i586 openSUSE Update Oss
gvim-8.0.1568-lp151.5.3.1.x86_64.rpm 8.0.1568 x86_64 openSUSE Update Oss
gvim - - -

Requires

Name Value
libICE.so.6()(64bit) -
libSM.so.6()(64bit) -
libX11.so.6()(64bit) -
libXt.so.6()(64bit) -
libacl.so.1()(64bit) -
libacl.so.1(ACL_1.0)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libcairo.so.2()(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgdk-3.so.0()(64bit) -
libgdk_pixbuf-2.0.so.0()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgpm.so.2()(64bit) -
libgtk-3.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpango-1.0.so.0()(64bit) -
libpangocairo-1.0.so.0()(64bit) -
libperl.so()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libtinfo.so.6()(64bit) -
libtinfo.so.6(NCURSES6_TINFO_5.0.19991023)(64bit) -
update-alternatives -
vim-data = 8.0.1568-lp151.4.4

Provides

Name Value
application() -
application(gvim.desktop) -
config(gvim) = 8.0.1568-lp151.4.4
gvim = 8.0.1568-lp151.4.4
gvim(x86-64) = 8.0.1568-lp151.4.4
gvim-base = 8.0.1568-lp151.4.4
gvim-enhanced = 8.0.1568-lp151.4.4
gvim_client -
mimehandler(application/x-shellscript) -
mimehandler(text/english) -
mimehandler(text/plain) -
mimehandler(text/x-c) -
mimehandler(text/x-c++) -
mimehandler(text/x-c++hdr) -
mimehandler(text/x-c++src) -
mimehandler(text/x-chdr) -
mimehandler(text/x-csrc) -
mimehandler(text/x-java) -
mimehandler(text/x-makefile) -
mimehandler(text/x-moc) -
mimehandler(text/x-pascal) -
mimehandler(text/x-tcl) -
mimehandler(text/x-tex) -
vi -
vim_client -

Conflicts

Name Value
gvim < 8.0

Obsoletes

Name Value
gvim-base < 8.0.1568-lp151.4.4
gvim-enhanced < 8.0.1568-lp151.4.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package gvim-8.0.1568-lp151.4.4.x86_64.rpm
Source Package vim-8.0.1568-lp151.4.4.src.rpm

Install Howto

Install gvim rpm package:

# zypper install gvim

Files

Path
/etc/gvimrc
/etc/alternatives/vim
/usr/bin/egview
/usr/bin/egvim
/usr/bin/eview
/usr/bin/evim
/usr/bin/gex
/usr/bin/gvi
/usr/bin/gview
/usr/bin/gvim
/usr/bin/gvimdiff
/usr/bin/rgview
/usr/bin/rgvim
/usr/bin/vim
/usr/share/applications/gvim.desktop
/usr/share/doc/packages/gvim/README.Japanese-XIM
/usr/share/doc/packages/gvim/gui_x11.txt
/usr/share/doc/packages/gvim/gvimrc_example.vim
/usr/share/doc/packages/gvim/suse.gvimrc
/usr/share/icons/hicolor/24x24/apps/gvim.png
/usr/share/icons/hicolor/32x32/apps/gvim.png
/usr/share/icons/hicolor/48x48/apps/gvim.png
/usr/share/icons/hicolor/64x64/apps/gvim.png
/usr/share/icons/hicolor/96x96/apps/gvim.png
/usr/share/icons/hicolor/scalable/apps/gvim.svg

Changelog

2018-04-04 - stefan.bruens@rwth-aachen.de
- Pre-convert gvim icons, otherwise building vim depends on
rsvg-convert -> librsvg -> cargo -> Rust -> LLVM
- Cleanup SVG icon, make lines pixel-grid aligned
- Correct RPM Group
2018-04-03 - kukuk@suse.de
- Use %license instead of %doc [bsc#1082318]
2018-03-23 - lnussel@suse.de
- instead of explicitly unsetting mouse, remove it from the defaults in the
first place (boo#1079185, vim-8.0.1568-defaults.patch)
2018-03-08 - idonmez@suse.com
- Switch to make -j1 clean to see if it fixes random build failures
on Leap/SLE 15.
2018-03-05 - idonmez@suse.com
- Updated to revision 1568, fixes the following problems
* No test using a screen dump yet.
* Screen dump test fails on MS-Windows.
* Dead code found.
* Assert_equalfile() does not close file descriptors. (Coverity)
* Dump test fails when using a shadow directory.
* Cannot use 24 bit colors in MS-Windows console.
* Compiler warnings without termguicolors feature.
* Libterm doesn't support requesting fg and bg color.
* C syntax test fails when using gvim
* C syntax test still fails when using gvim.
* Quotestar test is flaky when using the GUI.
* Xxd does not skip NUL lines when using ebcdic.
* Popupmenu is too far left when completion is long. (Linwei)
* No test for the popup menu positioning.
* Popup menu positioning fails with longer string.
* synpat_T is taking too much memory.
* Terminal screen dump does not include cursor position.
* With 'termguicolors' Normal color doesn't work correctly.
* When using 'termguicolors' SpellBad doesn't show.
* Screen dumps not included in distribution.
* Using feedkeys() in a terminal window may trigger mappings.
(Charles Sheridan)
* Undo in the options window makes it empty.
* Screen dump test script not included in distribution.
* Various small problems in test files.
* Various small problems in source files.
* On Mac 'maxmemtot' is set to a weird value.
* May leak file descriptors when executing job.
* Cannot see what digraph is used to insert a character.
* Custom plugins loaded with --clean.
* Build error for some combination of features.
* May not parse the t_RS response correctly, resulting in wrong characters
in the input stream.
* printf() does not work with only one argument. (Daniel Hahler)
* No right-click menu in a terminal.
* Build failure without GUI.
* Build failure without GUI on MS-Windows.
* Crash with rust syntax highligting. (Edd Barrett)
* The terminal debugger can't set a breakpoint with the mouse.
* Timeout of getwinposx() can be too short. (lilydjwg)
* Too many #ifdefs.
* Can't build Mac version without GUI.
* Too many #ifdefs.
* Cannot build Win32 GUI without IME. (John Marriott)
* Can't build on older Mac, header file is missing.
2018-03-02 - idonmez@suse.com
- Recommend vim-data so that colors can work by default

See Also

Package Description
gweather-data-3.26.1-lp151.2.3.noarch.rpm Auxiliary schema data for libgweather
gwenhywfar-4.18.0-lp151.2.4.x86_64.rpm Multiplatform helper library for other libraries
gwenhywfar-devel-4.18.0-lp151.2.4.x86_64.rpm Multi-Platform Helper Library for Other Libraries
gwenhywfar-lang-4.18.0-lp151.2.4.noarch.rpm Translations for package gwenhywfar
gwenhywfar-tools-4.18.0-lp151.2.4.x86_64.rpm Multiplatform Helper Library for Other Libraries - Tools
gwenview5-18.12.3-lp151.2.1.x86_64.rpm Image Viewer by KDE
gwenview5-lang-18.12.3-lp151.2.1.noarch.rpm Translations for package gwenview5
gxditview-1.22.3-lp151.4.48.x86_64.rpm Ditroff Output Displayer for Groff
gyp-0+git.20171012-lp151.2.2.noarch.rpm Generate Your Projects
gypsy-0.9-lp151.3.3.x86_64.rpm GPS multiplexing daemon
gzdoom-3.2.5-lp151.2.4.x86_64.rpm A DOOM source port with graphic and modding extensions
gzip-1.9-lp151.3.68.x86_64.rpm GNU Zip Compression Utilities
gzrt-0.8-lp151.2.2.x86_64.rpm Recover data from a corrupted gzip file
h5utils-1.13.1-lp151.1.2.x86_64.rpm Utilities for Data Conversions from hdf5
ha-cluster-bootstrap-0.5-lp151.3.1.noarch.rpm Pacemaker HA Cluster Bootstrap Tool
Advertisement
Advertisement