gf2x-devel-1.2-lp151.3.8.x86_64.rpm


Advertisement

Description

gf2x-devel - Development headers for libgf2x

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename gf2x-devel-1.2-lp151.3.8.x86_64.rpm
Package name gf2x-devel
Package version 1.2
Package release lp151.3.8
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://gforge.inria.fr/projects/gf2x/
License GPL-3.0-or-later
Maintainer -
Download size 18.03 KB
Installed size 64.52 KB
gf2x is a library for fast multiplication of polynomials over the
GF(2) binary field.
This package contains the interface definitions for the gf2x library.

Alternatives

Package Version Architecture Repository
gf2x-devel - - -

Requires

Name Value
libgf2x-1_2 = 1.2

Provides

Name Value
gf2x-devel = 1.2-lp151.3.8
gf2x-devel(x86-64) = 1.2-lp151.3.8

Download

Type URL
Mirror widehat.opensuse.org
Binary Package gf2x-devel-1.2-lp151.3.8.x86_64.rpm
Source Package gf2x-1.2-lp151.3.8.src.rpm

Install Howto

Install gf2x-devel rpm package:

# zypper install gf2x-devel

Files

Path
/usr/include/gf2x.h
/usr/include/gf2x/gf2x-config-export.h
/usr/include/gf2x/gf2x-config.h
/usr/include/gf2x/gf2x-impl-export.h
/usr/include/gf2x/gf2x-impl.h
/usr/include/gf2x/gf2x-small.h
/usr/include/gf2x/gf2x-thresholds.h
/usr/include/gf2x/gf2x_mul1.h
/usr/include/gf2x/gf2x_mul2.h
/usr/include/gf2x/gf2x_mul3.h
/usr/include/gf2x/gf2x_mul4.h
/usr/include/gf2x/gf2x_mul5.h
/usr/include/gf2x/gf2x_mul6.h
/usr/include/gf2x/gf2x_mul7.h
/usr/include/gf2x/gf2x_mul8.h
/usr/include/gf2x/gf2x_mul9.h
/usr/lib64/libgf2x.so

Changelog

2018-04-30 - jengelh@inai.de
- Ensure neutrality of description.
2017-12-25 - jengelh@inai.de
- Update to new upstream release 1.2
* No user changelog available
- Remove gf2x-memset.diff (fixed upstream)
- Add 0001-build-fix-version-info-for-libgf2x-after-ABI-break.patch
2015-06-26 - jengelh@inai.de
- Disable SSE2 on x86 because it is not necessarily present
- Add gf2x-memset.diff
2012-11-29 - jengelh@inai.de
- Update to new upstream release 1.1
* trap bad arguments to gf2x_tfft_init
2011-09-15 - jengelh@medozas.de
- Initial package (version 1.0) for build.opensuse.org

See Also

Package Description
gfan-0.6.2-lp151.2.48.x86_64.rpm Calculation of Gröbner fans
gfbgraph-devel-0.2.3-lp151.2.2.x86_64.rpm Access the Facebook Graph API -- Development files
gfio-3.4-lp151.4.6.x86_64.rpm Graphical front end for fio
gflags-2.2.1-lp151.1.1.x86_64.rpm Library for commandline flag processing
gflags-devel-2.2.1-lp151.1.1.x86_64.rpm Development files for gflags library
gflags-devel-static-2.2.1-lp151.1.1.x86_64.rpm Statically linked development libraries for gflags
gfs2-utils-3.1.9-lp151.2.3.x86_64.rpm Utilities for managing the global file system (GFS2)
gfxboot-4.5.50-lp151.1.1.x86_64.rpm Graphical Boot Logo for GRUB, LILO and SYSLINUX
gfxboot-branding-KDE-4.5.50-lp151.1.1.x86_64.rpm Graphical bootloader KDE theme
gfxboot-branding-openSUSE-15.1-lp151.2.2.noarch.rpm Graphical bootloader openSUSE theme
gfxboot-branding-upstream-4.5.50-lp151.1.1.x86_64.rpm Graphical bootloader upstream theme
gfxboot-devel-4.5.50-lp151.1.1.x86_64.rpm Tools for creating a graphical boot logo
ggz-client-libs-0.0.14.1-lp151.2.3.x86_64.rpm Common files needed to use GGZ
ggz-client-libs-devel-0.0.14.1-lp151.2.3.x86_64.rpm Development files for ggz-client-libs
ggz-client-libs-lang-0.0.14.1-lp151.2.3.noarch.rpm Translations for package ggz-client-libs
Advertisement
Advertisement