gedit-plugin-code-assistance-3.16.0-lp151.2.3.x86_64.rpm


Advertisement

Description

gedit-plugin-code-assistance - Plugin for gedit which provides code assistance for C, C++ and Objective-C

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename gedit-plugin-code-assistance-3.16.0-lp151.2.3.x86_64.rpm
Package name gedit-plugin-code-assistance
Package version 3.16.0
Package release lp151.2.3
Package architecture x86_64
Package type rpm
Category Productivity/Text/Editors
Homepage http://git.gnome.org/browse/gedit-code-assistance
License GPL-3.0+
Maintainer -
Download size 117.84 KB
Installed size 390.49 KB
gedit-code-assistance is a plugin for gedit which provides code
assistance for C, C++ and Objective-C by utilizing clang.

Alternatives

Package Version Architecture Repository
gedit-plugin-code-assistance - - -

Requires

Name Value
gedit -
libc.so.6(GLIBC_2.4)(64bit) -
libcairo.so.2()(64bit) -
libgdk-3.so.0()(64bit) -
libgee-0.8.so.2()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-3.so.0()(64bit) -
libgtksourceview-3.0.so.1()(64bit) -
libpeas-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -

Provides

Name Value
gedit-code-assistance = 3.16.0
gedit-plugin-code-assistance = 3.16.0-lp151.2.3
gedit-plugin-code-assistance(x86-64) = 3.16.0-lp151.2.3
libcodeassistance.so()(64bit) -
libgcaindentbackendc.so()(64bit) -
metainfo() -
metainfo(gedit-code-assistance.metainfo.xml) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package gedit-plugin-code-assistance-3.16.0-lp151.2.3.x86_64.rpm
Source Package gedit-code-assistance-3.16.0-lp151.2.3.src.rpm

Install Howto

Install gedit-plugin-code-assistance rpm package:

# zypper install gedit-plugin-code-assistance

Files

Path
/usr/include/gedit-3.0/
/usr/include/gedit-3.0/gca/gca.h
/usr/lib64/gedit/plugins/codeassistance.plugin
/usr/lib64/gedit/plugins/libcodeassistance.so
/usr/lib64/gedit/plugins/gca/
/usr/lib64/gedit/plugins/gca/indent-backends/gcaindentbackendc.plugin
/usr/lib64/gedit/plugins/gca/indent-backends/libgcaindentbackendc.so
/usr/share/appdata/gedit-code-assistance.metainfo.xml
/usr/share/doc/packages/gedit-plugin-code-assistance/AUTHORS
/usr/share/doc/packages/gedit-plugin-code-assistance/COPYING
/usr/share/doc/packages/gedit-plugin-code-assistance/ChangeLog
/usr/share/doc/packages/gedit-plugin-code-assistance/README
/usr/share/gedit/plugins/codeassistance/codeassistance.css
/usr/share/vala/vapi/gca.vapi

Changelog

2015-04-30 - zaitor@opensuse.org
- Update to version 3.16.0:
+ Fix save followed by save instead of restore.
2015-03-23 - dimstar@opensuse.org
- Update to version 3.14.3:
+ Fix crash at exit when closing several documents.
2015-03-16 - dimstar@opensuse.org
- Update to version 3.14.2:
+ Fix problem loading indent backends with new libpeas.
2014-12-19 - zaitor@opensuse.org
- Update to version 3.14.1:
+ Fixes the vapi in the tarball (bgo#738981).
2014-12-14 - badshah400@gmail.com
- Update to version 3.14.0:
+ Add smart indentation.
+ Fix newline deletion bug.
+ Fix crash in diagnostics.
- Include additional files installed by upstream.
- Disable the generation of static library by passing
'--disable-static' option to %configure.
2014-04-05 - zaitor@opensuse.org
- Update to version 0.3.1:
+ Misc bugfixes.
2013-12-17 - zaitor@opensuse.org
- Update to version 0.3.0:
+ This release issues a major change in how gedit-code-assistance
works. The code-assistance backends have been refactored as
out-of-process dbus services in a new project called
gnome-code-assistance. The gedit-code-assistance project now
uses gnome-code-assistance services to provide code assistance
for gedit as a plugin.
- Drop fdupes, pkgconfig(pygobject-3.0) and pkgconfig(libpeas-1.0)
BuildRequires, not needed any more.
- Exchange pkgconfig(gee-1.0) for pkgconfig(gee-0.8) BuildRequires,
following upstreams port to gee-0.8.
- Drop subpackages typelib-1_0-Gcp-3_0 and
gedit-code-assistance-devel, not built anymore.
- Add gnome-code-assistance BuildRequires, new dependency.
2013-07-29 - dimstar@opensuse.org
- Build using clang/llvm instead of gcc by exoprting CC=clang: the
C backend is written with llvm in mind. Not switching the
compiler can cause configure to mis-detect the availability of
clang/llvm due to invalid gcc parameters.
2013-03-30 - zaitor@opensuse.org
- Update to version 0.2.0:
+ Ported to python 3.
+ Misc bugfixes.
2012-10-21 - zaitor@opensuse.org
- Update to version 0.1.5:
+ Fix the XML backend.
- Changes from version 0.1.4:
+ Added XML backend.
+ Added python backend.
+ Moved backends to peas based plugin system.
- Add pkgconfig(libpeas-1.0) and pkgconfig(pygobject-3.0)
BuildRequires, new dependencies.
- Add fdupes BuildRequires in order to be able to use %fdupes.
- Split out new subpackage typelib-1_0-Gcp-3_0, containing the new
gobject-introspection typelib.
- Split out new subpackages gedit-code-assistance-devel, as there
are newly headers installed.

See Also

Package Description
gedit-plugin-codecomment-3.28.1-lp151.2.2.x86_64.rpm Gedit codecomment plugin
gedit-plugin-colorpicker-3.28.1-lp151.2.2.x86_64.rpm Gedit colorpicker plugin
gedit-plugin-colorschemer-3.28.1-lp151.2.2.x86_64.rpm Gedit colorschemer plugin
gedit-plugin-commander-3.28.1-lp151.2.2.x86_64.rpm Gedit commander plugin
gedit-plugin-dashboard-3.28.1-lp151.2.2.x86_64.rpm Gedit dashboard plugin
gedit-plugin-devhelp-3.26.1-lp151.3.5.x86_64.rpm Devhelp plugin for Gedit
gedit-plugin-drawspaces-3.28.1-lp151.2.2.x86_64.rpm Gedit drawspaces plugin
gedit-plugin-findinfiles-3.28.1-lp151.2.2.x86_64.rpm Gedit Find In Files plugin
gedit-plugin-git-3.28.1-lp151.2.2.x86_64.rpm Gedit git plugin
gedit-plugin-joinlines-3.28.1-lp151.2.2.x86_64.rpm Gedit joinlines plugin
gedit-plugin-latex-3.20.0-lp151.2.1.x86_64.rpm GEdit Plugin for Editing LaTeX Documents
gedit-plugin-multiedit-3.28.1-lp151.2.2.x86_64.rpm Gedit multiedit plugin
gedit-plugin-smartspaces-3.28.1-lp151.2.2.x86_64.rpm Gedit smartspaces plugin
gedit-plugin-synctex-3.28.1-lp151.2.2.x86_64.rpm Gedit synctex plugin
gedit-plugin-terminal-3.28.1-lp151.2.2.x86_64.rpm Gedit terminal plugin
Advertisement
Advertisement