gasnet-devel-1.30.0-lp151.2.46.x86_64.rpm


Advertisement

Description

gasnet-devel - Development files for GASNet

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename gasnet-devel-1.30.0-lp151.2.46.x86_64.rpm
Package name gasnet-devel
Package version 1.30.0
Package release lp151.2.46
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://gasnet.lbl.gov
License PostgreSQL
Maintainer -
Download size 160.63 KB
Installed size 1.09 MB
GASNet is a language-independent, low-level networking layer that provides
network-independent communication primitives tailored for
implementing parallel global address space SPMD languages
such as UPC, Titanium, and Co-Array Fortran.
The interface is primarily intended as a compilation target and for
use by runtime library writers (as opposed to end users).
Development package for GASNet. Including header files and libraries.

Alternatives

Package Version Architecture Repository
gasnet-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
gasnet = 1.30.0
libgasnet-1_30_0 -

Provides

Name Value
gasnet-devel = 1.30.0-lp151.2.46
gasnet-devel(x86-64) = 1.30.0-lp151.2.46
pkgconfig(gasnet-ibv-par) = 1.30.0
pkgconfig(gasnet-ibv-parsync) = 1.30.0
pkgconfig(gasnet-ibv-seq) = 1.30.0
pkgconfig(gasnet-mpi-par) = 1.30.0
pkgconfig(gasnet-mpi-parsync) = 1.30.0
pkgconfig(gasnet-mpi-seq) = 1.30.0
pkgconfig(gasnet-ofi-par) = 1.30.0
pkgconfig(gasnet-ofi-parsync) = 1.30.0
pkgconfig(gasnet-ofi-seq) = 1.30.0
pkgconfig(gasnet-psm-par) = 1.30.0
pkgconfig(gasnet-psm-parsync) = 1.30.0
pkgconfig(gasnet-psm-seq) = 1.30.0
pkgconfig(gasnet-smp-par) = 1.30.0
pkgconfig(gasnet-smp-parsync) = 1.30.0
pkgconfig(gasnet-smp-seq) = 1.30.0
pkgconfig(gasnet-udp-par) = 1.30.0
pkgconfig(gasnet-udp-parsync) = 1.30.0
pkgconfig(gasnet-udp-seq) = 1.30.0
pkgconfig(gasnet_tools-par) = 1.30.0
pkgconfig(gasnet_tools-seq) = 1.30.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package gasnet-devel-1.30.0-lp151.2.46.x86_64.rpm
Source Package gasnet-1.30.0-lp151.2.46.src.rpm

Install Howto

Install gasnet-devel rpm package:

# zypper install gasnet-devel

Files

Path
/usr/include/gasnet.h
/usr/include/gasnet_ammacros.h
/usr/include/gasnet_asm.h
/usr/include/gasnet_atomic_bits.h
/usr/include/gasnet_atomicops.h
/usr/include/gasnet_basic.h
/usr/include/gasnet_coll.h
/usr/include/gasnet_config.h
/usr/include/gasnet_handler.h
/usr/include/gasnet_help.h
/usr/include/gasnet_membar.h
/usr/include/gasnet_portable_platform.h
/usr/include/gasnet_timer.h
/usr/include/gasnet_toolhelp.h
/usr/include/gasnet_tools-par.mak
/usr/include/gasnet_tools-seq.mak
/usr/include/gasnet_tools.h
/usr/include/gasnet_trace.h
/usr/include/gasnet_vis.h
/usr/include/portable_inttypes.h
/usr/include/portable_platform.h
/usr/include/ibv-conduit/firehose_trace.h
/usr/include/ibv-conduit/gasnet_coll_fwd.h
/usr/include/ibv-conduit/gasnet_core.h
/usr/include/ibv-conduit/gasnet_core_fwd.h
/usr/include/ibv-conduit/gasnet_core_help.h
/usr/include/ibv-conduit/gasnet_extended.h
/usr/include/ibv-conduit/gasnet_extended_fwd.h
/usr/include/ibv-conduit/gasnet_extended_help.h
/usr/include/ibv-conduit/gasnet_vis_fwd.h
/usr/include/ibv-conduit/ibv-par.mak
/usr/include/ibv-conduit/ibv-parsync.mak
/usr/include/ibv-conduit/ibv-seq.mak
/usr/include/mpi-conduit/ammpi.h
/usr/include/mpi-conduit/ammpi_portable_platform.h
/usr/include/mpi-conduit/gasnet_coll_fwd.h
/usr/include/mpi-conduit/gasnet_core.h
/usr/include/mpi-conduit/gasnet_core_fwd.h
/usr/include/mpi-conduit/gasnet_core_help.h
/usr/include/mpi-conduit/gasnet_extended.h
/usr/include/mpi-conduit/gasnet_extended_fwd.h
/usr/include/mpi-conduit/gasnet_extended_help.h
/usr/include/mpi-conduit/gasnet_vis_fwd.h
/usr/include/mpi-conduit/mpi-par.mak
/usr/include/mpi-conduit/mpi-parsync.mak
/usr/include/mpi-conduit/mpi-seq.mak
/usr/include/ofi-conduit/gasnet_coll_fwd.h
/usr/include/ofi-conduit/gasnet_core.h
/usr/include/ofi-conduit/gasnet_core_fwd.h
/usr/include/ofi-conduit/gasnet_core_help.h
/usr/include/ofi-conduit/gasnet_extended.h
/usr/include/ofi-conduit/gasnet_extended_fwd.h
/usr/include/ofi-conduit/gasnet_extended_help.h
/usr/include/ofi-conduit/gasnet_ofi.h
/usr/include/ofi-conduit/gasnet_vis_fwd.h
/usr/include/ofi-conduit/ofi-par.mak
/usr/include/ofi-conduit/ofi-parsync.mak
/usr/include/ofi-conduit/ofi-seq.mak
/usr/include/psm-conduit/gasnet_coll_fwd.h
/usr/include/psm-conduit/gasnet_core.h
/usr/include/psm-conduit/gasnet_core_fwd.h
/usr/include/psm-conduit/gasnet_core_help.h
/usr/include/psm-conduit/gasnet_core_list.h
/usr/include/psm-conduit/gasnet_extended.h
/usr/include/psm-conduit/gasnet_extended_fwd.h
/usr/include/psm-conduit/gasnet_extended_help.h
/usr/include/psm-conduit/gasnet_extended_internal_extra.h
/usr/include/psm-conduit/gasnet_vis_fwd.h
/usr/include/psm-conduit/psm-par.mak
/usr/include/psm-conduit/psm-parsync.mak
/usr/include/psm-conduit/psm-seq.mak
/usr/include/smp-conduit/gasnet_coll_fwd.h
/usr/include/smp-conduit/gasnet_core.h
/usr/include/smp-conduit/gasnet_core_fwd.h
/usr/include/smp-conduit/gasnet_core_help.h
/usr/include/smp-conduit/gasnet_extended.h
/usr/include/smp-conduit/gasnet_extended_fwd.h
/usr/include/smp-conduit/gasnet_extended_help.h
/usr/include/smp-conduit/gasnet_extended_help_extra.h
/usr/include/smp-conduit/gasnet_vis_fwd.h
/usr/include/smp-conduit/smp-par.mak
/usr/include/smp-conduit/smp-parsync.mak
/usr/include/smp-conduit/smp-seq.mak
/usr/include/udp-conduit/amudp_const.h
/usr/include/udp-conduit/amudp_portable_platform.h
/usr/include/udp-conduit/gasnet_coll_fwd.h
/usr/include/udp-conduit/gasnet_core.h
/usr/include/udp-conduit/gasnet_core_fwd.h
/usr/include/udp-conduit/gasnet_core_help.h
/usr/include/udp-conduit/gasnet_extended.h
/usr/include/udp-conduit/gasnet_extended_fwd.h
/usr/include/udp-conduit/gasnet_extended_help.h
/usr/include/udp-conduit/gasnet_vis_fwd.h
/usr/include/udp-conduit/udp-par.mak
/usr/include/udp-conduit/udp-parsync.mak
/usr/include/udp-conduit/udp-seq.mak
/usr/lib64/libammpi.so
/usr/lib64/libamudp.so
/usr/lib64/libgasnet-ibv-par.so
/usr/lib64/libgasnet-ibv-parsync.so
/usr/lib64/libgasnet-ibv-seq.so
/usr/lib64/libgasnet-mpi-par.so
/usr/lib64/libgasnet-mpi-parsync.so
/usr/lib64/libgasnet-mpi-seq.so
/usr/lib64/libgasnet-ofi-par.so
/usr/lib64/libgasnet-ofi-parsync.so
/usr/lib64/libgasnet-ofi-seq.so
/usr/lib64/libgasnet-psm-par.so
/usr/lib64/libgasnet-psm-parsync.so
/usr/lib64/libgasnet-psm-seq.so
/usr/lib64/libgasnet-smp-par.so
/usr/lib64/libgasnet-smp-parsync.so
/usr/lib64/libgasnet-smp-seq.so
/usr/lib64/libgasnet-udp-par.so
/usr/lib64/libgasnet-udp-parsync.so
/usr/lib64/libgasnet-udp-seq.so
/usr/lib64/libgasnet_tools-par.so
/usr/lib64/libgasnet_tools-seq.so
/usr/lib64/pkgconfig/gasnet-ibv-par.pc
/usr/lib64/pkgconfig/gasnet-ibv-parsync.pc
/usr/lib64/pkgconfig/gasnet-ibv-seq.pc
/usr/lib64/pkgconfig/gasnet-mpi-par.pc
/usr/lib64/pkgconfig/gasnet-mpi-parsync.pc
/usr/lib64/pkgconfig/gasnet-mpi-seq.pc
/usr/lib64/pkgconfig/gasnet-ofi-par.pc
/usr/lib64/pkgconfig/gasnet-ofi-parsync.pc
/usr/lib64/pkgconfig/gasnet-ofi-seq.pc
/usr/lib64/pkgconfig/gasnet-psm-par.pc
/usr/lib64/pkgconfig/gasnet-psm-parsync.pc
/usr/lib64/pkgconfig/gasnet-psm-seq.pc
/usr/lib64/pkgconfig/gasnet-smp-par.pc
/usr/lib64/pkgconfig/gasnet-smp-parsync.pc
/usr/lib64/pkgconfig/gasnet-smp-seq.pc
/usr/lib64/pkgconfig/gasnet-udp-par.pc
/usr/lib64/pkgconfig/gasnet-udp-parsync.pc
/usr/lib64/pkgconfig/gasnet-udp-seq.pc
/usr/lib64/pkgconfig/gasnet_tools-par.pc
/usr/lib64/pkgconfig/gasnet_tools-seq.pc
/usr/lib64/valgrind/gasnet.supp

Changelog

2017-10-05 - nmoreychaisemartin@suse.com
- Force load of MPI environment
- Use OpenMPI2 instead of OpenMPI1 except for ppc64be (unsupported by OpenMPI >= 2)
2017-09-06 - nmoreychaisemartin@suse.com
- Force timer to use POSIX RT instead of native, as native is not
precise enough in VM and causes validation to crash.
2017-09-01 - junghans@votca.org
- Version update to 1.30.0:
* InfiniBand Verbs (ibv-conduit)
- Improve the handling of GASNET_PHYSMEM_* env vars
* Libfabric (ofi-conduit)
- Fix bug 3426: Unbounded recursion within gasnetc_ofi_poll()
- Significant improvements to AM buffer management and wire header overheads
- Finer-grained control over AM buffering, see ofi-conduit/README
- Initialization cleanups for stricter compliance with the OFI specification
- Support for the Intel(R) True Scale Fabric provider, psm, has been removed.
The Intel(R) Omni-Path Fabric is still supported through the psm2 provider.
- We now recommend ofi-conduit for the Intel Omni-Path fabric.
- The conduit has been validated on libfabric version 1.5.0.
* Intel Omni-Path PSM2 (psm-conduit)
- This conduit is now DEPRECATED.
- Use of ofi-conduit with libfabric's psm2 provider is recommended for users
of the Intel Omni-Path fabric.
* GASNet tools
- Fix bug 3448: x86*/Linux timers once again default to use of the TSC due
to addition of new logic for correct calibration on newer Intel CPUs.
- Add gasnett_nsleep()
2017-08-11 - bwiedemann@suse.com
- Add gasnet-build-id.patch to fix build-compare (boo#1047218)
2017-06-30 - nmoreychaisemartin@suse.com
- Remove BuildRequires for libpsm2-compat
- Build with OFI support on x86
2017-06-09 - nmoreychaisemartin@suse.com
- Enable OFI conduit on x86_64
- Disable debug to build GASnet in optimized mode
- Add gasnet-date-time.patch to remove build date/times from binaries
- Add gasnet-s390-support.patch and enable s390/s390x builds
2017-06-08 - nmoreychaisemartin@suse.com
- Remove version dependency to libibverbs
2017-05-31 - nmoreychaisemartin@suse.com
- Build gasnet for all arch but s390*, s390x not supported by upstream:
https://upc-bugs.lbl.gov/bugzilla/show_bug.cgi?id=3523
- PSM2 support is only for x86_64
2017-05-16 - nmoreychaisemartin@suse.com
- Support gasnet over OFI and ibverbs
2017-04-07 - pth@suse.de
- Remove conflict marker.

See Also

Package Description
gasnet-doc-1.30.0-lp151.2.46.noarch.rpm Documentation for GASNet
gaupol-1.3.1-lp151.2.45.noarch.rpm GTK Subtitle editor
gavl-1.4.0rsvn4256-lp151.2.3.x86_64.rpm Library which provides basic support for uncompressed multimedia data
gawk-4.2.1-lp151.2.70.x86_64.rpm GNU awk
gbdfed-1.6-lp151.2.3.x86_64.rpm A Gtk-based BDF Font Editor, Descendant of XmBDFed
gbrainy-2.3.5-lp151.2.66.noarch.rpm A brain teaser game and trainer
gbrainy-lang-2.3.5-lp151.2.66.noarch.rpm Translations for package gbrainy
gc-devel-7.6.4-lp151.2.2.x86_64.rpm A garbage collector for C and C++
gcab-1.1-lp151.2.2.x86_64.rpm Cabinet file library and tool
gcab-devel-1.1-lp151.2.2.x86_64.rpm Development files for the gcab cabinet file library
gcab-lang-1.1-lp151.2.2.noarch.rpm Translations for package gcab
gcad3d-2.352+git20170420.b5668e9-lp151.2.3.x86_64.rpm 3D CAD-CAM application
gcal-4.1-lp151.2.3.x86_64.rpm A Program for Printing Calendars
gcal-lang-4.1-lp151.2.3.noarch.rpm Translations for package gcal
gcc-32bit-7-lp151.3.5.x86_64.rpm The system GNU C Compiler
Advertisement
Advertisement