gambas3-gb-vb-3.10.0-lp151.3.66.x86_64.rpm


Advertisement

Description

gambas3-gb-vb - The Visual Basic compatibility component for Gambas

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename gambas3-gb-vb-3.10.0-lp151.3.66.x86_64.rpm
Package name gambas3-gb-vb
Package version 3.10.0
Package release lp151.3.66
Package architecture x86_64
Package type rpm
Category Development/Tools/IDE
Homepage http://gambas.sourceforge.net/
License GPL-2.0-or-later
Maintainer -
Download size 23.33 KB
Installed size 12.12 KB
This component aims at including some functions that imitate the behaviour
of Visual Basic functions. Use it only if you try to port some VB
projects.

Alternatives

Package Version Architecture Repository
gambas3-gb-vb - - -

Requires

Name Value
gambas3-runtime = 3.10.0
libc.so.6(GLIBC_2.4)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -

Provides

Name Value
gambas3-gb-vb = 3.10.0-lp151.3.66
gambas3-gb-vb(x86-64) = 3.10.0-lp151.3.66
libtool(/usr/lib64/gambas3/gb.vb.la) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package gambas3-gb-vb-3.10.0-lp151.3.66.x86_64.rpm
Source Package gambas3-3.10.0-lp151.3.66.src.rpm

Install Howto

Install gambas3-gb-vb rpm package:

# zypper install gambas3-gb-vb

Files

Path
/usr/lib64/gambas3/gb.vb.component
/usr/lib64/gambas3/gb.vb.la
/usr/lib64/gambas3/gb.vb.so
/usr/lib64/gambas3/gb.vb.so.0
/usr/lib64/gambas3/gb.vb.so.0.0.0
/usr/share/gambas3/info/gb.vb.info
/usr/share/gambas3/info/gb.vb.list

Changelog

2018-04-18 - mpluskal@suse.com
-  Drop sqlite2 support as it is being obsoleted
2018-03-06 - lars@linux-schulserver.de
- use %license macro
- use spdx 3.0 license string
2017-12-11 - avvissu@yandex.by
- Fix build on Factory (add pkgconfig({ice,sm}))
2017-12-10 - avvissu@yandex.by
- Rebase bconds
- Add gb-openal package
- [Fixed] E: summary-not-capitalized
- Update description for: gb-args, gb-option, gb-xml-rpc
- Spec file cleanup
2017-12-09 - avvissu@yandex.by
- Build with the --disable-qt4 option on Factory
- Add gambas3-3.10.0-disable-qt4.patch (bnc#1072031)
- Drop gambas3-gb-chart (only qt4 version)
- Add pkgconfig(poppler-qt{4,5})
2017-12-07 - dimstar@opensuse.org
- Escape the usage of %{VERSION} when calling out to rpm.
RPM 4.14 has %{VERSION} defined as 'the main packages version'.
2017-09-19 - zaitor@opensuse.org
- Add gambas3-adapt-to-poppler-058.patch: Adapt to poppler 0.58 api
changes.
- Drop obsolete and unused pkgconfig(webkit-1.0) BuildRequires.
2017-08-28 - zaitor@opensuse.org
- Pull in tarball from upstream again to please Factory source
checker bots, as a new tarball with same version was uploaded
2017-07-19 - avvissu@yandex.by
- Update to 3.10.0:
* see: http://gambaswiki.org/wiki/doc/release/3.10.0
- Add component gambas3-gb-term
- Drop gambas3-3.9.2-gcc7.patch
- Rename and rebase gambas3-3.9.2-llvm.patch to
gambas3-3.10.0-llvm.patch
- Spec file cleanup
2017-06-04 - avvissu@yandex.by
- Build with gcc7 (gambas3-3.9.2-gcc7.patch)

See Also

Package Description
gambas3-gb-web-3.10.0-lp151.3.66.x86_64.rpm The CGI web component for Gambas
gambas3-gb-web-feed-3.10.0-lp151.3.66.x86_64.rpm The component to generate and parse RSS documents
gambas3-gb-web-form-3.10.0-lp151.3.66.x86_64.rpm The CUI web component for Gambas
gambas3-gb-xml-3.10.0-lp151.3.66.x86_64.rpm XML tools for Gambas
gambas3-gb-xml-rpc-3.10.0-lp151.3.66.x86_64.rpm The XML-RPC protocol implementation for Gambas
gambas3-gb-xml-xslt-3.10.0-lp151.3.66.x86_64.rpm libxml-based XSLT tools for Gambas
gambas3-ide-3.10.0-lp151.3.66.x86_64.rpm The Gambas Development Enviroment
gambas3-runtime-3.10.0-lp151.3.66.x86_64.rpm The Gambas runtime
gambas3-script-3.10.0-lp151.3.66.x86_64.rpm Program that allows to write script files in Gambas
gamin-devel-0.1.10-lp151.2.4.x86_64.rpm Libraries and includes to build against gamin
gamin-server-0.1.10-lp151.2.4.x86_64.rpm Server for the Library providing the FAM File Alteration Monitor API
gammaray-2.10.0-lp151.1.14.x86_64.rpm Introspection/Debugging Tool for Qt Applications
gammaray-devel-2.10.0-lp151.1.14.x86_64.rpm Introspection/Debugging Tool for Qt Applications
gammu-1.39.0-lp151.2.6.x86_64.rpm Mobile phone management utility
gammu-devel-1.39.0-lp151.2.6.x86_64.rpm Development files for Gammu
Advertisement
Advertisement