gambas3-gb-gui-3.10.0-lp151.3.66.x86_64.rpm


Advertisement

Description

gambas3-gb-gui - The Qt/GTK loader component for Gambas

Property Value
Distribution openSUSE Leap 15.1
Repository openSUSE Oss all
Package filename gambas3-gb-gui-3.10.0-lp151.3.66.x86_64.rpm
Package name gambas3-gb-gui
Package version 3.10.0
Package release lp151.3.66
Package architecture x86_64
Package type rpm
Category Development/Tools/IDE
Homepage http://gambas.sourceforge.net/
License GPL-2.0-or-later
Maintainer -
Download size 113.30 KB
Installed size 479.08 KB
This is the component that just loads gb.qt if you are running KDE or
gb.gtk in the other cases. It is used to make your application more
desktop-friendly.

Alternatives

Package Version Architecture Repository
gambas3-gb-gui - - -

Requires

Name Value
/usr/bin/env -
gambas3-runtime = 3.10.0
libc.so.6(GLIBC_2.4)(64bit) -

Provides

Name Value
gambas3-gb-gui = 3.10.0-lp151.3.66
gambas3-gb-gui(x86-64) = 3.10.0-lp151.3.66
libtool(/usr/lib64/gambas3/gb.gui.la) -
libtool(/usr/lib64/gambas3/gb.gui.opengl.la) -
libtool(/usr/lib64/gambas3/gb.gui.qt.la) -
libtool(/usr/lib64/gambas3/gb.gui.qt.webkit.la) -
libtool(/usr/lib64/gambas3/gb.gui.trayicon.la) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package gambas3-gb-gui-3.10.0-lp151.3.66.x86_64.rpm
Source Package gambas3-3.10.0-lp151.3.66.src.rpm

Install Howto

Install gambas3-gb-gui rpm package:

# zypper install gambas3-gb-gui

Files

Path
/usr/lib64/gambas3/gb.gui.base.component
/usr/lib64/gambas3/gb.gui.base.gambas
/usr/lib64/gambas3/gb.gui.component
/usr/lib64/gambas3/gb.gui.la
/usr/lib64/gambas3/gb.gui.opengl.component
/usr/lib64/gambas3/gb.gui.opengl.la
/usr/lib64/gambas3/gb.gui.opengl.so
/usr/lib64/gambas3/gb.gui.opengl.so.0
/usr/lib64/gambas3/gb.gui.opengl.so.0.0.0
/usr/lib64/gambas3/gb.gui.qt.component
/usr/lib64/gambas3/gb.gui.qt.la
/usr/lib64/gambas3/gb.gui.qt.so
/usr/lib64/gambas3/gb.gui.qt.so.0
/usr/lib64/gambas3/gb.gui.qt.so.0.0.0
/usr/lib64/gambas3/gb.gui.qt.webkit.component
/usr/lib64/gambas3/gb.gui.qt.webkit.la
/usr/lib64/gambas3/gb.gui.qt.webkit.so
/usr/lib64/gambas3/gb.gui.qt.webkit.so.0
/usr/lib64/gambas3/gb.gui.qt.webkit.so.0.0.0
/usr/lib64/gambas3/gb.gui.so
/usr/lib64/gambas3/gb.gui.so.0
/usr/lib64/gambas3/gb.gui.so.0.0.0
/usr/lib64/gambas3/gb.gui.trayicon.component
/usr/lib64/gambas3/gb.gui.trayicon.la
/usr/lib64/gambas3/gb.gui.trayicon.so
/usr/lib64/gambas3/gb.gui.trayicon.so.0
/usr/lib64/gambas3/gb.gui.trayicon.so.0.0.0
/usr/share/gambas3/info/gb.gui.base.info
/usr/share/gambas3/info/gb.gui.base.list
/usr/share/gambas3/info/gb.gui.info
/usr/share/gambas3/info/gb.gui.list
/usr/share/gambas3/info/gb.gui.opengl.info
/usr/share/gambas3/info/gb.gui.opengl.list
/usr/share/gambas3/info/gb.gui.qt.info
/usr/share/gambas3/info/gb.gui.qt.list
/usr/share/gambas3/info/gb.gui.qt.webkit.info
/usr/share/gambas3/info/gb.gui.qt.webkit.list
/usr/share/gambas3/info/gb.gui.trayicon.info
/usr/share/gambas3/info/gb.gui.trayicon.list

Changelog

2018-04-18 - mpluskal@suse.com
-  Drop sqlite2 support as it is being obsoleted
2018-03-06 - lars@linux-schulserver.de
- use %license macro
- use spdx 3.0 license string
2017-12-11 - avvissu@yandex.by
- Fix build on Factory (add pkgconfig({ice,sm}))
2017-12-10 - avvissu@yandex.by
- Rebase bconds
- Add gb-openal package
- [Fixed] E: summary-not-capitalized
- Update description for: gb-args, gb-option, gb-xml-rpc
- Spec file cleanup
2017-12-09 - avvissu@yandex.by
- Build with the --disable-qt4 option on Factory
- Add gambas3-3.10.0-disable-qt4.patch (bnc#1072031)
- Drop gambas3-gb-chart (only qt4 version)
- Add pkgconfig(poppler-qt{4,5})
2017-12-07 - dimstar@opensuse.org
- Escape the usage of %{VERSION} when calling out to rpm.
RPM 4.14 has %{VERSION} defined as 'the main packages version'.
2017-09-19 - zaitor@opensuse.org
- Add gambas3-adapt-to-poppler-058.patch: Adapt to poppler 0.58 api
changes.
- Drop obsolete and unused pkgconfig(webkit-1.0) BuildRequires.
2017-08-28 - zaitor@opensuse.org
- Pull in tarball from upstream again to please Factory source
checker bots, as a new tarball with same version was uploaded
2017-07-19 - avvissu@yandex.by
- Update to 3.10.0:
* see: http://gambaswiki.org/wiki/doc/release/3.10.0
- Add component gambas3-gb-term
- Drop gambas3-3.9.2-gcc7.patch
- Rename and rebase gambas3-3.9.2-llvm.patch to
gambas3-3.10.0-llvm.patch
- Spec file cleanup
2017-06-04 - avvissu@yandex.by
- Build with gcc7 (gambas3-3.9.2-gcc7.patch)

See Also

Package Description
gambas3-gb-httpd-3.10.0-lp151.3.66.x86_64.rpm The httpd component for Gambas
gambas3-gb-image-3.10.0-lp151.3.66.x86_64.rpm The image component for Gambas
gambas3-gb-image-effect-3.10.0-lp151.3.66.x86_64.rpm Image filtering routines for Gambas
gambas3-gb-image-imlib-3.10.0-lp151.3.66.x86_64.rpm Gambas image routines based on the Imlib2 library
gambas3-gb-image-io-3.10.0-lp151.3.66.x86_64.rpm IO operations with images based on gdk-pixbuf for Gambas
gambas3-gb-inotify-3.10.0-lp151.3.66.x86_64.rpm Filesystem event monitoring for Gambas
gambas3-gb-libxml-3.10.0-lp151.3.66.x86_64.rpm The libxml component for Gambas
gambas3-gb-logging-3.10.0-lp151.3.66.x86_64.rpm The Gambas logging component
gambas3-gb-maps-3.10.0-lp151.3.66.x86_64.rpm Map display for Gambas applications
gambas3-gb-markdown-3.10.0-lp151.3.66.x86_64.rpm Gambas Markdown syntax
gambas3-gb-media-3.10.0-lp151.3.66.x86_64.rpm Gambas interface to the GStreamer library
gambas3-gb-memcached-3.10.0-lp151.3.66.x86_64.rpm The memcached component for Gambas
gambas3-gb-mime-3.10.0-lp151.3.66.x86_64.rpm MIME message encoder and decoder for Gambas
gambas3-gb-mysql-3.10.0-lp151.3.66.x86_64.rpm MySQL specific routines for Gambas
gambas3-gb-ncurses-3.10.0-lp151.3.66.x86_64.rpm The ncurses component for Gambas
Advertisement
Advertisement